Drobo

iTunes sharing and DroboShare connection issue...

Recently I reformatted my Drobo to EXT3 for usage with several Macs and a DroboShare. It was previously formatted as HFS+. In the past when connecting from my Macbook Pro to my Mac Mini (which contains the iTunes library via DroboShare) via iTunes home sharing I would have no issues connecting at all. Now since the reformat trying to connect to the Mac Mini’s iTunes library via iTunes home sharing causes the Mac Mini’s iTunes to say “not responding”. I have tried turning off home sharing and using normal iTunes sharing and this has not cause the issue to go away. I have also rebooted all machines involved – including the DroboShare. Anyone else seeing this? I’m thinking of rebuilding the iTunes library on the Mini via Netatalk instead of over Samba. Another solution might be to revert to iTunes 9, which I know worked in the past. Reformatting back to HFS+ is not an option.

OK… thus far I’ve figured out that by deleting my iTunes library and mounting an AFP share via Netatalk (Backmyfruitup) and recreating the library with the AFP mount instead of SMB mount I can successfully connect to that library via iTunes Home Sharing. The next step is to rebuild the library via normal SMB mount and seeing if it was a corrupt library at work. If not it might be an issue with SMB and iTunes 10.