Drobo

iSCSI on Lion Broken

FYI, just upgraded to the Lion GM seed and my DroboPro connected via iSCSI dropped off within about 1-2 hours after upgrading. Switched to FW800 for now until Drobo can fix this.

Well, it seems I lost connection even on FW800 so be warned about running Lion with a Drobo!


I’m hearing other reports about Lion updates breaking connections
on other devices as well. (HP Mediasmart/MAC backups). Just be
aware it may not be Drobo at fault here.

Been running my Drobo with Lion since the 3rd beta release. No problems, no drops for me. I am connecting via FW800.

That’s great, but do you have problems connecting via iSCSI.

You’ll need to include more information to be taken seriously. I’ve gotten trouble tickets that say basically “it’s broken when will you fix it!!” We used to print those and tape them up next to the Dilbert comics.

Here’s an example of the sort of detail I mean:

  • history before upgrading (how long did this work before, did you have problems, etc)
  • what else changed besides the OS
  • what iSCSI initiator you’re using
  • the steps you’ve taken to eliminate other components (NIC, cabling, switch, port settings, ethernet settings) as possibly involved
  • what steps you’ve taken to attempt to fix the problem
  • how you configured iSCSI
  • if you’ve tested from other computers or other operating systems
  • what you’ve tested so far (e.g. did you just test iSCSI and say screw it when it didn’t work, or did you test audio, USB, other network connections…)
  • if there are any other problems

What did you write in the bug report you filed with Data Robotics?

Agreed, point taken. The only thing that changed was the OS, I was using whatever was the default initiator. I had the auto configure IP setting for the iSCSI setup. It also happened on FW800 after the first drop on iSCSI. I could go on with more information but right now after upgrading to 2.0.2 Dashboard and running on FW800 it’s been up since yesterday. I haven’t tried iSCSI yet. I thought I’d let it run on FW800 for a few days and see how stable it is before trying iSCSI again. I’ll report back.

FYi, I had major problems with Dashboard 2.0.2 (and the initiator that comes with it) and my DROBO Pro via iSCSI.

It was confirmed with tech support that 2.0.2 should not be used with DroboPro.

I was having all sorts of disconnects and volume corruption using 2.0.2 on a Mac Pro running 10.6.8

Removed 2.0.2 and installed 1.8.4 and all my problems went away.

I’ve had no problem with FW800 and Lion.

The Dashboard wouldn’t even install on any build of Lion, until the 2.0.2 update.

You might want to look in the top level of the HDD where the Applications, Developer, Library, System, and Users folders are located. When I upgraded to the GM seed Lion created a folder with incompatible software at the top level. Some of it was drivers I used for other devices. Once I reinstalled them they worked just fine with Lion.

All that is to say maybe Lion removes something that Dashboard needs to work properly. Perhaps try a reinstall of the Dashboard.

Another iSCSI connection issue report here.

Running a on a Core 2 Duo Mac Mini with 10.6.8 originally. Upgraded Dashboard to 2.0.3 first. Then upgraded from Snow Leopard to Lion a few days later.

The Mini has two Drobo 2.0’s attached via FW800 and the DroboPro via iSCSI. All are the latest firmware. The Pro disconnects randomly. My FW800 devices stay connected.

I moved the Pro over to FW800. That seems to work OK but the performance sharing with two Drobo’s is not what I’m used to. I backup from the Pro to one of the Drobo’s and the other Drobo is very busy too.

Hopefully Drobo or Apple (or both) will have a fix for us soon.

I am also having a Drobo 1st Gen and a DroboPro. The Drobo remains connected all the time via USB with no disconnection where DroboPro started disconnecting and entering standby by itself when connected via iSCSI on a Cisco 3560G switch. Support has not been able to pinpoint the issue yet but asked me to try a different switch and a different ethernet cable. I have not managed to perform these tests yet as I am backing up the most important contents of my DroboPro to my old Drobo just to be safe. I am concerned though that the problem is not the cable or the switch as DroboPro was working fine via iSCSI before the upgrade to Lion and Drobo Dashboard 2.0.3.
So now I am using it using the FW800 connection to my MacBookPro.

Forget about recabling, trying other ports and what not. DroboPro iSCSI is definitely broken on Lion. No matter what DataRobotocs will tell you.

I escalated my issue with them and after working more than a month on the support ticket, they will now send me a replacement unit. I doubt that will help. This is clearly a software issue.

Even though I’ve upgraded my Mac laptops to Lion, I’m still sticking to SL on my desktop because I do not want to see iSCSI problems. I’m already having problem with DroboDashboard 2.0.3 seeing the drobo, so I’ve been using the GlobalSAN iSCSI initiator for a month now. The connection is rock solid and in the past month I have 0 disconnection. But the current GlobalSAN initiator is not compatible with Lion yet and they are working on it. So until then, I will not upgrade to Lion on my Mac desktop.

Unless someone want to share how good the $200 ATTO iSCSI initiator is working for them, then I might consider buying it. I didn’t want to but I might have to because it’s just a pain in the a** when DroboDashboard decide to not work with my DroboPro on random days while other initiators are rock solid. Make me wonder if DataRobotics is still profitable selling hardware with problematic iSCSI initiators, especially in their high-end business units. The DroboDashboard is simply an unacceptable piece of software and I don’t see them fixing it in the near future. All they do is give you a replacement on the hardware where the software is the main culprit.

As soon as the Mac Pro will come out with Thunderbolt, I will kiss Drobo goodbye and get one of those Pegasus boxes. I’ve had enough of this Drobo.

I just got the Pegasus box.
Great improvement! :slight_smile:

JO

This is 100% a problem with the Drobo Dashboard / iSCSI Initiator. I have an open case with Drobo. Response from Support has been:

and:

As of August 9th. Using the Drobo Pro with FW800 works fine, and is solid.

If one feels like spending $200 on the ATTO iSCSI Initiator, that also works.

It’s sad that Lion has been in development & available to developers for many months now, yet the Data Robotics software development team couldn’t check & bring up to compatibility with Lion.

Neither could they see fit to update their support pages to indicate that the Drobo iSCSI Initiator was not tested / does not work with Lion.

You guys might want to read this - it applies to Lion Server which is where I had the issue. Could well set you on the right path though.

https://discussions.apple.com/message/15900127[hr]

Just posted a version of Drobo Dashboard with a new iSCSI initiator that has better support for OS X Lion. Please give it a shot if you are using a DroboPro with an iSCSI connection.
http://www.drobospace.com/forums/showthread.php?tid=3487

Sorry for the troubles. Hopefully the new solution works well for you.

-ErikP
Drobo

It connected via iSCSI once for me for about ten seconds and then the drobopro rebooted. Haven’t been able to connect since. Have to go to work now so won’t be able to mess around with it.

I tried the new 2.0.4 on my DroboPro this afternoon. It did not work right away for me, but I got it after fiddling a little with the settings.

What I did:

  1. Disconnect and turn off Drobo. Uninstalled the GlobalSAN iSCSI initiator that I’ve been using for quite some time since beginning of this year. I’ve grew tired Drobo Dashboard’s initiator disconnecting every few hours. I have to say, I almost bought the ATTO iSCSI initiator, but held off eventually. FW800 is too slow comparing to iSCSI, so I didn’t bother using it.

  2. Installed drobo dashboard 2.0.4 (with ATTO iSCSI initiator, YES! finally something worth using).

  3. Drobo Dashboard did not discover the DroboPro. I turned off the DroboPro. Directly connected with FW800.

  4. Dashboard sees drobo via FW800. Go into Drobo Dashboard Settings and changed the static IP address I set for my DroboPro. In my case I had it as 192.168.3.3. I changed it to 192.168.1.4 and click SAVE. DroboPro had to restart to take it IP address change.

  5. Once my DroboPro completed the startup process (still connected via FW800), I changed the IP back to what it was before 192.168.1.3 and clicked SAVE and have DroboPro restart itself.

  6. When I see my DroboPro (FW800) disappeared and disconnected from the Desktop, and the lights on the DroboPro were gone. I disconnected the FW800 and plug the ethernet cable back.

  7. DroboPro started to turn on and the lights started to go up one by one. Then few minutes later, DroboPro (via iSCSI) appears on my Desktop. I opened up the Drobo Dashboard, it is not able to see DroboPro via iSCSI.

So far so good and no disconnection yet, but we’ll see after a week or so.