Drobo

iSCSI for old DroboPro's on old Apple server systems

#1

Hi everybody,

this post will give some info’s and leave some questions. First of all, I work in the support business for Apple product’s since more then 20 years, so this post is not from a newbie, ok :wink:

I and some of my clients use Drobo products since many years. Most of them are slow, but very reliable when it comes to storing big amounts of data. Especially photographers appreciate the Drobo RAID systems, because they are less noisy and can be placed in office environments. And they run forever. I even experienced a lot less hard drive failures then in other RAID systems. I don’t no why, but it just is like that.

Lately I installed an DroboPro, 8 bay, on a clients server and couldn’t connect it through iSCSI. I didn’t had the time to dig in further, so I just connected it through FireFire. Run’s ok like that.
But a few days ago, my storage server, still running on an G5 with OS X 10.5.8 server, got a broken mainboard. I thought no problem, I just replace it with another old MacPro 1,1 and OS X 10.6.8 server. Set it up and tried to connect the 2 DroboPro’s that I have through iSCSI. Of course the IP’s and the network remained the same. No chance, the DroboPro’s simply won’t connect. I tried all the tricks and hint’s I could find in the forum, through Google etc., also contacting the official Drobo support. Well, as aspected, they don’t like to help on product’s that are EOL (end of lifetime) and actually on my opinion have a very limited knowledge about there product’s. So up to this point, I believe there is no way at all, to connect a DroboPro through iSCSI to any kind of Apple server system above OS X 10.5.8 !!!

iSCSI connection runs well with: OS X server 10.5.8, Drobo Dashboard 1.7.3, DroboPro Firmware 1.2.3
iSCSI connection won’t run at all on: OS X server 10.6.8, Drobo Dashboard 2.2.1, DroboPro Firmware 1.2.3

For myself I was able to get another G5 and I can run the 2 DroboPro’s now again with iSCSI under OS X 10.5.8 server. I know, it is old, but why through away 2 DroboPro’s fully equipped with 3TB or 4TB hard drives that are still serving well as storage systems? The main reason, why I need to connect through iSCSI is, that one of the DroboPro’s is in the basement as a backup system, the other one in the office as a storage system. That’s a perfect way for us to be protected against robbery, in case someone will break in to the main office. And why through something, that runs so well?

Anyone with similar experience?

Best regards,
Mathias

#2

Hi everybody,

I tried all different kinds of combination since a couple of weeks ago. The Drobo support isn’t helpful at all, I only got ridiculous answers. There are only 2 ways to solve it:

  1. keep running OS X 10.5.8 server. There is a PPC version for G5 or a Intel version for the MacPro, both work with the Drobo Pro’s and the iSCSI initiator software / Drobo Dashboard.
  2. Upgrade to 10.11.6 and use the ATTO Xtend SAN software. Expensive, but it works.

I totally love the old Drobo Pro’s and see no reason to through them away. They are still good for storage and backup systems.

By the way: I tried all OS X systems: 10.5.8, 10.6.8, 10.7.5, 10.8.5, 10.9.5, 10.10.5, 10.11.6. None of them worked for me with the Drobo Pro iSCSI software. 10.5.8 is really the last system that supports iSCSI native.

Cheers,
Mathias