Is it possible Drobo doesn't know that it has a bad drive? (& my Drobo won't mount)

I came home from Christmas break to find that my Drobo will not mount to my Macbook. It was still labeled as “Drobo” in Disk Utility and the Drobo Dashboard reports everything is fine. All of the lights are green and the blue lights are where they should be in relation to the amount of data I’ve used on the drives.

When I initially connected the Drobo to my Mac, I didn’t know anything was wrong, but I did notice that it was at work doing something. I ran repair disk overnight which, I believe, told me it couldn’t do anything for me.

I put the Drobo into Standby and reconnected it with a USB cable (it has always been connected via firewire 800). It still didn’t mount, but this time the drive was labeled “disk1s2” in Disk Utility and running another scan told me that there was an “Invalid B-Tree Node Size”.

I’m currently running a Disk Warrior rebuild which has been “Step 5: Locating Directory Data” for about 12 hours now. DW is reporting that “Speed reduced by disk malfunction: 61”

I have read on other sites and forums that this is a sign of a bad disk drive and that DW is likely to come back and say it cannot rebuild the disk. If this is true, why isnt Drobo just rebuilding itself with the good drives?

Or is it likely the drives are all good and Im dealing with a directory issue?

Most “bad drive” errors from disk utilities don’t necessarily apply to abstracted devices like Drobo.
It sounds like it’s more a problem with the data stored on the Drobo, rather than the drives themselves.

It also could be that you have a drive that is going bad (has recoverable errors), but has not yet gone bad (has unrecoverable errors). DRI would need to diagnose that by looking at your logs though.

In the time that has passed I have run a Disk Warrior rebuild twice, once with Firewire 800 and once with USB 2.0, each scan taking about a 1.5 days. Both times I received this dialog box:

I am running Mac OS X 10.6.5 and DiskWarrior 4.2, the newest versions of each. The only difference in the scans I could tell was the second time it only found 59 Disk malfunctions instead of 61.

I have also tried TechTools which, when trying to rebuild, only takes a few seconds and says everything is fine. Disk Utility still says “Invalid B-Tree Node Size” when scanned and no longer attempts to repair the disk when I try to. Drobo Dashboard still shows that everything is good. All lights on the Drobo itself are normal.

So, I’ve been thinking about running Data Rescue 3 on the drive to pull everything I could from it. But, a quick scan immediately produces an error and I will have to run the Deep Scan which takes 3 minutes per gigabyte. If it only needs to scan the actual data I have on my Drobo (1.18 TB) Im ok with that, but if it has to scan the Volume, which it thinks is about 17.5 TB, this will take over a month to complete.

I have had a Data Robotics support ticket open for part of the process, and I sent my logs. The first recommendation was to try DW on firewire, which is now completed. After trying everything above, I asked what my logs showed. I was then told,

[quote]The log is showing that the drive in bay 2 is in danger of failure, and could be causing issues with your Drobo. Please replace it as soon as possible.

Drive: WD-WCASY1716287 WDCWD6400AAKS-00A7B0 01.03B01
Slot : 2
FULL timeout : 3[/quote]

If I pull and replace this drive, will it rebuild with a correct directory structure? Maybe this would get rid of the bad drive, and then I could run DW again to rebuild the directory, but the previous DW errors point to an issue with version of the software?

Thanks for any advice. Im trying to figure out what would be my best move here to save my data.

[quote=“Cameron, post:3, topic:2132”]Im trying to figure out what would be my best move here to save my data.


Drobo’s Thin Provisioning can confuse standard disk utilities, so there is a possibility of turning a recoverable situation into an unrecoverable one.

Think of it like trying to fix a home electrical problem - there are people who can fix it on their own without making a mess of things, but it’s best to consult with an expert first to avoid unfortunate results.

Thanks for you response, I have contacted DRI support as noted above, but was looking for a confirmation or second opinion. The communication between DRI and me have been slow and Im doing all I can myself to learn about best methods.

My main concern was that if the drive is bad, and I replace it, will that even fix the directory problems? Maybe someone like yourself had run into a similar problem in the past and could help.

If the problem is a bad drive, it is very UNlikely to fix any directory corruption issue.

If you think of your files like a physical document, there’s

  1. The words
  2. The paper the words are written on

Your files are the words, and the hard drives in Drobo is the paper.

Drobo keeps the paper safe, but it doesn’t know about or care about the words.

Now let’s say you’re writing down a recipe (a really important one)…
You make a mistake while writing the recipe and put in “10 cups flour” instead of “1 cup flour”

You walk away, and your dog eats half the paper.
Drobo reconstructs the missing half of the paper.

But the recipe is still wrong, because it was written wrong.
Drobo doesn’t know what the “right” recipe is - just what was there before your dog ate half the paper.

So, it’s your operating system’s responsibility to maintain the filesystem and its data. Drobo just ensures the filesystem and its data is still there - correct or not - in the event of a drive failure.

I had this exact situation greet me a few days ago. It’s the second time it’s happened. Drobo Dashboard shows everything is OK, yet OSX doesn’t see the volume. In my digging around, I found some threads on firmware issues with some Seagate drives from the 2008 time frame. Turns out all 4 of my drives need new firmware. This issue was described as the drive would report the correct size and % full to the OS, but the directory information was hosed up. The data was still on the drive, but wasn’t being passed for some reason. Info can be found at I still don’t know if this was the root cause or not but the drives have been removed in favor of some WD20EADS drives.

One other thing I’m still researching is the inability to format the Drobo when my MBP is booted from a FW drive. My internal drive failed a couple days ago and I restarted the machine from an external FW drive I use for SuperDuper backups. The drobo is also hooked up to FW 800. Even when reset to factory settings, the format process always failed. Got a message about Drobo Dashboard couldn’t format the drive. Restart Dashboard and try again. That never worked.

I finally opened up the MBP and moved my backup drive into the MBP. After restarting, Drobo Dashboard was able to format the new drives and it’s been working fine since. Once formatted, accessing the Drobo when booted from a FW drive seems to work, but I’m still trying combinations of things to narrow down the scenario…