Is Drobo 5D compatible with Yosemite ?

Hi there,

I am on Mac currently running on Maverick. My Drobo 5D is running fine. Both my Drobo Dashboard and firmware are the latest. And no issues with the Drobo 5D on my Maverick.

In order to test whether Drobo 5D is compatible with Yosemite before I totally wipe out Maverick and replace it with Yosemite, I install Yosemite on an external 3TB Harddisk.

The problem I am facing with Drobo 5D in Yosemite is that the Drobo 5D cannot be detected. I have gone to the General tab and tick the external HD.

When I did a check using Terminal using “diskutil list”, no Drobo 5D was detected.

I also went to Disk Utility but the Drobo 5D was also not seen to be connected.

I then went to Apple Menu > System Report > Hardware to check and this is the results:

Under Hardware > Storage, all external hardest was detected except the Drobo 5D. I cannot find the Drobo 5D.

But Under Hardware > Thunderbolt > Thunderbolt Bus, the 5D was detected.

Please note that in Maverick it was detected in both

Hardware > Storage as well as

Hardware > Thunderbolt > Thunderbolt Bus

but in Yosemite the 5D was ONLY detected in Hardware > Thunderbolt > Thunderbolt Bus and NOT in Hardware > Storage

Some info on the Thunderbolt Bus are as follows:

Port (Upstream):
Status: Device Connected

Status: No device connected
Link Status: 0x7

Question 1:
Based on the above, any tips on how to get it connected ? Desperately need help here

Question 2:
Can the Drobo 5D be detected and causes error if the Yosemite is boot up from an external HDD instead of the Mac’s internal drive ?


I have a Gen2, Gen3 and 5D working perfectly with 10.10.3 on a Mini Server.

Dashboard 2.6.7 and latest firmware.

Thanks mgriffin,

Do you know whether my issues could be because I install the Yosemite on an external HDD ?

For your info, when I switch back to boot up Maverick from my internal Mac drive, the Drobo 5D can be detected as per normal …


I’m also on 10.0.3 using a 5D. No issues whatsoever.

If I were you, I would install Yosemite on the internal drive to rule out a bug with the external install. Just be sure you have a backup, preferrably in addition to the Drobo.

Thanks jaycarroll,

Would it help if i create 2 partitions in the internal drive, one with current Maverick and one with the new Yosemite. Then i run and boot up Yosemite from the internal drive in the new partition… Will that work?


Oh sure, that’ll work, provided you have enough space. I really don’t see any issue with you using the 5D with Yosemite, but it’s always good to be cautious.

Hi mcgriffin and jaycarroll,

Can i know when you used your Drobo with Yosemite, whether you upgrade your Yosemite from Maverick or you just started from Yosemite?

If you upgrade from Maverick, can the Drobo be detected straight away or you have to install some softwares ?

I read somewhere that for Yosemite, you have to install some kernel software? Is that true ? Did you install that Kernel thing ?


I upgraded to Yosemite with the first available beta, never had to do anything special with the Drobo. I’m using a 2012 Mac Mini.

I upgraded from 10.9 to 10.10.

I had issues with my Drobo 5D and Yosemite with Thunderbolt at first too… I’m not sure what I did different, but everything worked properly after going from 10.10.2 -> 10.10.3.
I used to have the exact same issue with it showing up unter the system profile under Thunderbolt, but wouldn’t initialize as a disk or under the Drobo dashboard. I’ll look into it to see if I can figure out what exactly is different.
(BTW, it’s actually a Hackintosh that I’m on with the Asus ThunderboltEXII card, and it works great)