Interesting Connection Problem...

Today, I developed an interesting connection problem with my Drobo 5N.
Firmware 3.2.2 and Drobo Dashboard 2.6.8 on OS X 10.10.3

My iMac has no problem connection to by Drobo.
My MacBook Pro can’t connect, no matter what I do — very reminiscent of most of the connection issues that I am reading about here, BUT one of my Macs has no issue, and one cannot connect at all - and I have uninstalled the Drobo Desktop software multiple times, to no avail. All other network connectivity issues seem okay. I am getting the “lost connection to the Drobo Desktop Service” dialog box as well.

The whole thing is very peculiar.

Intermittent NIC or faulty cable perhaps?

Strange this would only happen on one Mac, you can check:

  • Firewall, make sure DDService64d is allowed
  • If you are using 3rd party firewall or anti-virus software on this Mac this could also interfere with our Dashboard operation.

Well, none of the above were the problem. Guess how I solved this?

I booted to my Recovery partition using <Command + R>, and then I reinstalled Yosemite (after uninstalling the Drobo Desktop). After the OS X reinstall, I reinstalled the latest Drobo Desktop. Bingo, no further connection problem. I had run out of other options, so I am very happy that this worked.

I would suggest that if all else fails, try a reinstall of OS X (which is non-destructive). The only other thing to do would have been a clean install — thank the stars that I didn’t need to do that!

sboydman - Thank you for sharing this information on how you resolved the issue -

Glad to share — hope this can help others in getting stubborn issues fixed.