Drobo

Installing or updating Dashboard 3.4.2(or newer) - Mac El Capitan v10.11.6 (or earlier)

Subject line says it… Would like to update dashboard - installing Dashboard as new won’t work either.

Sorry, you can’t, Drobo only supports up to 3.2.1 to El Capitan. If you want the newer Dashboard, you have to upgrade Mac OS to Sierra. I wouldn’t update anyway, if I were you. Mine all started acting super weird after, I’ve been downgrading everything to 10.11.6 to get stability back.