Installing DroboMini

On Monday I set up a new DroboMini with new drives, formatted it using the Drobo Dashboard and everything seemed to be working well on a new Windows 8 installation.

This morning I plug in the Drobo Mini (USB 3 connection) and Windows has frozen on a “Device Setup/Installing DroboMini/Please wait while Setup installs necessary files on your system. This may take several minutes.” message. That process appears hung, since it’s been 30+ minutes with no movement on the progress bar.

Have any of you seen something like this? What should I do?

I cancelled that Window. Drobo Dashboard reports that health is “good”.

This doesn’t leave me feeling comfortable…


Sometimes when other component installs are required (.NET Framework, etc) - a prompt can appear behind other windows or off-screen. Alt-Tab to see if there’s something hidden.

There was nothing hidden. And other ideas?


Not sure… Perhaps right-click the Setup file and Run as Administrator? That’s often required for things that want to access hardware.

hmm, i havent tried a mini, but on win7 with my drobo-s, the only thing that sometimes pops up is an error from Dashboard, as it tried to connect to the drobo service i forgot to start.

then it half quits and tries to load but it cant proceed until i manually start the service.
(im not sure how win8 works, but ive heard all sorts of flaky stories with it not being a full o/s or something)

if you have a look if you can get into services.msc (or from task manager) to see in case the service (likely DDService.exe) is running, and then if so, plug in the mini - does that get any further?

have you tried another usb port just as a test?
when i used other products (such as a wireless usb, or another usb storage device) it would try to install/prepare the same drivers, just because i happened to plug it into a ‘different’ port than the one i initially used.

if windows plays up a bit, try restarting the computer too, especially windows 8.
let us know how it goes when you can, and once its working again, probably a good idea to run a scandisk on it (or chkdsk if thats in win8)

(sometimes if you use a port blocker to lock down your system, it might interfere too)

Where’s the double-facepalm smiley?[hr]
@Frosty, I think that could be Windows trying (and failing) to look for updated device drivers over the Internet. You can take a look at the Drobo item in the Device Manager and see if there are any problems reported. You could also retry the automatic update from the right-click menu.

thanks for the friendly reminder that i might have made an ‘oops’ :slight_smile:

i was probably thinking of the flavour of win8 which is the RT edition