Installing apps for 5N (please help a noob)

So I thought Drobo would be simple and user friendly. I guess not. I’m trying to install the crashplan app to backup my drobo to the cloud.

I have drobo apps enabled on my 5N, the app list comes up, but when I click to install it gives me the error “This application failed to install. Please try again”

Reading through the massive amount of confusing threads, I think I need to manually install some apps for it to work? Locale, Java8 & crashplan? Everyone is talking about moving the tgz files (which I was able to find) to the Droboapps folder. Where is this folder??? I’m running windows 10 (which is probably a mistake I know). Can someone help walk me through this? Any help is appreciated!


Due to the way CrashPlan is designed, it remains the most difficult thing to get working. The DroboApp should just install from the Dashboard along with all dependencies, but then there’s a reasonable amount of stuff that needs to be done to force your Crashplan client on the computer to connect to the engine running on the Drobo. That much is Code42’s fault - there’s utterly no reason they couldn’t have put an option in there from the start to connect to a remote server, and instead we have to hack it all kinds of fragile ways.

You can persevere and get it working, but I gave up on it a long time ago. It was just too fragile, too much to maintain, and the CrashPlan service was far too slow. Not things you want in a backup service in my opinion.

Do you have the latest firmware and dashboard installed (3.3.0 and 2.6.10 respectively)?

Yes, I believe everything is up to date.

If you do have firmware 3.3.0 and Dashboard 2.6.10 installed, then it should be just a matter of clicking install on CrashPlan. All dependencies will be installed for you.

When in the dashboard, I go to tools and click update. It says “Drobo has the latest versions of the Drobo Dashboard and Drobo firmware”

When I then go to Drobo apps and click install for crashplan, I still get the error “This application failed to install. Please try again”

Is there any way to install crash plan for drobo manually?


Can you mount the DroboApps share on the 5N? If so, do it and try to remove the file “.servicerc”, then try to reinstall crashplan.

What do you mean mount the DroboApps share? Sorry, can you walk me through that?

Also, where can I find the file “.servicerc” ?

You have to mount the Windows Share \drobo-5n\DroboApps (if you are on a Mac, CMD+K on Finder, then smb://drobo-5n/DroboApps). Replace drobo-5n by whatever your Drobo is called.

Once the share is mounted, delete the file called .servicerc. This is a hidden file, so you’ll have to configure either Windows Explorer or Finder to show hidden files.


Ok, first I think I was able to mount the DroboApps folder. Is “mount” the same as “map”? I.e. assign it a drive letter?

Regardless, I was able to find the droboapps folder. My location was “\drobo5n\DroboApps” (no dash) And I just right clicked on it and hit map to assign it a drive letter.

I put the downloaded crashplan .tnz file in there and restarted the drobo. Once restarted, the file .servicerc did show up and I deleted it and tried to install crashplan. Still no dice. Then I remembered you need Java8 and that Locale. I downloaded those .tnz files and also put them in the DroboApps folder, restarted the drobo and voila! It works.

… now I just have to figure out how to actually use it with crashplan app… this may need a whole new thread lol. Thank you so much for your help!!!

UGH! Ok, so I finally got the crashplan app installed on the dashboard. But my drobo still isn’t showing up in the crashplan app.

When I click “configure” to get connection details in the droboapp, it says the page can’t be displayed.

Any ideas? Are there still more steps that I need to do?

Thank you in advance for any help!

If you had to install Java8 and Locale manually, you are not running the latest firmware. Please double check the firmware using the Drobo Dashboard.

This means that the embedded HTTP server is not running. This is probably because you are not running the latest firmware.

So I’m in Drobo dashboard, I go to tools, and under software updates I click “check for updates”. It still says I have the latest versions of drobo dashboard and drobo firmware. Do you mean I need the latest version of Java8 and Locale? How do I do that? The only reason I installed them manually is because I wasn’t able to install them from the dashboard.

Thank you for all your help so far ricardo. I really appreciate it.

But which versions do you have, specifically?

For the Drobo, you can click it and go to the Status tab. There should be a firmware item in the “System Information” table.

For Dashboard, you can click the “Help and Support” tab. There should be a “Drobo Dashboard version” field in there.

Drobo firmware is 3.3.0

Dashboard is 2.7.0

bump. Still need help!

I’m not sure what is going on with your Drobo, so my suggestion is to remove all apps, disable DroboApps in Drobo Dashboard, reboot the Drobo, and start installing crashplan again, from the Dashboard.

Ok, so I’ll walk you through exactly everything I did so hopefully you can see what I did wrong.

I disabled all drobo apps. Then I deleted everything from the Droboapps folder \drobo5n\DroboApps. Then I restarted my drobo to make sure it was empty. Once restarted I re-downloaded the crashplan .tgz, the locale .tgz, and the java8 .tgz files. Here are the links where I got those, so they should be the up to date version. (downloaded 4.4.1 for the 5N) (2.11.1-1 for the 5N) (update 33 for 5N)

Once downloaded, I moved all files to the DroboApps folder while also deleting the “.servicerc” file in there.

I then restarted the Drobo. Once restarted, it now is showing that crashplan has an update and is telling me to click update. But when I click it, it does nothing. It also does nothing when I click start (because it says the app is stopped) and the configure screen still won’t show up. Just giving me a blank “navigation to the page was cancelled”

That’s all I got. See any holes in what I did?

Please don’t click the update button. Since you installed a version of crashplan from outside the Drobo Dashboard, you can’t update from the Dashboard anymore, at least until the official repository gets updated as well. It will break the app, as you are experiencing it.