Drobo

How to use unallocated space

I have a Drobo5n with a large amount of DASD across 5 drives. The 5N though is reporting 4TB of unallocated space. How do I get the 5N to use / recognize this space?

When I asked Drobo support this question there answer was to buy a new Drobo5N fill it with new drives migrate all of my data from the old 5n to the new 5n, and then reset the old 5n and then it should recognize all of the space. Sounds great if I had another $2,000 to through around.

Really need a solution to this issue that works within the existing 5N.

hi thomlamb, can i check what size each drive is, and if you are using the default Single SDR drive redundancy, or if it is using dual DDR?

Same question here. I upgraded one of my hard drives from 4TB to 6TB, but the additional 2TB show as unallocated space. I am using the standard SDR, not DDR.

Sometimes, depending on existing disk sizes, adding only a single larger disk will not increase your usable capacity. It will instead reserve this newly-found space for future expansion. You would need to add two or more disks to increase your usable space.

This Capacity Calculator can help you visualize this…
http://www.drobo.com/storage-products/capacity-calculator/

Bummer! Oh, well. Will buy another drive and report with the results…

I have replaced two of the drives with 8TB drives, so my setup now is three 4TB drives, plus two 8TB. When I check the capacity, I still get 12% of the total space as unallocated space.

Thoughts?

With those drive capacities and using SDR, you should essentially have about 18 TB of usable storage. What do you show for total space available?

Correct, but a big chunk shows as “unallocated”. Here is a screen grab…

https://www.dropbox.com/s/itf5bnnafv34d9h/DROBO.jpeg?dl=0

Strange indeed. I assume your firmware and dashboard are current?

Correct, everything is up to date.

I have added an additional 8TB drive to see if that makes a difference, but still the same. Now it is 21.76TB total, with 26% of that showing as unallocated space.

So as I understand it, you now have three 4-TB drives, one 6-TB drive and one 8-TB drive installed in a Drobo with Single-Disk Redundancy (SDR)?

Wait… you mentioned UNALLOCATED space… not RESERVED space, right? Those are different. What model Drobo do you have and what is your volume size set to?

I currently have three 8TB plus two 4TB drives. The drobo is a 5N with firmware 3.5.12

Capacity shows 21.76 total, with 69% of used space, 26% of uncallocated space and 5% of free space.

Hope this clarifies :slight_smile:

hi vinc,
if you had 8TB x3 drives, and 4TB x2 drives, (with SDR) it should work out to this:

8TB + 8TB + 8TB + 4TB + 4TB = 32TB raw
32TB (-8TB for sdr) = 24TB actual
24TB (*0.9 for filesystem overheads) = approx 21.5TB usable

would you be able to double check if SDR is used currently (it most probably is, though good to double check) :slight_smile:
one thing that might be worth doing, would be to try copying some data from the drobo onto somewhere else, like to your computer if possible, just to try getting the free space to about 16% free.

this might allow it to be able to fully assimilate the new capacity into the diskpack, and trigger a rebuild after some time, probably at least 15mins i think based on something i read.

btw can you remember what your default max volume size per volume is? if it is 4TB, what happens if you also try shutting down dashboard (when not transferring anything), and then re-launching dashboard - does a popup appear, mentioning setting up another volume?

Hi Paul,

Thanks for your suggestions!

Correct, I am getting exactly 21.76TB of total “usable”. Out of that, 26% (5.76TB) shows as “unallocated”. I filled out the entire available space to see if after reaching that point the “unallocated” space became usable, but no, I get an error saying that there is not enough space:

https://www.dropbox.com/s/de540r3helbb1xu/ERROR.jpeg?dl=0

https://www.dropbox.com/s/hevfa6soiraefxf/STORAGE.jpeg?dl=0

I have tried creating a new share, to see if that opened up the unallocated space. Nope.

As you suggested, I checked to make sure that Dual Disk Redundancy is not on, and it is not. I also tried deleting some of the data to free up at least 16% of the storage. It has been sitting for a few hours, rebooted a couple of times and… nothing so far.

About the default max volume size, you got me there. I only remember setting a max size for the Time Machine share, not for the other ones. Perhaps that is where I am doing something wrong?

Or perhaps the only option is to reformat the entire Drobo? Hope is not the case, that is exactly what I wanted to avoid when I bought it! :slight_smile:

I misunderstood your issue in the beginning, and I now believe what you have is an original setup of a 16 TB volume on your 5N. This limit is set during the initial setup and will never grow without help. The new volume limit is 64 TB which began with firmware version 3.5.2 but it requires a system “reset” if you upgraded from previous versions. This would explain why your UNALLOCATED space keeps growing as you add drives.

The only way to increase the volume size to its maximum 64 TB is to copy all your data off the Drobo, reset your Drobo so it rebuilds with its new default 64 TB volume, then copy your data back onto the Drobo. You should then have full access to all your drive space.

More info here…
https://myproducts.drobo.com/article/AA-01867

Bummer! That is a major pain in the neck :slight_smile:

Thank you for your time. I will do as you suggest and will report to confirm that it works.

I have 23.58TB with only 15.66TB used and the remaining unallocated space. Same problem?