Drobo

How to Tell What Drive is Causing Issues?

Hey all,
Recently I have been having some issues with write failures getting reported in Windows to my drobo. I seem to be able to get everything working ok again after restarting my drobo, but a couple hours of writes later it happens again. I’d like to be able to determine which drive is having these issues so that I can replace it. How do I go about determining this?

What OS are you on?
What firmware version on you on?
What dashboard version are you on?
Are you connected via USB or FW?

My apologies -
I’m using Windows 7
I’m on firmware 1.3 (still trying to get the latest firmware to update properly for me)
I’m using the latest dashboard version as of today
I’m connected to USB with a first-gen drobo

Thank you, Jennifer!

I would definitely get your firmware up to 1.3.5.

Firmware 1.3.1 was designed to fix some usb connectivity issues on firmware 1.3.0.
Which those connectivity issues caused write failures.

Also, after updating the firmware to 1.3.5, I recommend doing a chkdsk on the volumes.

Write failures usually indicate data corruption, not an issue with a drive.

I’ll give it a shot and report back, thanks Jennifer.

Alright, so Windows 7 dskchk has a nasty bug in it which makes it basically unusable for checking and repairing errors on my drobo volume. Are you guys aware of any free alternative utilities which will do the job appropriately? I am not having luck finding anything that works.

Interesting… I have my Drobo formatted to 16 TB, connected to Win 7 Professional, and Chkdsk completes OK from Command Prompt, but I have to remember to stop any programs/shares accessing the drives.

A few times it seemed to “hang” at the end (just after the summary output) and never returned to the command prompt, but a reboot (normal, not forced) made it OK. BTW, it still did the repairs it needed to, even though it didn’t return to the command prompt.

The “check the disk on next reboot” seems not to work for me so far. It either gets skipped or runs and completely faster than I can see it.

bhiga - what command options are you using? chkdsk /r bluescreens for me after consuming > 2GB of memory. I’m trying some updates to see if that helps as well, but don’t have anything to report back on yet as far as that goes.

I run Chkdsk /F

/R scans for bad sectors and since Windows is unaware of thin provisioning, I could forsee that going crazy. Plus it shouldn’t be necessary since Drobo does its own bad sector management.

Brandon

chkdsk on next reboot doesn’t work because drobo takes so long to startup that windows has already gone past the point of checking for dirty volumes before drobo presents any volumes!

Run chkdsk from the command prompt, not on next reboot.

Thanks, bhiga, I’ll give that a try and report back.

its says its unable to lock the drive/get exclusive access to the drive/the drive is in use (or something similar) which is why i was trying to do it on the next reboot :stuck_out_tongue:

If it can’t be locked for exclusive access…

  1. Boot in Safe Mode
  2. Make sure nothing else is open (including Explorer windows)
  3. Turn off antivirus

Then try running Chkdsk again. It should be able to run, unless you’re doing something funky like having the Drobo as your boot or paging file drive.

Ok, so now when I run chkdsk, I am getting this error:
Insufficient disk space to fix volume bitmap CHKDSK aborted

I have 2.50 TB of used space and 668.43 GB of free space in my drobo. According to internet research, chkdsk likes 15% of drive space to do its work. By my calculation, 500GB of free space on the drobo should be sufficient to run chkdsk. But it isn’t working.

I can read from my drobo all day, but writing to it craps out so quickly. I’m starting to get concerned. Any more suggestions, my friends?

CHKDSK, like defrag, needs a minimum of 15% free, but may need more.
If you have lots of large files, CHKDSK may need way more space than that.

First off, empty the recycle bin on the Drobo volume to free space.

Then delete any temporary files on the Drobo volume to free more space

If you still don’t have enough free space, check the Drobo for any recovered data files that CHKDSK might’ve created. They might have useful data, so be careful when sorting through.

If you have files that can be error-checked (for example, ZIP archives) on the Drobo volume, copy them off to another location, verify/test the copy for validity, then delete the file off the Drobo to make more space until CHKDSK can complete successfully.

Alternatively, you might want to pick up a 2TB drive and an enclosure or USB-SATA adapter and use that to back up/move as much data off the Drobo as you can until you CHKDSK can successfully repair it.[hr]
Oh yeah, you are running Command Prompt with elevated privileges, right? (Run as Administrator)

Thanks bhiga, I’ll move some stuff off of my drobo volume and try again. Will report back…

Ok, so I have cleared enough space to run chkdsk, but the process isn’t completing. It seems to happen pretty consistently at this point in the chkdsk output:

4096 bytes in each allocation unit.
4294934518 total allocation units on disk.
3679217035 allocation units available on disk.

the process stalls. Looking in the process monitor, I am seeing these errors as far as the eye can see:

6:55:05.7803322 PM chkdsk.exe 2740 DeviceIoControl T: IO DEVICE ERROR Control: IOCTL_DISK_VERIFY
6:55:05.7834427 PM chkdsk.exe 2740 DeviceIoControl T: FAST IO DISALLOWED Control: IOCTL_DISK_VERIFY
6:55:05.7834578 PM chkdsk.exe 2740 DeviceIoControl T: IO DEVICE ERROR Control: IOCTL_DISK_VERIFY
6:55:05.7866911 PM chkdsk.exe 2740 DeviceIoControl T: FAST IO DISALLOWED Control: IOCTL_DISK_VERIFY
6:55:05.7867063 PM chkdsk.exe 2740 DeviceIoControl T: IO DEVICE ERROR Control: IOCTL_DISK_VERIFY

I still seem to be able to access my drobo volume (after ending the chkdsk process), but I’m concerned that the chkdsk process is not completing properly. Any ideas on how to fix this would be greatly appreciated.

Grrr, so I tried to download to the drobo again, and after a few minutes there would be what appears to be another error - now when I look in any folder on the drive, it appears as if there are no files in any of the folders. The folder structure remains intact. Everything is fine again when I reboot, until I try to download to the drobo again. After a few minutes, I get missing file errors and all I can see on the drobo is the folder structure.

This is getting very discouraging!