Drobo

How to recover a Drobo partition now marked as Unformatted?

After an unfortunate hard-drive upgrade which completely messed up my Drobo (http://www.drobospace.com/forums/showthread.php?tid=2460), my Drobo finally managed to enter the ‘protected state’ again after two full weeks of intense disk activity, multiple reboots,etc. However the file system is now marked as unformatted and the Drobo doesn’t mount.

Here’s a quick overview of the current state:

  • 1st gen Drobo with 4 drives
  • Initially formatted under HFS (OS X)
  • All drive lights are now green
  • Capacity gauge is about 80% on the blue diodes
  • Drobo shows up in Disk Utility but with no partition mounted

What would now be the best to attempt to repair the file system and attempt to recover my data?

I have at my disposal:
-OS X Disk Utility
-Disk Warrior
-Drive Genius
-TechTool Pro
I have also heard that R-Studio might be good at recovering RAID partitions. I don’t have that one but if that is the way to go I’m ready to purchase it.

Any suggestions?[hr]
I tried running a simple Repair Disk in Disk Utility and it stops after a few seconds with the following message:

Verify and Repair volume “disk5s2”
Checking Journaled HFS Plus volume.
Checking extents overflow file.
Checking catalog file.
Invalid record count
The volume Drobo400 could not be verified completely.
Volume repair complete.Updating boot support partitions for the volume as required.Error: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.

Disk Utility stopped repairing “disk5s2”
Disk Utility can’t repair this disk. Backup as many of your files as possible, reformat the disk, and restore your backed-up files.

I’m a pc guy - but the general consensus on the forums seems to be that diskwarrior is best at recovering data - i’ve seen quite a few people report varying degrees of success (its far from guaranteed!) but it always seems to do better than competing products

let us know how you get on

Wow… I am speechless!
After seemingly be stuck for an hour on the Drobo partition, Diskwarrior managed to repair the full directory structure!

So after almost 3 weeks now of drive switching and data relayout, multiple Drobo self reboots, and an unreadable file system for the past 10 days, Diskwarrior managed to repair the file structure and from the looks my files seem to be there and working (haven’t tested all of them of course!)

I had already accepted the fate of the data loss and now it feels like someone just came back from the dead!

I am speechless… and happy!

Congratulations! You should get some sort of award for the most interesting adventure thread here :slight_smile:

glad to hear it worked :smiley:

Well I hope it was entertaining for everyone! :wink:
Can’t say that’s how I felt about it though!

I’m glad my investment into Disk Warrior paid out too! It’s not the first time that this program saves my data.

Now I just need to find enough storage to copy everything off the Drobo and then test the disks one by one. Because even for my old Drobo, 2 full weeks of relaying out data seems a bit much!

Thanks again for everyone’s input and advice! It was certainly very helpful!

Cheers

Just another quick update:
I started copying data off my ‘repaired’ Drobo and about 500GB into the data it went all blinking again and lost the connection with the Drobo dashboard. Left it for 24H and then turned the Drobo off as the drives didn’t seem to have been spinning for a while. When rebooting I had to do another Disk Warrior repair (they seemed to be much more extensive this time) and now it seems ok again. While copying the data off I encountered some corrupted and lost files but nothing irreplaceable. I have 1TB to go to get everything off and then I will take the drives out and test them one by one. One of them must be partially defective.

I hope that this whole thread is not too boring but I figured that maybe someone else will go through the same experience and having a story like that documented might provide additional insight (and maybe hope!)

You should submit a log now to DRI Tech Support. They should be able to pinpoint the drive. There are cases where the Drobo does not like a drive that otherwise tests ok.

My Drobo shows actually four red lights, the drives are recognized but dashboard says that too many drives were removed (?). Disk warrior seems not to recognize the drobo partition (even on the substitution unit sent by DR). Any suggestion how to proceed? Dashboard shows data protection on…

dont change anything

telephone support

thats pretty much it im afraid

im now having 2nd thoughts about my upgrade project from here lol :frowning:
http://www.drobospace.com/forums/showthread.php?tid=2576

Paul,

My only advice, out of this whole drive swapping experience, is the following:

If you mix drives that were in different Drobos, make sure you SHRED the whole drive (as in zeroing out not just one partition but the whole drive). Don’t just do a simple format. I ran into this whole issue described in this thread because I just formatted the drive (apparently Drobos do write on some hidden or special sectors), which then led my Drobo to believe I had swapped out 3 drives from the old Drobo as opposed to 1 drive from the new.
Just my 2c.

ive never wiped drives - the only “trick” is to hot swap the drives - that way drobo is already running off the disk pack you want to continue to use :slight_smile:

I hotswapped too… but that didn’t work out for me.
I would recommend it as a precaution… it’s far less time consuming to shred a HD than to have to go through these day long rebuilding procedures :slight_smile:

thanks for the information macdingo.

i would have thought that taking out a drive (when theres no bad colours or blinking lights and safe etc) and putting in another drive, would simply wipe the drive that is put into the drobo, unless it had some pack info when from the same pack as the other drives already still inside it.

(maybe it didnt treat it like a proper hotswap when you put it into standby mode - if i read your linked original post correctly?)