Drobo

How to get PureFTP to work

I need some help on configuring/setting up/installing PureFTP to work correctly. In order to gain access to my DroboShare through the Internet. Can someone help me, please.

Thank you,
Christopher

What is your problem? What is your configuration? What error messages do you get?

I don’t get a error code. I downloaded PureFTP file from drobo.com/droboapps and downloaded it into the Drobo folder called DroboApps. From there on I’m stuck in configuring the PureFTP and getting up and running. Hoping if you can help me out. Thank you.

I would like some sort of direction on this as well. I can’t seem to find anything via Google or here on the forums.

@Steven From where would you like some direction?
Have you enabled DroboApps?
Have you downloaded PureFTP and restarted?
Did the install go as expected?
Is the FTP-port open?
etc.

Sorry,
Yeah I got it installed rebooted DroboApps is enabled.
I am stuck same as above with the configuration.
I have never used PureFTP before and haven’t used Linux since RedHat 6. I read somewhere configuration has to be created from scratch? What does the file need to be named how should it be structured?

This might be an obvious question but here goes :

  1. How do you change the default username and password? (The root/giveit2me one)
  2. Can you set up another user account with its own user/password as well as limit to a specific directory?

Thanks in advance,

CS

Yes I need this information as well, plus how to even turn it on so I can log in.

You need to ssh to the Droboshare and use the passwd command. If you don’t understand this sentence, then you are probably in over your head and need to hire someone to help you. OR study up on Linux.

I do understand how to use SSH to a basic degree - can you post an example script line please?

Cheers

CS

I’m trying to do the same thing. Please post an example!
Thanks
Absolute

Just log into the Drobo via SSH and type passwd
It will then ask you for your new root password, and then will ask you to re-enter the new password.

Then to log into ftp, just use the username of root, and the password you have just changed to.

I just installed pureFTP and I’m a little stymied also. I have run config file FTP servers in the past, but aparently PureFTP doesn’t use a config file, only command line options when starting. I have the root user password changed and that was easy. As far as I can tell from the documentation, if a user exists, they can FTP into the Drobo. My question is…how do I create a “user” for the Drobo/FTP?? Is it the same as creating a user on a regular *nix system? I’m a little leary about farting around with the Drobo as root 'cause I don’t want to brick the thing.

Thanks,

Dodd

I’ve got PureFTP working, along w/ dropbearSSH. Used ExpanDrive to connect via FTP directly through the Finder (Mac OS X). From there, I was planning on running DroboShare to back-up remotely. However, files that I FTP disappear somewhere. Where can you retrieve files uploaded via FTP, w/ PureFTP app running?
Thanks in advance for anyone’s help on getting a user-friendly, reliable off-site backup system running.

http://www.pureftpd.org/project/pure-ftpd
and especially section “PER-USER CHROOT() RULES”.

[mac /]
$ ssh root@10.0.1.199
root@10.0.1.199’s password: giveit2me

Welcome to Embedded Linux
_ _
| |||
| | _ ____ _ _ _ _
| || | _ | | | |\ / /
| || | | | | |
| |/
||||| ||____|_/_/

      A Data Robotics Product.

http://www.drobo.com/
/>
BusyBox v1.1.2 (2007.06.18-15:03+0000) Built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

~ $ rm ConnectedDrobos/
~ $ addgroup ftpgroup
~ $ more /etc/group
root:x:1:root
user:x:500:
ftpgroup:x:501:
~ $ adduser -h /root/ConnectedDrobos/./ -G ftpgroup ftpuser
adduser: Failed to execute ‘passwd’, you must set the password for ‘ftpuser’ manually
~ $ more /etc/passwd
root:$1$$J8Ji9LlFpF1EaoKKlkeGO/:0:0:root:/root:/bin/sh
nobody:x:99:99:Nobody:/:/sbin/nologin
user::500:500:Linux User,:/home/user:/bin/sh
ftpuser:x:501:501:Linux User,:/root/ConnectedDrobos/./:/bin/sh
~ $ passwd ftpuser
Changing password for ftpuser
Enter the new password (minimum of 5, maximum of 8 characters)
Please use a combination of upper and lower case letters and numbers.
Enter new password: ftpuser
Bad password: too simple.

Warning: weak password (continuing).
Re-enter new password: ftpuser
Password changed.
~ $ cd /mnt/DroboShares/Drobo/DroboApps/pure-ftpd/
/mnt/DroboShares/Drobo/DroboApps/pure-ftpd $ ls
auto_config nohup.out pure-ftpd-start.sh pure-ftpd.pid
name pure-ftpd pure-ftpd-stop.sh
/mnt/DroboShares/Drobo/DroboApps/pure-ftpd $ rm auto_config
/mnt/DroboShares/Drobo/DroboApps/pure-ftpd $ ./pure-ftpd-start.sh unused /mnt/DroboShares/Drobo/
/mnt/DroboShares/Drobo/DroboApps/ /mnt/DroboShares/Drobo/Music/
/mnt/DroboShares/Drobo/Movies/ /mnt/DroboShares/Drobo/My Stuff/
/mnt/DroboShares/Drobo/DroboApps/pure-ftpd $ ./pure-ftpd-start.sh unused /mnt/DroboShares/Drobo/Music /mnt/DroboShares/Drobo/DroboApps/pure-ftpd
/mnt/DroboShares/Drobo/Music
/mnt/DroboShares/Drobo/DroboApps/pure-ftpd
~ $

Note on the pure-ftpd-start.sh parameters:
1 - is unused in the shell script
2 - mount directory this creates a symlink called ConnectedDrobos in the root directory of home that points to this mount directory
3 - pure-ftp application directory where pure-ftpd is located

Open browser
enter the URL: ftp://root:giveit2me@10.0.1.199/ or ftp://root@10.0.1.199/ (and be prompted for user/password)
or
ftp://ftpuser:ftpuser@10.0.1.199/ or ftp://ftpuser@10.0.1.199/ (and be prompted for user/password)

Now close the FTP browser window.

Set your router up to do port forwarding of your dynamic ip to your DroboShare (mine is at 10.0.1.199).

If you don’t know your dynamic IP, check http://whatismyip.com/. For this example, lets say mine is 123.456.789.123.

Once you rebooted your router, you should be able to login again from the outside, e.g., ftp://ftpuser@123.456.789.123/[hr]
#######################################################

Written by: mountainbiker (Drobo Forum)

Version: 20081122-1532

Purpose: .profile for use on the DRI DroboShare

Note:

Don’t forget to mkdir $FTP/ftp

#######################################################

Prompt

Black 0;30 Dark Gray 1;30

Blue 0;34 Light Blue 1;34

Green 0;32 Light Green 1;32

Cyan 0;36 Light Cyan 1;36

Red 0;31 Light Red 1;31

Purple 0;35 Light Purple 1;35

Brown 0;33 Yellow 1;33

Light Gray 0;37 White 1;37

red=’\e[0;31m’

RED=’\e[1;31m’

blue=’\e[0;34m’

BLUE=’\e[1;34m’

cyan=’\e[0;36m’

CYAN=’\e[1;36m’

green=’\e[0;32m’

GREEN=’\e[1;32m’

NC=’\e[0m’ #no color

PS1="\n[[${RED}]\u[${NC}]@[${RED}]\h [${BLUE}]\w[${NC}]]\n$ "

Environment Variables

export PS1
export DROBO=/mnt/DroboShares/Drobo
export TORRENT=$DROBO/DroboApps/ctorrent-dnh3.3.2/ctpackage
export FTP=$DROBO/DroboApps/pure-ftpd
export PROFILE=$HOME/.profile

Shell options

set -o vi # won’t set to on for me on the DroboShare; use “set -o” to check

Aliases

alias c=“clear”
alias e=“vi $PROFILE;l”
alias l=". $PROFILE"

alias pureftp=“cd $FTP”
alias ll=“ls -al”
alias start_ftp="_ftp_prefix;./pure-ftpd-start.sh x $FTP/ftp $FTP;_ftp_postfix"
alias start_music_ftp="_ftp_prefix;./pure-ftpd-start.sh x $DROBO/Music $FTP;_ftp_postfix"
alias stop_ftp="$FTP/pure-ftpd-stop.sh"
alias start_torrent="$TORRENT/ctorrent -D 200 -U 10 -E 1.5 $TORRENT/torrents/*.torrent"
alias torrent=“cd $TORRENT”
alias …=“cd …;”
alias …=“cd …;cd …;”
alias _ftp_prefix=“rm /root/ConnectedDrobos/;rm $FTP/auto_config;cd $FTP”
alias _ftp_postfix=“cd - > /dev/null”[hr]
[DroboShare ~]
/$ more /etc/passwd
root:$1$$J8Ji9LlFpF1EaoKKlkeGO/:0:0:root:/root:/bin/sh
nobody:x:99:99:Nobody:/:/sbin/nologin
user::500:500:Linux User,:/home/user:/bin/sh
ftpuser:$1$$lEGWZx3wSut2Y0BtV6pzq1:501:501:Linux User,:/root/ConnectedDrobos/./:/bin/sh

[DroboShare ~]
$ more /etc/group
root:x:1:root
user:x:500:
ftpgroup:x:501:[hr]
[DroboShare ~]
$ ls $FTP
auto_config name pure-ftpd pure-ftpd-stop.sh
ftp nohup.out pure-ftpd-start.sh pure-ftpd.pid

[DroboShare ~]
$ stop_ftp

[DroboShare ~]
$ start_ftp
/mnt/DroboShares/Drobo/DroboApps/pure-ftpd/ftp
/mnt/DroboShares/Drobo/DroboApps/pure-ftpd
nohup: appending output to ‘nohup.out’

[DroboShare ~]
$ ls -l
.ash_history
.profile
ConnectedDrobos -> /mnt/DroboShares/Drobo/DroboApps/pure-ftpd/ftp
DontPlaceFilesHere.txt[hr]
Look at http://www.dyndns.com/

DynDNS URLs are set to the IP you set at setup (under the free service). Therefore, to ensure the named DynDNS URL works, you need to verify that it matches your dynamic IP provided by your ISP. You can check your IP quickly using http://whatismyip.com/[hr]
This function I use in my bash (not Droboshare) profile:

function ip() { # Get IP adresses.
IPWIRED=$(/sbin/ifconfig en0 | egrep -o ‘inet [0-9.]+’ | egrep -o ‘([0-9]{1,3}.){3}[0-9]{1,3}’)
MACWIRED=$(/sbin/ifconfig en0 | egrep -o ‘ether [0-9a-f:]+’ | egrep -o ‘([0-9a-f]{2}:){5}[0-9a-f]{2}’)
IPWIFI=$(/sbin/ifconfig en1 | egrep -o ‘inet [0-9.]+’ | egrep -o ‘([0-9]{1,3}.){3}[0-9]{1,3}’)
MACWIFI=$(/sbin/ifconfig en1 | egrep -o ‘ether [0-9a-f:]+’ | egrep -o ‘([0-9a-f]{2}:){5}[0-9a-f]{2}’)
IPWORLD=$(curl -s www.whatismyip.com/automation/n09230945.asp | egrep -o ‘([0-9]{1,3}.){3}[0-9]{1,3}’)

echo -e -n "${RED}Local (wired) :${NC} ${IPWIRED:-Not connected}\n"
echo -e -n "${RED}MAC (wired)   :${NC} ${MACWIRED:-Not connected}\n"
echo -e -n "${RED}Local (WiFi)  :${NC} ${IPWIFI:-Not connected}\n"
echo -e -n "${RED}MAC (WiFi)    :${NC} ${MACWIFI:-Not connected}\n"
echo -e -n "${RED}ISP           :${NC} ${IPWORLD:-Not connected}\n"

}[hr]
On your Mac side, make an entry like

10.0.1.199 droboshare

into /etc/hosts. Note: 10.0.1.199 is the IP assigned by your router, so the IP maybe static or dynamic (DHCP).

You’ll then be able to use it to do shorthand things like

ssh root@droboshare to SSH into the DroboShare

http://droboshare:8080/ to access the DroboShare Admin Utility[hr]
The router will need to do port mapping, which passes the “live” ISP IP address to your local IP address. These IPs could be dynamic or static. Typically, both are dynamic, but your router may assign the same dynamic local IP address to your DroboShare, unless you change your networks configuration.

Note: 10.0.1.199 is the dynamic local IP address, which could potentially change; therefore, this will have to reflect any such change.

Mountain Biker,
[font=Impact][font=Trebuchet MS]Thank you so much![/font][/font]
This is incredible directions, and is by far the most help I’ve seen anyone getting on the forum. Actually, I got the FTP working later last night, I just forgot to put the correct remote path in the FTP, and gained access w/ ExpanDrive. After having the Drobo mounted in the Finder, I used DroboCopy and created a test folder to copy back and forth between 2 drobos, one of them remote. That worked. I proceeded to set DroboCopy to check a large folder (approx. 500GB) for changes. The Drobo it was copying to already had the majority of these files on it, just not some changes that have occurred in the past 2 weeks. That didn’t work so well. I’m thinking it’s too large, so I’ll break it down into more realistic amounts.
However, there are several issues I need to address that your instructions include the answers too, so I’ll proceed w/ what I need. I’d really like to write a friendly tutorial on how to do this on a mac, and would gladly partner to accomplish this correctly, if you’re interested. I feel there’s alot of lost Drobo users out there that need a tutorial to bridge the gap of setup information that is currently hurting Drobo reaching it’s full potential.
Thanks again for your help. I’ll let you know how it proceeds as I progress.
Sincerely,
Abs0lute[hr]
Hey mountainbiker,
your 1st link doesn’t work, it just goes to the Drobo Forums Homepage.
http://www.drobospace.com/forum/thread/1...tpd-going/
Any clues?
Abs0lute

Tried what you listed mountainbiker, thanks.
However, most of it was already running somehow via the DroboShare, but it was a fun learning experience.
Any suggestions on connecting to the Drobo via ExpanDrive SFTP(SSH)?
Thanks for your help, let me know if you’d like to collaborate on a tutorial.
Abs0lute

My post was from notes I took when I got PureFTP going one weekend. It is really old (around the time the Droboshare first came out), and I haven’t used PureFTP since.
The first link you refer to – now removed – was to a post I made way back then. However, when DRI re-did their forum recently, it appears they trashed all the earlier posts by members.

It’s okay, I got it up and running now. Any clues on accessing the Drobo via SFTP (SSH)?
Absolute

During testing, I just used Firefox and Filezilla – so sadly no. After that weekend, I put it up on the “shelf” as it didn’t really meet my needs: (1) PureFTP wasn’t really robust enough, and (2) the Drobo was just way to slowwwwww.