How to downgrade

I have a drobo elite attached to an iMac through the ethernet connection. I have Yosemite. It was working great until opened dashboard and it asked did i want to upgrade the software. I did and thats where the problem began. I did have 2.5.3 but upgraded to 2.6.4. and now it will not mount the drobo. I read it may have something to do with 2.6.4 does not support iscsi setup. so my question is how do i downgrade back to 2.5.3 or any suggestions on how to fix this.

Run the uninstaller for Dashboard. Follow the instructions precisely.

Here is a link to Dashboard 2.6.3 which is a ‘last known good’ version.

https://www.dropbox.com/s/mxlldxw4d4qvo1c/Drobo-Dashboard-2.6.3.dmg?dl=0

Hi all friends who have issues with latest updates of Drobo Dashboard.

There is a bug with their Mac OS X updates and the most surprising annoying irritating fact is that their customer support will NOT help, unless you pay for their support. So says a certain Sean K.

Yes, Drobo Support wants you to PAY for fixing their own errors!

Based on my research reading these forums, I’m not the only victim here of their uncaring attitude. I will be going all out to warn future buyers about all issues I have with drobo products (this is not the only problem I’ve had).

Anyway here’s how I got around the problem. I reinstalled my previous version of Drobo Dashboard.

Searching for previous versions of Drobo Dashboard on the internet is very difficult. However I’ve discovered that on the Mac, (so thankfully) all previous installer .dmg files are stored. The path is Shared > Drobo Dashboard > updates

To be able to reinstall a previous version:

  1. Uninstall the faulty update
  2. Copy the above mentioned previous installer file to another disk.
  3. Delete the shared folder
  4. Restart the computer
  5. Make sure Drobo disks are not mounted
  6. Install the earlier version of Drobo Dashboard
  7. All should be back to how it was. But make sure you disable future auto updates!!!

If you find the installer is not loading, providing apple event errors etc, then just check that the above steps have been taken.

If you have any further issues, reply to this. I will also upload my version of the installer file (2.5.4) which is working for me to my website, so that it can help future victims desperately seeking previous versions of the software.

DROBO SHAME ON YOU FOR PUTTING YOUR CUSTOMERS THROUGH ALL THIS UNNECESSARY TROUBLE, AND LEAVING US TO FEND FOR OURSELVES.

1 Like

I agree with lime absolute rubbish support from drobo got yer money now we couldn’t care less attitude I will never buy endorse or have any drobo brands under any circumstances ever again

Called Drobo for support for my Gen 2 and it is past being supported. They basically said “go fish” for support else where. I have been satisfied with my Gen 2 and it still runs well. 4/3/3/4 TB drives. Not looking forward to when it fails. getting all that archive back to 2006 is going to be a pain.

Can someone please upload the previous version of the dashboard 2.5.3?
Nothing is working.

Thanks,

Rafael

If you have any further issues, reply to this. I will also upload my version of the installer file (2.5.4) which is working for me to my website, so that it can help future victims desperately seeking previous versions of the software.

I am desperate to find a 2.5.x installer for my Mac/2nd Gen Drobo and I am being stone-walled, I guess like everyone else is?

I’ve been asking for a link for the past 3 months and been told they weren’t supporting 2 Gen (actually wouldn’t even tell me which Gen my FW800 Drobo was so I had to figure that out, myself), then they couldn’t find my registration (3rd time lost?!?) so, I had to register but of course, without a working dashboard I had no serial number (until I found an old screenshot!).

They get my vote for the WORST customer service of any computer company that I’ve ever had dealings with since 1981!

HELP! PLEASE!

martygerman(at)mac.com

Here is 2.5.2 for Mac

https://www.dropbox.com/s/fgsv3vrvnf1qph4/Drobo-Dashboard-installer-2.5.2.dmg?dl=0