Drobo

How to delete Time Machine share via Dashborad or Window 10

My Drobo FS has a share for a Time Machine backup. It backed up an Apple iMac which (a) is no longer compatible with the Drobo Dashboard (DD) version applicable to the FS and (b) does not recognise the Drobo on the netwaork. .

We now use a seperate external hard drive in the iMac for Time Machine, but the old back up remains on the Drobo FS. I would like to remove the Time Machine share and free up some space on my Drobo.

When I tried to delete the share via DD on my WIndows PC the share initially disappeared but DD then immediately displayed a warning message saying the changes were not saved.

How can I delete the share when I cannot access either DD on the Drobo itself on the iMac?

Any help would be greatly appreciated.

Try rebooting the Drobo, see if it a) actually did it despite the error & b) if it will do it after a reboot.

Thank you for the suggestion.

I have just tried rebooting the Drobo but the Time Machine share still exists. I tried to delete itm but the same message appeared saying "Failed to save the setting"s.

Ok 3 options:

  1. Wait for someone who knows the NAS units better than me.

  2. Contact support.

  3. Backup > reset > restore.

Three usually works for most problems that otherwise seem intractable, but you do need somewhere with enough space for your data temporarily.

If you could still access it from your Mac, I’d say use the Time Machine interface to delete all backups then try again.

If you can access the share from Windows, then creating an empty folder on Windows & using Robocopy to sync that empty folder to the share with the /purge option might clear it to try again with the share empty… that would be entirely at your own risk though, no promises it wouldn’t make things worse. It does delete many things in a folder that explorer can’t though.

Thanks for your further input.

Unfortunately we cannot access the Drobo from the Mac, either via network or directly attaching it due to incompatibility with the latest MacOS so we cannot use it delete the data or the share on the Drobo.

The Time Machine share does not show up at all in File Explorer on the WIndows PC. It only shows up in the Drobo Dashboard.

Over the last 24 hours I have been erasing from the Drobo various Windows data backups that are not needed with view to copying what remains and resetting the Drobo exactly as you suggest in option 3.

I can make one copy of the Drobo data to my PC and copy it across 2 external hard drives so I have two backups.

I reckon this is really the only viable workaround.

One day I shall have to bite the bullet and buy a up to date Drobo model. In a way now is the time to do it while the present one still works and the data has been pared down and can be backed up!