How I got Crashplan to work well on my Drobo


I’m writing this post to save others a lot of time, frustration and oh so many Google results!
I gathered these tweaks from a lot of post in this Forum and on the web.
I want to thank every one of you who contributed in this forum and especially Ricardo.

For the past year I’ve been struggling to get Crashplan to work properly on my Drobo 5N, recently I found out that it hadn’t been running in quite some time.

Needless to say this had to be fixed.

CrashPlan was the first App I installed the moment I got my Drobo 5N.
It was working ok in the beginning but then I started adding more and more files and things got hairy…

Crashplan was starting and stopping every couple of minutes.
I connected to the Headless Client on the Drobo and noticed that it kept crashing while scanning the files.
After some googling I found out that CrashPlan was running out of memory and stopping.

[size=large]1. Divide your backup into multiple Backup Sets [/size]

I have about 3 TB of RAW files in my Backupset and Code 42 recommends a 1024MB of Ram per Terabyte.
This is clearly not happening on the Drobo.

I divided my backup into 3 separate Backup Sets of 1 TB max.

I tried to add the link from CrashPlan on how to do it but due to the Spam filter I can’t post it, just google “Create Backup Sets” if you don’t know how to do it.

[size=large]2. Raise CrashPlan memory limit[/size]

First stop the service through ssh.

cd /mnt/DroboFS/Shares/DroboApps ./crashplan/ stop

Then edit [color=#696969]run.con[/color] found at [color=#696969]DroboApps/crashplan/app/bin/run.conf[/color]

On the line that starts with [color=#696969]SRV_JAVA_OPTS[/color] find


and change it to


Start the Service again

cd /mnt/DroboFS/Shares/DroboApps ./crashplan/ start

[size=large]3. Add more SWAP memory[/size]

I found that CrashPlan would still crash because the Drobo doesn’t have enough memory/swap so I created another Swap file as explained by Ricardo

I tried doing this with the AddSwap app in the Drobo Share section on DroboPorts. But i couldn’t get it to work.
Maybe Ricardo would be able to update the App so it works on the Drobo 5N?

[size=large]4. Change CrashPlan settings for better upload speeds[/size]

After these changes CrashPlan was working but the upload was unbearably slow. I got slightly better upload speeds after changing the Data de-duplication to Minimal and Compression Off.
Source: Article by (can’t link)

[size=large]5. Disable Data de-duplication completely for the initial backup
With all these tweaks CrashPlan was working fine but the upload still slow, I have a 10Mb upload on my connection but CrashPlan would never go above 1Mb and usually chug along at 325 Kb. I found an article by explaining how to disable data de-duplication completely

I don’t which tweaks really solved my problem but all them combined did the job.

Please feel free to share your fixes and tweaks together we can solve this!