Drobo

How can I disable Dashboard logging?

I just noticed that Drobo Dashboard 2.8.5 is doing a lot of logging in
/Users/Shared/Drobo Dashboard/Logs. Here are some of the files in there:

rw-r–r-- 1 root wheel 1.7K Dec 30 18:39 TMDiags_2016-12-30_18-33.log
-rw-r–r-- 1 willf wheel 347K Dec 30 18:42 DDDiags_2016-12-30_18-42.log
-rw-r–r-- 1 root wheel 70M Jan 1 14:44 TMDiags_2016-12-30_18-40.log
-rw-r–r-- 1 willf wheel 298K Jan 2 13:59 DDDiags_2017-01-02_13-59.log
-rw-r–r-- 1 willf wheel 292K Jan 2 14:49 DDDiags_2017-01-02_14-48.log
-rw-r–r-- 1 root wheel 60M Jan 3 01:14 TMDiags_2017-01-01_14-44.log
-rw-r–r-- 1 willf wheel 8.2M Jan 3 18:08 DDADiags_2016-12-30_18-40.log
-rw-r–r-- 1 root wheel 59M Jan 4 11:58 TMDiags_2017-01-03_01-14.log
-rw-r–r-- 1 willf wheel 316K Jan 4 12:51 DDDiags_2017-01-04_12-50.log
-rw-r–r-- 1 willf wheel 3.7M Jan 5 11:41 DDADiags_2017-01-03_18-08.log
-rw-r–r-- 1 root wheel 42M Jan 5 11:41 TMDiags_2017-01-04_11-58.log
-rw-r–r-- 1 willf wheel 310K Jan 5 13:37 DDDiags_2017-01-05_13-37.log
-rw-r–r-- 1 willf wheel 292K Jan 5 16:17 DDDiags_2017-01-05_16-16.log
-rw-r–r-- 1 root wheel 63M Jan 7 00:56 TMDiags_2017-01-05_11-42.log
-rw-r–r-- 1 root wheel 78M Jan 9 01:06 TMDiags_2017-01-07_00-56.log
-rw-r–r-- 1 willf wheel 363K Jan 9 14:49 DDDiags_2017-01-09_14-46.log
-rw-r–r-- 1 willf wheel 375K Jan 9 14:53 DDDiags_2017-01-09_14-52.log
-rw-r–r-- 1 willf wheel 8.5M Jan 9 14:59 DDADiags_2017-01-05_11-42.log
-rw-r–r-- 1 willf wheel 258K Jan 9 14:59 DDDiags_2017-01-09_14-58.log
-rw-r–r-- 1 root wheel 23M Jan 9 14:59 TMDiags_2017-01-09_01-06.log

I would like to disable this sort of logging, is there a way to do this?

Also I see this error in the DDADiags_2017-01-05_11-42.log:
DDA: 0x7fff7cb30000 01\05 11:42:52 Error - DDADiagsSettings::loadDiagSettings failed to load diag setting from file /Users/Shared/Drobo Dashboard/settings/DiagsSettings.xml.

What does that mean?

I am seeing the same thing. I have 4 Drobos with dashboards on two machines. Both machines are experiencing continual writing to %programdata% and for SSDs, which are quickly becoming typical today, this is horrific.

Just like the Spotify bug (https://www.google.com/search?q=spotify+writing+ssd) this will dramatically shorten the life of your SSD, or, as these articles point out, will kill your SSD real quick.

Drobo must provide a way to disable this logging. I have resorted to stopping the ddservice, setting it to manual, and exiting the Dashboard, rendering the software 100% useless, but at least it will not kill my very expensive NVMe SSD.

SMFH. This should be a debug-only action of last resort, not “always on, always writing, and too bad, so sad, you can’t turn it off”

hi fz798, can i check which drobo units you have and which ssds you have in them if applicable?

btw thanks for the info link about spotify…ive posting about it mabe 5 times in the last month or so (including today here) http://www.drobospace.com/forums/showthread.php?tid=147404 but never thought to include a link… am just glad at least what i read about it matched up to what i was refering to :slight_smile:

for your drobo wfiveash,
can i check is this the same replacement/new drobo that you got, which ended up with an intel SSDMCEAC06 60GB card (that is still inside your drobo)? (and also did you end up going to a v3.5.x firmware in the end?

On Win10x64 machine is Drobo Mini (assorted SSDs), latest firmware, latest dashboard, and both ddservice and drobodashboard create/lock files in %programdata%.

On W2K12 box, are two Drobo 5D units and a DroboPro 8-bay unit, also both service and dashboard creating/locking files in %programdata%.

On both systems I have disabled the service and removed the dashboard from startup as I don’t want this logging, at all.

Shortly after I got the replacement 5D and put the drives and msata SSD back in, the 5D indicated that the SSD was dead as was one of the drives. I’ve replaced the bad drive but have not replaced the msata SSD (yes, this is the 5D that I’m using currently). I’m using dashboard v2.8.5 and firmware 3.5.2.

BTW, I asked support about the incessant logging and they said that “feature” can not be disabled. I hope they reconsider as I am using a SSD and prefer not to have it’s life shortened (or spaced used) by these irrelevant logs, not to mention the 5D performance isn’t that great so I’d prefer not to have it spend any time logging unless it’s actually logging errors. Currently it’s just storing noise.

+1

For me, it’s absolutely unacceptable, so, as I said, I’ve disabled the service and stopped the dashboard, it’s completely useless to me unless the logging can be disabled.

I’m unaware of any other software that logs debug data in a manner which cannot be disabled - It’s incredibly inconsiderate of the end user’s hardware to not provide a means to disable the logging.

hi, thanks for the info,
i had a look in my similar folders but only found a settings ini file (plus a few others like xml apps info or firmware setups etc… im only on v2.5.3 of dashboard here… can i check if you can have a look in your dashboard preferences/settings, if you have enabled anonymous feedback and reporting?

my old xp computer stopped working sometime last year so i cant check there yet but i never really noticed lots of logging there (but i did often run diagnostic logs maybe once a quarter and on each drobo, so was often having some logs there) but if you get a chance try to see those settings just in case that is the cause?

In dashboard prefs there aren’t any prefs for enabling anonymous feedback and reporting as far as I can see.[hr]
I’m wondering what would happen if I:

ln -s /dev/null ‘/Users/Shared/Drobo Dashboard/Logs’

?

Thanks for this, - it made me think about writing to RAMDisk instead, I’d not thought about making a symlink to a RAMDisk folder, which I’ve done for other similar writing (temp env vars, browser temp files, etc). Good idea.

This worked perfectly on both machines, now the logs are written to RAMDisk:
[color=#0000CD]mklink /D “C:\ProgramData\Drobo Dashboard” “R:\Temp\Drobo Dashboard”[/color]

Still, should be an option to disable logging altogether.

Paul, could it be hidden folders/files causing you not to see them?

hmm it might only have been there in an older version but i will try and check (im pretty sure i checked the folders to show all files but can check again and post back in case not)