Drobo

Hide a Folder

I can’t seem to figure out how to hide a folder for my Drobo FS that I am connecting to through my Windows 7 64 bit machine.
There is one folder that shows up that my syncing software creates that I don’t want to see on the network drive. When I right click and select hidden attribute, it does not stay. Any ideas?
Sorry, I am new to this NAS life.

Thanks,
Toby

Hey Dynatnt1,

Which syncing software are you using? Is possible that the software is removing the hidden attribute when it runs? Is the hidden attribute removed after time, or it does not go hidden ever?

Any additional details about your specific setup would be helpful.

FlyBoyOz,
I am using a program called GoodSync. The problem is, when I click on the properties panel for the folder in Windows and click hidden, after I click okay and close the box, if I go back in, the hidden box is unchecked.
Doesn’t seem to stick.
Hope this helps.

Thanks,
Toby

The hidden file attribute is not being saved because you are using a linux based NAS and connecting using Samba. Because of how the drobo configures samba by default, the hidden attribute is not supported (ie, not saved) so when you look at the file properties again the hidden attribute shows as unchecked. Samba needs to be configured to treat hidden files correctly, you can look at this for all the details: http://www.samba.org/samba/docs/using_samba/ch08.html

Before you think you can easily enable this, it’s not something easy to just turn on for the Drobo FS and here is why:

  • the settings are in /mnt/DroboFS/System/samba/conf which is a regenerated file so any changes you make WILL be lost at some point
  • the drobo configures files with a default mode of 0777 and since samba uses the execute bits to store file attributes, essentially the drobo is configured to default every file as potentially a “hidden+system+readonly” file (if you enabled these in samba), so you would need to change the default mode as well

I’m not saying that it’s not possible to do this yourself, I’m just saying that it would be difficult and may not be worth the effort. It will also mean that most likely won’t be able to use the Dashboard to manage your shares without blowing away your changes.

I would suggest that you open a support case with DRI and state that “windows file attributes don’t work on the Drobo FS” and hope you are lucky enough to get them to enable this in the future. Assuming support will not fix it immediately, I would also log it as a feature request.

Thank you j-hah, that makes perfect sense now.
Like you said, not worth the effort for just hiding a folder. If it was something that was easy to change, I would just do it.
Gonna leave it for now.

Thanks,
Toby