Help with rescuing a FW Drobo

I have a FW Drobo (Gen 2?) that I am having major issues with and hoping someone can help.

Running Mac OSX Mavericks 10.9.2 on a 3.2Ghz Quad Core Mac Pro

Started with 1TB drives in all four bays

All had been working fine for over a year, no problems

Gradually upgraded to :
Top two bays have WD 2TB drives
3rd bay has 3TB Seagate Barracuda
4th Bay had a WD 1.5TB

Still no problems until this happened:

Drobo is set to 3 partitions on the desktop.
Drobo got about to 80-90%full
One day I noticed one partition missing from the desktop
Bay 4 was red, indicating the 1.5TB needed to be replaced.

Replaced it with a 2TB Seagate Barracuda.

I noticed just after I replaced the drive in Bay 4, that the TOP bay turned red for a moment. Then it went back to green, then the rebuild process started.

It has now been over 2 weeks and it is still flashing orange/green.

Other two partitions have now disappeared from the desktop. No longer able to mount any partition, so cannot get anything off the Drobo.

Drobo Dashboard 1.8.4 no longer sees the FW Drobo unit. (It still sees my older Gen 1 Drobo just fine.)

Have I just lost everything on this Drobo?

You’re using a very old version of Drobo Dashboard. The first thing you could do is download and install the lastest version compatible with the Gen 2 Drobo (2.5.2).

See if that helps.

i think up to 10 days would be all that is needed for a (normal rebuild) after upgrading your drives.

eg, i had about 5tb of (raw drive capacity) and it took between 4-5 days for me to upgrade my gen1 (and that was just from 4x1tb into 2x1.5tb and 2x1tb).

If you have been waiting so far, might as well give it a bit more time…

What “could” be happening is something like these:

  • upgrade is taking more time because your drobo is still connected to the computer, and something else might be slowing it down by using it in some way.
    (you could try disconnecting the cable from the computer)

  • upgrade is taking more time, because another drive of yours maybe encountered some stress-problems and it had to do some more rebuilding.

  • upgrade is taking more time, because maybe there are some hard drive errors on the drives and drobo is having to work around it and it takes more time. (a diagnostics log could show if a particular drive is failing, but i wouldnt run the diagnostics just yet as it might interfere with the rebuild)

What i would do if it was me, would be to give it a couple more days,
and then shutdown the mac and disconnect the fireware cable. (so that the drobo is just with the power plug)
and then listen to the drobo/touch/feel vibrations etc to see if its “doing stuff”, and then leave it for a few days on its own with no computer attached.

(if you feel that after that you have waited too long, you could try to power down the drobo, wait 5 mins, and then power it up again, and then let it boot up again and see if it starts continuing again/rebuilding.)

if you dont want to power off the drobo, and have waited for a lot of time, then you could try rebooting the mac and then plug the drobo cable back into it to see in case it was the mac which needed a reboot as well.

(i’ve had a few “scary moments” with my gen1 and gen2, especially after a power cut, and it took a few restarts and an overnight rebuild/letting it run on its own, and then all was ok).

hope it helps a bit[hr]
also, as toby said, there might be some limitations with your particular dashboard or firmwares, but you need to make sure before doing that, in case its half way rebuilding with 1 version and then gets stuck trying to finish off with another firmware etc.

my gen1/gen2 units run fine on dash and firmware 1.3.7 and 1.7.3 (or vice versa) :slight_smile: but i havent tried upgrading any drives beyond 1.5tb yet.

Thanks for the tips. Updated the Dashboard to 2.5.2. It could see the FWDrobo and tell me it was still rebuilding, but when I came in this morning , it could no longer see it. I’m gonna try the 5 min power off and power it back up unplugged from the Mac and see how long that will go. (Fingers Crossed)

Well, the Dashboard is able to see the FW Drobo now, and says that Data Protection is in progress with 27 hours remaining. It has now been stuck at 27 hours remaining since last week. Suggestions?

hi does it let you exit dashboard and launch another instance of it?

once or twice my dashboard for the gen1/gen2 hanged and when i closed it and reopened it, it was working again.
(i may have had to restart the ddservice at the time too but i cant remember)

I would safely eject/unmount the Drobo, disconnect its data cable and come back in a few days.

Any Drobo access, including Drobo Dashboard itself, will slow the rebuild process.

In the past I’ve let Drobo Dashboard monitor the rebuild and because that particular reporting seems to be a lower-priority function (good and bad), I saw the time estimate vary wildly. I disconnected and just waited. Wall-time ended up being around 36 hours for my Drobo configuration and amount of data at the time, which I don’t remember offhand.