help, please - cannot get firmware to update, cannot get drobo fs volumes to mount


here is my set-up — Drobo FS, purchased 12/13/2010, with the Firmware v.1.2.6 [4.44.64324] and on my iMac, the Drobo Dashboard v.2.5.3 [66012] on a gigabit ethernet home network. i access the Drobo FS from my iMac 27" with an intel core i7 processor @ 2.8 GHz, 16 GB RAM and Mac OS X 10.9.3 with all the latest updates.

there are 2 main issues: [list=1][]the latest downloadable firmware for the Drobo FS is v.2.5.3, but it fails every time i try and update to that;
]i cannot, no matter what i try, get the Drobo FS volume shares to mount on my desktop like they used to so i can back up to them with time machine.
more detail —

issue 1, cannot update Drobo FS to firmware v.2.5.3.

i see my Drobo FS just fine, with all it’s set volume shares, on the Drobo Dashboard, just fine. i updated the Drobo Dashboard to 2.5.3 via the Drobo Dashboard > Tools > Check for Update. that worked fine. after restarting my iMac and the new Drobo Dashboard v.2.5.3 [66012], it then updated me from Firmware 1.2.5 to v.1.2.6 [4.44.64324] and restarted the Drobo FS remotely (the iMac is downstairs in the home office, the Drobo FS is upstairs, both on the same gigabit ethernet network). that worked fine.

however, i noticed on the Drobo support download site, the latest version of the Firmware for the Drobo FS is v.2.5.3. when i try and update through Drobo Dashboard v.2.5.3 > Tools > Check for Updates, it says i have the latest firmware all ready, even though my firmware is v.1.2.6 [4.44.64324] and the Drobo Downloads site says the latest version for the Drobo FS is v.2.5.3.

i tried downloading the release.Fugitoid.tdf for Firmware v.2.5.3 and tried updating it manually through Drobo Dashboard > Tools > Manual Update, and it consistently fails, every time, at various stages of running the update (it’s even gone as far as almost getting 70% through applying the update and still failing.

i have read and gone over the steps in the Drobo Knowledge Base article, Why does my attempt to update software or firmware fail with a message to contact Customer Support? What solutions can I try?,” i’ve tried doing what it says, creating folders in “Applications/Drobo Dashboard/updates,” i’ve named them both “Updates” and “updates,” tried everything it suggests, tried moving the the Firmware update release.Fugitoid.tdf to another folder, to the desktop, etc. - no matter what, the update fails somewhere along the line.

yes, i’ve cycled power on the Drobo FS, several times.

yes, i’ve restarted the iMac also, several times.

i can ping the Drobo FS on my network just fine, i can see it in the Drobo Dashboard v.2.5.3, and i can telnet into the Drobo FS’ port 445 just fine. i just can’t get the Firmware update to complete.

nothings seems to work to get this firmware updated on my Drobo FS to 2.5.3. please help?

issue 2, cannot mount Drobo FS shares on my iMac with Mac OS X 10.9.3 for TimeMachine.

this may be related to not being able to update the firmware mentioned above, but here goes —

i cannot mount my Drobo FS volume shares with my known log-ins and passwords on my iMac with Mac OS X 10.9.3 with all the latest updates to work with the Apple TimeMachine back-up.

i have tried via the Drobo Dashboard 2.5.3 > Shares > Mount, i get the error message, “Drobo Dashboard could not mount this share."

i have tried via the Mac OS X Finder to connect and also via Finder > Go menu > Connect to server… (cmd-key-K), putting in my known log-ins & passwords. i get “There was a problem connecting to the server ‘’ - The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.” every time.

as stated above —
yes, i’ve cycled power on the Drobo FS, several times.

yes, i’ve restarted the iMac also, several times.

i have tried connecting to the Drobo FS volume shares as both SMB and AFP in Mac OS X, both get the same error message.

i can ping the Drobo FS on my network just fine, i can see it in the Drobo Dashboard v.2.5.3 with all its volume shares, and i can telnet into the Drobo FS’ port 445 just fine. i just can’t mount the Drobo FS server volume shares to work with Apple TimeMachine.

also, when i go into the Drobo Dashboard v.2.5.3 > Shares > Share settings and attempt to update my password, thinking that might be the way in, when i attempt to click “OK” and save the change, i get the error message, “Failed to save the settings," in Drobo Dashboard. :frowning:
please help?

thank you in advance.


— faddah wolf
portland, oregon, u.s.a.

hi, do you have access to a windows computer maybe via a friend, just to see if it mounts via windows?

if it lets you, at least that way you could access the data a back it up via copy/paste (or similar) in the menatime?

Issue 1:
You don’t actually have an issue here. :slight_smile:
The latest firmware for Drobo FS is v1.2.6, which Drobo Dashboard already updated you to.
The latest Drobo Dashboard for Drobo FS is v2.5.3

It’s actually lucky that whatever firmware you downloaded was not applied, as flashing the wrong firmware can make a unit unusable.

Drobo Dashboard is the management software, the firmware is the firmware for the device.
So you’re good here.

Issue 2:
This one, I’m not sure… It might be related to your attempts to flash that mysterious fugitoid file… I would download the current v1.2.6 firmware for Drobo FS and manually flash it, just to make sure your firmware is in the correct state.

hi all —

thank you for the replies. actually, Drobo Tech Support’s Kyle F. got back to me on e-mail and were able to help, despite the Drobo FS being legacy, out of warranty and, therefore, not totally supported.

yes, you are correct, and i was wrong - the actual firmware version for the legacy Drobo FS is 1.2.6 - i thought it was 2.1.5 because on the page, it shows the DroboPro FS firmware as being 2.1.5 and i got the two confused (the regular Drobo FS legacy downloads are below, and yes, it is 1.2.6). so that issue is settled.

they were able to show me how to re-set the password on the legacy Drobo FS. that did it, and it is, after a couple of days “preparing back up” in Apple’s Time Machine, backing up a-ok, it appears to the Drobo FS over gigabit ethernet. so i’m taken care of. didn’t need a windows machine or anything.

i include the support e-mail from Drobo Tech Support’s Kyle F. here, below, so others can learn from this experience. thank you all for the responses.


— faddah wolf
portland, oregon, u.s.a.

[quote] Discussion Thread
Response Via Email (Kyle F.) 07/04/2014 04:17 PM

Hello Faddah Wolf

Since your Drobo is currently out of warranty and support entitlement, there are limited technical support options.

For further information on end of life products please review:

  1. The latest firmware build for the FS devices is 1.2.6. You can find it listed here:
    There is no firmware 2.5.3.

  2. Below are instructions on resetting the Admin credentials for the FS unit. Follow that, and you should be able to re-mount the shares. If that doesn’t work I advise uninstalling/reinstalling the Dashboard software:
    Answer Link: What is the proper way to uninstall and re-install Drobo Dashboard on my Mac?

Please follow these instructions to reset the password to your Drobo Dashboard.

Please remember that both the username and password are case-sensitive.
Username = reset
Password = F4Iv2RdpwKt7GISo


The password reset key must be copied directly from our Email, please do NOT put into text editor.
Windows: Ctrl+C to copy and Ctrl+V to paste
OS X: Cmd+C to copy and Cmd+V to paste

  1. Click on the Status menu in Drobo Dashboard

  2. Click the blue Login link under the name of the Drobo FS

  3. username = reset

  4. Copy & Paste the password into the password box.

IMPORTANT: make sure there are NO SPACES before OR after the password.

  1. HOLD the CTRL key down on your keyboard and CLICK the OK button.

*** IMPORTANT make sure you hold the CTRL key down and click the OK button - simultaneously.

  1. Change your username and password

  2. Click OK

  3. Click on the Tools menu and shutdown your Drobo FS

  4. When all of the lights on your Drobo FS go out, toggle ON the power.

  5. When the Drobo FS reboots and connects to the Drobo Dashboard, click on Logout.

  6. Log back into the Drobo Dashboard with your new Username and Password.

** If the password reset was not successful try these steps again and pay close attention to steps 4 and 5. **

Kind Regards,
Kyle F.

Technical Support Agent


Glad to see you got it sorted!

Thanks for sharing this, I found it really helpful when I recently had some serious problem with my DroboFS: all of my users and shares disappeared, though the files IN the shares are still there. I could not log in as Admin in Drobo Dashboard, on the “Status” screen it had a link under the device name saying “click here to password protect your drobo” but it failed until I tried the “reset” username technique, then reset the Admin password.

Now I have to figure out how to restore the users and shares without risking my data.