Help please! 4 bay Drobo will not mount

2nd Gen [i think] 4 bay drobo - the one that physically sits on top of the separate droboshare [im sure its EOL]
Firmware 1.4.2 [1.254.50341]
Dashboard version 2.5.3 [66012]
PC is running windows 7
when i do check for updates via ddashboard - i get the msg “drobo has the latest vers of dashboard and firmware”

Drobo just stopped showing up one day as a mounted volume - not sure why - no major upgrades or installs were done on either PC or Drobo

  • i can see Drobo listed under ‘devices and printers’
  • all drobo lights are green
  • there is still room on the current physical disks 23% free [8 of the 10 blue lights are lit]
  • drobo is seen as and viewed as healthy by Drobo Dashboard
  • can get dashboard to blink the lights on drobo
  • performed a full power cycle on both drobo and PC
  • powered down drobo - pulled discs, and reattached drobo to pc and started up. powered back down, and reinserted drives and powered back up - no change
  • turned on network discovery on PC
  • ensured that drobo is allowed on Windows firewall
  • tried hooking drobo directly [via firewire-usb] to both PC, and a laptop - seeing same issues on laptop as PC
  • volume is showing in Disk Management as a healthy partition - cannot assign a drive letter - on the right click menu options, everything is greyed out except delete partition, and help :\
  • Consulted the drobo knowledge base and followed all recommended steps (rebooting/restarting/switching cables/checking security settings, etc.) without success.

i still cannot get the drobo to mount!

dont want to reset/reformat - i haven’t got this data [~2TB] backed up anywhere else

any ideas out there for me?


hi, i saw in another thread zbig mentioned to be careful not to accidentally click a popup that might say “Drive not recognised, do you want to format” or similar which might appear if you plug in a Droboshare’d drobo directly without the droboshare…just fyi.

what happens if you do this:
disconnect from internet,
shutdown antivirus & shutdown windows firewall (and similar programs like those) completely,
exit dashboard program,
restart dashboard and see if drobo still there,

Thanks Paul.
i gave your suggestions a try - here’s what i did this time around;

  • turned off norton av completely

  • turned off windows firewall completely

  • drobo [without droboshare] is directly plugged into PC via firewire to usb cable

  • drobo dashboard sees drobo - it is healthy and has capacity

  • drobo dashboard can make the lights blink

  • i’ve pulled the drobo diag, [and it saved to my desktop] but from what ive been reading on these forums - no one has a utility to read them except for drobo support - and i am using on EOL product :frowning:

  • drobo is still visible as a healthy volume in computer mgmt - right click only options are ‘delete’ and ‘help’
    in ‘devices and printers’ i can see drobo as a listed device. right click > troubleshoot provides no help - shocking! :wink:

  • cannot map as a network drive

  • all device drivers are up to date

  • i performed a windows restore - as far back as i could go [not that far - only sept 5th], and still no change

  • the only other thing i can thinks of is borrowing a friends mac laptop, and seeing if i can try to get ti to mount on that. after that, i am all out of ideas.

any other suggestions?[hr]
one last thing - i attempted to create a new ticket with drobo support but i am get the following msg when attempting to do so;

We see you have encountered an error while trying to access your account.
Please email your first and last name, username and phone number to us at

so i just summed up everything from this thread in an email, along with the diag i captured and sent it off to that address. i am not expecting much [if anything] from that email, but i thought i’d do my due diligence.

any other help would be greatly appreciated

hi joel,
ok cool that you got some diagnostics, maybe they can still help to check them for you…

i think the support site might have already created a user with your username, so it might just be the case where they have to manually tweak your account name to be slightly different. (a lot of us had a similar problem when they did the sso unification but it turned out ok in the end) :slight_smile:

i had a few more questions for you…

q1) just to clarify - when you say this:
“is directly plugged into PC via firewire to usb cable”
what does this mean? (that you tried a range of cables from firewire-to-firewire, and usb-usb?)
or you were using a firewire to usb converter?

q2) have you tried a usb-to-usb cable directly?

q3) has your drobo gen2 ever been setup with the droboshare? or is it only every used directly attached, (and like me, it came with a droboshare but you never used it?) - when you mentioned droboshare it made me think that it was a droboshared-drobo.

q3) if you check your windows services, is the drobo dashboard service running as well? (im guessing it is, as newer versions of dashboard seem to require it, but just in case)

q4) one other method, could simply be for you to try to borrow someone elses drobo gen2 (with at least the same version of firmware as yours), and with ALL POWER OFF EVERYTHING, to take out your diskpack of all drives, and put it into their drobo, and then power up just their drobo to see if it still goes up to 8 Leds etc, and then to plug that into your computer after booting your computer up.

(eg, maybe your device had a problem of some kind)

You could also politely ask support whether they could forward you/loan you a replacement, at a cost, and then discount you if you purchase a gen3 to replace/upgrade to, as that way a gen3 would give you some kind of formal support entitlement, which might also apply to helping you migrate from an older model :)[hr]
(and of course, they would have to have seen and analysed your diagnostics before being sure that an upgrade would fix it) :smiley:

Hi Paul, thanks for the response,

so, big surprise - not one peep from the drobo support folks.

  1. it was plugged in using a firewire to usb converter

  2. i have tried a usb-to-usb directly, and no luch with it mounting using that either

  3. Drobo dashboard is running just fine - it ‘sees’ the drobo, thats how i got the diags and did a few of the admin things like make the lights blink, etc. the drobo was previously hooked up to my network via droboshare. this was the first gen droboshare that was a physically separate piece of HW from the drobo itself. i have since disconnected the droboshare, and have been troubleshooting with the device with direct cabling [and yes, it used to mount just fine on my Pc when i had tried this before]

  4. sadly, i don’t know anyone who owns a drobo - so i am out of luck there

i’ve had it with proprietary software. if i can ever get my data off this drobo, i’m never using this product again :frowning:

if anyone has any bright ideas, please let me know - other wise i’m going to just bite the bullet, lose my >3TB of media and reformat my disks to use in a regular NAS that can actually be serviced/fixed

same issue just happened to me, except mine is a gen 1, did you figure anything out?

sadly no - the only thing i’ve been made sure of during this whole ordeal is to never again buy proprietary SW/HW that leaves you handcuffed into no other option than doing a full replacement. [fool me once Apple, fool me twice Drobo - i’m an idiot …lesson learned]

the only 2 suggestions that i haven’t yet tried are;

  1. borrowing a friends mac laptop, and seeing if i can try to get it to mount on that [trying this soon]

  2. borrowing someone’s 4-bay drobo, and swapping the discs - problem is, i don’t know anyone with a drobo :frowning:

so sadly, the question is - lose my data, or buy a whole new drobo? based on this experience, i’ll lose my 3 TB of data, and buy a NAS that is supported, and live happily ever after, thanks.

hi joel,
just to look back at the original setup… do you still have the droboshare?
if you are not able to get hold of someone with a drobo, maybe you can try a (hopefully cheap) droboshare instead?

what happened to your existing droboshare, and have you tried plugging the drobo back into through the droboshare in various ways since? (am assuming that the reason you unplugged it from the share, was that there was a mounting problem that started happening?)

hang in there and dont give up yet… did you actually raise a ticket/phone up their support team?
they probably didnt see this post but try to phone them as it will be in their interest to help you upgrade/fix the issue, (there may be some costs involved, but it might be worth it?)

as for propriety, you are right that it can be risky, (and usually requires duplicates to help mitigate that risk, which unfortunately have a cost attached) but maybe by phoning up the support team, there might be a way to pay for shipping costs there and back/renting drobo, minus a price reduction if you sent it back, to at least try and see if you can recover your data. (they might need a credit card payment for the full price, and then refund that after you return it or something similar, but its worth asking/suggesting)

btw i saw a post from doc chris, in case it helps:

Hi Paul,
yes - the original setup was the droboshare connected to my home network. it just stopped becoming visible as a drive/volume, and since then, i’ve tired every conceivable way of connecting this drobo to my PC. currently it is directly plugged into my PC via usb.

so i just got off the phone with Drobo support, and they tell mw both 2nd gen drobos and droboshares are EOL, and they wont help me. the only thing he could suggest is to search these forums for ‘file system corruption’ threads, and thats it.

from your thread:

‘yes, just plug it in, drobo just appears like a regular disk drive’

yes - mine used to do that - but now it doesn’t…why? thats the $64,000 question[hr]
does anyone know how i can check for file system corruption on this drobo if the drobo has no drive letter assigned?

hi joel i saw this now, were you able to get things going again?
did you ever try to borrow someones droboshare?
i still have mine in the box somewhere unused, but as you mention $64000 question, youre probably in a different country :slight_smile: