Health Critical, 5N shows green lights

Dashboard: 2.8.5
Firmware: 3.5.10
OS: MacOS Sierra (10.12.2), Windows 10 Pro (Anniversary Ed.)
(Out of warranty)

As you can see via the screenshot, Dashboard still sees the device. The drives are still good, but none of the 5n Shares found (the 5N is not even visible on the network). And the Health is marked as [color=#FF0000]Critical[/color].

What led to this? The activity lights had been on for hours. I could not determine what was causing the activity. Access and responsiveness of the Drobo was slow. Even ssh’ing into the command line, running “top” and “ps -ef” did not reveal any extreme activity, but response to commands was unusually slow. I finally used the Dashboard to restart the device. When it came back up, it was in this condition, so I used the Dashboard to shutdown the device down completely. When I powered back up, it was still in this condition.

From other threads, this means that the filesystem is corrupted and I need to Repair it. But with so many dire warnings about using Repair (in those threads). I wanted to see if anyone had any other comments about my situation.

In particular, the activity light was running for hours and I could not see anything that should have been accessing it. I used Dashboard to restart it, thinking that that would be a “safe” way to end the activity. I’d done something similar, several months ago, and it solved the problem. Using Dashboard to restart or shutdown the Drobo while it is busy is not necessarily safe?

Assuming Repair would work well, but some files are lost, would it most likely be those files which were actively being written? Or could random parts of the directory structure be damaged and even old files might be lost? Or, there is no telling what might happen?

I’m just looking for some peace of mind (it certainly isn’t very peaceful at the moment).

hi wrlee2, are you able to click on the little arrow near the dropdown for System information?
if so, can you set it to show details on each drive to see what it shows for those in that area too?
(in case it does not work, you could also try clicking on the actual drive bays in the dashboard screen area too)

the “repair” option, can take a very long time depending on how long a piece of string is (and im not sure how long it would take for you), though some other users who lost access to shares, were able to regain shares by setting up a new one or setting up a new one and then renaming the new one to something else, but i think their drive lights were green and not flashing.

are any drives there showing any status messages, like warning, healed or failed labels?

can you also remember if you got any emails or popups about the drobo being low on space?
and can you check the windows 10 recent activity, and the add/remove programs feature (if it shows any new updates or programs being installed recently?)

essentially am just trying to see in case some kind of windows update (or similar program) maybe did an update, and automatically used the larges drive (eg your 5n) for temporary backups space, and maybe temporarily overfilled it?

(that could possibly account for the activity light being on, but another program like an antivirus, or a windows search index could also cause that too)[hr]
btw do you have an msata inside?

Thanks Paul. I’ve had it turned off since that day. I will tell you what I know/remember, and I will turn it back on tonight to see whether anything differs or I have more info.

The device, itself, shows all green. I have not received any warnings about capacity running out. I believe that I’d briefly looked at the drive status view and all the drives showed green, though I did not click on more than 1 or two of the drives. As you can see from my screen-shot, only 70% of the blue LEDs are lit. The drive and capacity LEDs accurately reflect what the 5N actually shows. No mSATA.

I will check my Windows history. I would be very surprised if it is using the NAS as a drive for work-space.

Is it your observation that Repair is usually successful? Or that it works and everything is back or everything is wrong. I am worried about missing files and not knowing what I’m missing.

As I suspected (and as shown by the screen shot), all drives are listed as “good”.

Do you think it is safe for me to run Repair?

ah wrlee2, for the part about not knowing in case someting is missing or not, there are some good tools that could help you going forward, which are these:

cathy (by r.vasicek or similar spelling) which is a good windows tool i use on my Das drobos, to essentially create a 1-file mini database of all content, that can be browsed like a file explorer to compare if files are missing.
(creating or refreshing the database can take a fair bit of time so best to not use the computer or drobo for anything during this)

and Corz a checksum program that can catalogue and create i think md5 hash files, even at a parent folder level, which will recursively scan files and folders inside it. Then once complete, you can run it with a verify option and will tell you if all files are still there and still the same as before.

there may be a mac version or some similar tools too, but as usual its always good to read up a bit about using them and to try with a smaller copy of your data first as a test, just to become familiar with the tools.

for the Repair… i dont know to be honest… i havent been able to hook up 5n yet, but with my current knowledge, if i was in the same situation, and dashboard showed me repair options or on any NAS, i would raise a ticket with support, and possibly even block clone all my diskpack drives first before trying… (unless i had a backup of the data etc)

on a DAS model though, with ntfs, i wouldnt hesitate to chkdsk in a multi-pass approach, once per volume that i have, and one instance at a time, (just as i had to do yesterday when explorer crashed and i ran chkdsk 4 times on my 2-volumes of Drobo-s-gen2)

Sadly, since my Drobo is out of warranty, they won’t respond to the ticket, I’d submitted. And I don’t have enough extra drives around to block clone my drives. (That always seems an ironic idea, since the reason I have a Drobo is because I don’t have enough storage, otherwise :slight_smile: )

ah that’s fair enough about that, i remember back in the days when i was juggling computer drive partitions with i think partition magic with about 10MB on each partition thinking i still had enough space :slight_smile:

for the ticket part, i think there is still a way to raise a ticket as a paid-incident even if out of support, if you can or would wish.

what options can you see in the Shares area of dashboard btw?

[quote=“Paul, post:7, topic:143603”]
what options can you see in the Shares area of dashboard btw?
[/quote]I loved the simple days of PartitionMagic! :slight_smile:

The Shares selection was disabled, in this state.

Figuring that there was really no recourse, I planned on running Repair. The Drobo article about it mentioned that the firmware should be updated before running Repair. I debated about this since I felt it introduced another variable that could cause trouble. I finally decided to do that, first. Low and behold, once it restarted, it started normally, as if nothing had ever happened. I feel lucky (and happy).

ah ok thanks for the shares info, and more importantly, well done for the outcome that you achieved :slight_smile:
if you can, try and check each drive in dashboard regarding health status if visible, (just to make sure nothing has since changed) but well done indeed for the good outcome… even if it possibly made a few hairs turn grey in the meantime :smiley:

(btw in case anyone sees the mentioning of partition tools please remember not to use any partitioning tools on your drobo)