Drobo

Having problems configuring email alerts.

I’ve got my new 5N pretty much all set up and running, with one exception. I’m trying to configure email alerts to my Gmail account, but when I enter my account details and try to send a test email it fails saying “An error occurred while sending the test email. Cause: SMTP protocol error. 535 5.7.8.” It also provides a link, but it’s not copy/pastable from the Drobo dashboard window, and it’s pretty long to retype.

So, any suggestions?

Google says error 535 is AUTH failed which means incorrect username/password.

Generally speaking you should enter your ISP’s SMTP server and your ISP credentials (if any).

http://www.hmailserver.com/documentation/latest/?page=reference_error_messages_smtp

I’ve tried using both my ISP’s SMTP server and Google’s, I copied the account settings straight from my email client to make sure I got the right info. I’m using two-step authentication with Google, I tried using both my standard password and an application-specific password, still nothing. In desperation I ended up re-typing the long-ass URL provided in the error dialog, it just takes me to a “Getting started with Gmail” page. Not sure what else I can try. This should be easy…

Gmail SMTP server authentication and SSL on port 465 IIRC.

I’ve successfully used Gmail alerts in the past but haven’t had them enabled for a while. Let me try…

Well, all I got was timeout - even after enabling rules for DDAssist, DDService and Drobo Dashboard… shrug

At least yours sounds like it’s connecting to some server…

According to Google, port 465 is for SSL and 587 is TLS. I’ve tried both, I get the error message on 587 and on 465 I also get a timeout. Well, at least I’m not the only one. I’m having similar problems when trying to send through my ISP’s SMTP server, I’m starting to wonder if it’s a Drobo issue, not configuration.

mine setup fine today, on both the new 5n and the fs i reset up my fs with new disk pack

here are my setups
to non gmail address
from xxx@gmail.com
mail server smtp.gmail.com
port 587

authentication
xxxx@gmail.com
password
use ssl

Interesting. There are two places in the Drobo dashboard where you can set up email alerts, one under Drobo Settings -> Alerts, and one on the Dashboard Preferences page. Previously I couldn’t get either one working, now I can configure the one under Drobo Settings and have it work, but the one on Dashboard Preferences still fails. Oh well, as long as one of them works.

Drobo Dashboard has had a problem with it’s internal email server since day 1, I have made support requests in regards for the last 6 years and nothing has changed. They need to replace it, but refuse to even acknowledge the problems. I can’t set up any alert via Gmail. In the past it worked from certain of my client’s locations using port 587 (never 465). Otherwise, try to find an outgoing email server that does not require authentication or SSL, as this is where Drobo Dashboard’s email service fails.

Drobo: please replace the embedded email server with one that works. Email alerts are not optional for your products.

Gmail alerts work fine from my 5N.

Under Alert Settings/Email Settings make sure the “TO” and the “FROM” are actual email addresses (I use the same for both)…mail server is “smtp.gmail.com”…port is “587”…username (include the "@gmail.com") and passwords are entered correctly…“authentication” and “SSL” are checked.

Right, like I said, sometimes it works and sometimes it doesn’t.

I finally got mine working by generating a GMail Application Specific password to use with Drobo. I’m using two factor authentication on my GMail, so it wouldn’t let me use my regular password.

AHA! Thanks for the update. Makes sense now… and now I’ll go fix my dashboard settings too. :slight_smile:

I was failing to get my yahoo mail to work (I pay for the “Plus” yahoo mail services). I tried using gmail to send alerts and it accepted the above settings for me. Thanks!

PS - I got the test email right away, “This is a test to verify that the Drobo Alert System can send e-mail.”

If you are using Google’s 2 step verification or security protocols, you will need to add your device to use Google services. Use the password that was generated by Google as your password. This should resolve your issue when setting up the Drobo Dashboard Email Alerts.

I have not been successful setting up alerts FROM a gmail account, either to that same gmail account OR to a hotmail account. I do not have access to a different SMTP server that does not require a username & password. I do not have google’s 2 factor authentication turned on.

I tried:

–> smtp.gmail.com & SMTP port = 25 without SSL
error: “STARTTLS required”

–> smtp.gmail.com & SMTP port = 25 with SSL
error: Protocol error 534 5.7.14 https://support.google.com/mail/answer/78754

–> smtp.gmail.com & SMTP port = 465 without SSL
error: timeout

–> smtp.gmail.com & SMTP port = 465 with SSL
error: timeout

Then I followed the instructions Google provides, on this page:
https://support.google.com/a/answer/176600?hl=en
for “restricted Gmail SMTP access” (TLS optional, apps can only send email to gmail accounts, etc.)

–> aspmx.l.google.com & SMTP port = 25 with SSL
error: Protocol error 534 5.7.14 https://support.google.com/mail/answer/78754

–> aspmx.l.google.com & SMTP port = 25 WITHOUT AUTHENTICATION
It worked!! Gmail filtered the email to spam, but OK.
It worked again!! Still filtering to spam, despite telling gmail this was NOT spam.
It failed on the third attempt in 20 minutes, generating an error message in Drobo Dashboard, like above. The error pointed to this page as explanation:
https://support.google.com/mail/answer/188131
which says, in sum, “The email you sent looks like spam, so we blocked it. Other email might not get blocked”.

Google recommends email generators, like Drobo email alerts, to follow these guidelines:
https://support.google.com/mail/answer/81126?hl=en

Will Drobo’s developers update the Drobo Dashboard alerts to comply with Gmail’s requirements?

I have not been successful setting up alerts FROM a gmail account, either to that same gmail account OR to a hotmail account. I do not have access to a different SMTP server that does not require a username & password. I do not have google’s 2 factor authentication turned on.

I tried:

–> smtp.gmail.com & SMTP port = 25 without SSL
error: “STARTTLS required”

–> smtp.gmail.com & SMTP port = 25 with SSL
error: Protocol error 534 5.7.14 https://support.google.com/mail/answer/78754

–> smtp.gmail.com & SMTP port = 465 without SSL
error: timeout

–> smtp.gmail.com & SMTP port = 465 with SSL
error: timeout

Then I followed the instructions Google provides, on this page:
https://support.google.com/a/answer/176600?hl=en
for “restricted Gmail SMTP access” (TLS optional, apps can only send email to gmail accounts, etc.)

–> aspmx.l.google.com & SMTP port = 25 with SSL
error: Protocol error 534 5.7.14 https://support.google.com/mail/answer/78754

–> aspmx.l.google.com & SMTP port = 25 WITHOUT AUTHENTICATION
It worked!! Gmail filtered the email to spam, but OK.
It worked again!! Still filtering to spam, despite telling gmail this was NOT spam.
It failed on the third attempt in 20 minutes, generating an error message in Drobo Dashboard, like above. The error pointed to this page as explanation:
https://support.google.com/mail/answer/188131
which says, in sum, “The email you sent looks like spam, so we blocked it. Other email might not get blocked”.

Google recommends email generators, like Drobo email alerts, to follow these guidelines:
https://support.google.com/mail/answer/81126?hl=en

Will Drobo’s developers update the Drobo Dashboard alerts to comply with Gmail’s requirements?

Hi All -

I was getting the issue same too with configuring email alerts with my Gmail email address but I finally got to the bottom of this. I hope this helps others that are having the same issue. Let us know if this helped. This is what I did to get this working.

  1. Log into your gmail email account.

  2. Go to this link: https://www.google.com/settings/security/lesssecureapps

  3. Set the “Access for less secure apps” to ON.

  4. Test to see if you issue is resolved.

Next, I went back to the Drobo Email Settings and did this below:

To Email: I used my Gmail email address
From Email: Used same Gmail email address
Mail Server: smtp.gmail.com
Port: 527
Authentication: Checked On
Username: same Gmail email address
Password: enter your Gmail password
Use SSL: Check on.

Hit the Test Email button. You should see an message that the test email was successful.

I hope this helps.

~Angel ~ :slight_smile:

sounds like useful info… maybe you are an angel (not) in disguise :slight_smile:

Got mine working with Gmail address but not Google Apps for some reason. So I suggest that.

I tried every single suggestion in these posts and none worked.

Drobo should really rewrite DD from scratch because at the moment is really embarrassing.

I still hope in some direct web access, something like Transmission Drobo App does or most routers do… :\

Update: As Davel23 said, there are two places where you insert email data, I was referring to the Dashboard preferences one.
But I think the important one, the one that alerts you when Drobo has (or solved) problems is the one in All Drobos > Drobo settings… > Alerts and that works with these settings:

drobo@home.it is totally invented (and it doesn’t seems to work, anyway: email comes from your gmail address). :slight_smile:

Hope this helps. :slight_smile: