Hard disk enigma (Drobo and Mac)


My 4-bay Drobo with 4 WD Green 4.0 TB hard disks started flashing green/yellow on the 3 upper bays, and there was no light to the right of the 4th harddisk - the one at the bottom.

Drobo Dashboard said that bay 4 was empty. It wasn’t.

I let the flashing conitnue until Drobo was happy again. Solid green lights in the 3 upper bays and no light in the 4th bay.

Then I ejected the 4th harddisk, and inserted it again.

After a few seconds the flashing stated again. Now on bay 1, 2 and 4.

And Drobo Dashboard now claims bay 3 is empty !!!

After 12 hours the lighs were again solid green - except there was still no light in bay 3.

I unmounted Drobo and shut him down. Ejected all drivesand inserted them again, hoping it was a connection problem inside.

When I started Drobo up again only the two upper bays are active. And Dashboard reports that bay 3 and 4 are empty!


Them I took the drives out of bay 3 and 4 and attached them to another mac to reformat the drives. Strangely enough Disk Utility can easily see the drives, but sees them as 1.8 TB drives.

I have tried to repartition them and to delete them, but both of them are still seen as 1.8 TB drives.

Is there a way to get the lost space back?

I am afraid to re-inset the two drives in Drobo untill it has done its “Data Protection” wchich now - with only two drives inserted - is estimated to take 32 hours.

I don’t know what to do.

My plan is to let it finish the Data Protection routine, make a full backup, insert the two detatched drives and perhaps reformat the whole ting … hoping for a better result.

But I’d like to know if any other users have experienced something similar.

Any clues and hints will be appreciated. Including how to the the 4 TB dives to act as 4 TB drives and not 1.8 TB drives - I can’t figure out that has happened.

Kind rehards,


hi peter,
when you mentioned them showing up as 1.8TB on the mac, can i check how you connected them up?
if it was via a stand-alone caddy, such as a usb caddy, some of them can only recognise (or work with) drives up to a certain size. in this case maybe the caddy can only use 2TB drives or smaller?

(if it was a caddy, can you remember if you have ever been able to use a 4TB drive which was recognised in that caddy before too?)

it may not be the cause, but i do seem to remember a few posts where a suggestion (possibly by doc chris) was to use a windows diskpart to remove any partitions (or to change between gpt and mbr) - (i found it) :slight_smile:

on the other hand, there is a chance that the backplane is not making a proper connection (possibly also damaged if the unit was tilted or moved around a lot with drives inside) which could account for drives disappearing and re-appearing, but i think your current next steps are good… for example to let the current process finish and then to make a backup before trying anything else.

can you also remember if the 4TB greens are from the same batch, and approximately how old they are?

Hello Paul

Yes, I guess you would call it a caddy - it looks like this: http://www.oxygenez-vous.com/shop/img/p/80004-91261-large.jpg

I use the caddy rarely, and I can’t remember if I have ever used iot woth such large drives before. Also i was not aware that it may not be able to read larger drives, I thought that was a Windows problem from earlier times. And I use a Mac, so I could not say.

The Drobo has not been tossed around, it has a steady place where it has been stading for a little over a year now, and all the drives were bought at the same time (dec 2015) (from the same batch, as you say).

Since yesterday, Drobo has finished protecting my data and I have solid green light in bay 1 and 2. No drives in bay 3 and 4.

So just now I inserted a drive in bay 3 (it was a 1 TB drive I had lying around) but that did not impress Drobo. No light. Neither red og green or anything. An Drobo Dashboard still reports the bay as empty.

It’s like it doesn’t see the drives I insert in bay 3 and 4. I have tried with a couple of drifferent drives, but Drobo doesn’t react.

So maybe it’s the drobo that is defective … :frowning:

I had the same issue last night. Drobo Gen 2 Firewire. Bay 3 would not see a WD Green 2TB when the drive was inserted. I left the Drobo on all night. This morning, still nothing. So I shut down the Drobo and removed all the hard drives. (But can’t remove my WD RED 5TB HD in Bay 1: it only slides out 1/4 of a inch then gets stuck). Blew compressed air in the 3 remaining bays to blow out all the dust. Reinstalled the 3 remaining HD, and restarted. Bay 3 now sees the WD Green 2TB that I tried to use last night. I have 4 green lights (Bay 1 WD RED 5TB has a green light, and I don’t have any plans now to remove this drive, since I could either damage the HD or the Drobo).

thanks peter for the clarifications,

it could be that the main unit has a problem, and just in case, i think it would be good to try making backups of your data and verifying etc, before trying anything else (or at least of the most important data)

then when you are happy that your data is backed up, one thing you could try is this: (simply calling the 4 drive bays, 1 2 3 and 4)

  • to power all down (via dashboard for the drobo, and then the computer)
  • and to remove all power and cables from the drobo
  • and to make a note of the order of your diskpack drives, for future reference,
    but this time (assuming your drobo works ok when you only have the first 2 drives working in the drobo and nothing else in bays 3 and 4),
  • and with power still all off and cables unplugged, what happens if you eject the first drive and put it in bay 3, and eject drive 2 and put it in bay 4), and then plug in power and turn on?
    (does the drobo boot up with the usual blue led sequence, with lights filling up from 1 through to 10, usually from right to left, and then go into standby mode?) does it seem to recognise with bay lights, those 2 drives there?

in case it needs longer to complete the boot up sequence, please do allow plenty of time here.

then, if you power up the computer, and launch dashboard, and then to connect the drobo to the computer again, does it wake up and shortly afterwards, become recognised by dashboard, and accessible by the computer again?

if yes, then it might just be that it does not seem to like those other drives somehow (even though i would have thought it would simply mark them as bad and show flashing red lights for them)

if however, the drobo does seem to find those drives, and if it does not show up or work properly again, you could try shutting all down and removing all power and cables, and to essentially reverse the process so that the originally working drives are moved back from bays 3 and 4 back into bays 1 and 2, and to see if it works again as earlier… and if it does work again, then it would appear as though the bays are not working properly anymore

after all that, however, you could then also try to use another caddy which can support larger drives, and to try erasing them/formatting/ removing any partitions on those removed drives, and trying again in the drobo (or also fully resetting the drobo and updating to the latest firmware for it), and then to see if the bays work ok again, but yes, it could just be that after several years the backplane has encountered a problem…

(a bit like when we get old we might get hip issues or back problems, even devices can suffer from old age) :)[hr]
(hi ticzon1, am just also linking to you stuck drive thread too)