Gmail email alert settings.

Wanted to post this information.

I originally got the correct port number from the old DroboSpace and wanted it on the new DroboSpace in case anyone had issues with setting up email alerts for gmail. Not sure who originally posted it, but thanks!!

Mail Server: smtp.gmail.com

Port: 587

Our Knowledge Base directs customers to this website for settings for Incoming and Outgoing Mail Server Settings for Hotmail, Yahoo! Mail, GMail, MSN, AOL and more:

The site has the port for gmail as port 465.

I’m having a very strange problem with the Drobo e-mail alert system on my Mac mini, but not on my Mac Pro.

Both Drobo Dashboards are configured absolutely identically, both are running 1.5.19930 on OS-X 10.5.8, both specify port 587, the same From and To e-mail addresses, the same logon name and password. Identical, as far as I can tell, except that on the Mac Pro I’m running as a standard user, while on the mini I’m logged on as Admin.

One other strange thing is that when I receive an e-mail from the Mac Pro client, it comes in with my full name – the one that is specified in my Entourage setup. Nowhere did I specify that name in anything that Drobo Dashboard knows about.

But on the Mini, I don’t have Entourage installed – only Mail, which I don’t use.

I thought that the Drobo Dashboard was its own SMTP e-mail client. Does it piggyback on top of another client, somehow?

The message that is received is “501 Syntactically invalid HELO argument(s)”. I spent 30 minutes on the phone with Tech Support at my ISP, and they looked at my server, and all they saw was the same message.

Is there a log file somewhere that records more details, or can anyone give me a further clue?

It’s all based on your ISP or whatever email client you are using. I use Gmail to send and my work email is what receives the notice. I have my name listed as Jennifer W in my profile on my gmail account. So when my gmail emails my work email when I do a test or there is an alert the email comes from “Jennifer W”.

There are no log files. It’s not the dashboard actually emailing, it “piggybacks” off of your email.

This is what I found googling your error message:

501 Syntactically invalid HELO argument(s)

When sending e-mail to a third-party SMTP server or through a firewall, a non-delivery report (NDR) similar to the following may be generated:
Subject: Notification: Outbound Mail Failure - A protocol error occurred.

A mail message was not sent due to a protocol error.

501 syntactically invalid HELO argument(s)

The message that caused this notification was:

This error is generated by a third-party SMTP server or firewall.

When the Microsoft Exchange Internet Mail Service establishes a connection to a remote host, the Internet Mail Service initiates the SMTP conversation with “EHLO domainname.com”. If an error is returned, the Internet Mail Service falls back to “HELO domainname.com”. If the HELO command returns an error, an NDR is generated containing the error.

Interesting. So a not-stated requirement is that you have to have a mail program of some kind installed on whatever machine you are running Drobo Dashboard, correct?

If so, then I need to set up / dig into / debug Mail that comes with the Mac, as I don’t want to have to pay for yet another mail program.

However, that bring up another problem, as a really don’t want to receive mail on that machine – I only want to send it.

Is anyone else having this problem, or better yet, know of a good solution?

I don’t use a mail program at my home. I use gmail only.

The email alerts worked just fine with my laptop with gmail as my email provider.

We may have a terminology problem here. What I took from your original message was that the Drobo Dashboard was not, by itself, acting as an SMTP client, but rather it was piggy-backing on another, existing e-mail client, e.g., Entourage or Mail on the Mac, or Outlook on Windows, that happened to be installed on that machine, presumably by calling the internal APIs.

Since I haven’t used Gmail, I don’t know how it works. Is it a purely web-based application, like Outlook Web Access?

If by "piggy-backing’ YOU meant that Dashboard IS an SMTP client that contacts the e-mail server at your ISP, and logs on just like your normal e-mail client would, well that’s how I thought it worked. And in that case I can’t explain the difference in behavior between the two machines.

But I’m going to install Snow Leopard tonight, and see what difference that makes, if any.

Yes, when I met piggy-back I did mean it uses YOUR email to do the sending and receiving. It actually does not do the sending and receiving.

Gmail is completely web-based.

I have seen many a ISP’s block the dashboard from sending email alerts.

For the to email, use the email you want to get the alerts in.
For the from email, use gmail. I know it works.

Unfortunately I can’t troubleshoot ISP issues, nobody can in Tech Support.

(And I used to work for a cable ISP.)

What I get here is that the Dashboard is using the OS’s default “send email” method. It tells the OS it wants to send email, then the OS uses its settings in its default email client to send the mail.

So on your Mac Pro, the OS is using Entourage’s settings to send email.
On your Mac Mini, likely Mail isn’t set up, so the OS might get the request to send an email, but it doesn’t have settings so it can’t really send it.

It’s similar to how, on the Windows side, when you click a mailto: link and haven’t set up Outlook Express, you get prompted to enter the email settings for the SMTP server, etc.

If you can, just give Mail your SMTP server, username and password, without IMAP or POP server. That way it’ll only be able to send, not receive.

Do I have to have Dashboard running at all times for the email alert to work? I typically don’t leave drobo dashboard open, but if the email alerts only work while it’s running then maybe I’ll start!

I believe that’ s the case, regardless of the OS. That’s why Dashboard needs to be completely rewritten, so that it runs as a deamon service that the GUI can then interrogate.