Generally unable to access Drobo 5N

Dear DroboSpace,

A few weeks ago I was “cleaning up” my Drobo 5N using Drobo Dashboard, just removing some old shares that I didn’t care about any more. During that operation the Drobo stopped responding to Drobo Dashboard commands. On further inspection it appeared as though the Drobo had stopped responding completely (the activity light was fully on). When I restarted the Drobo Dashboard application the Drobo could no longer be found. It was almost eighteen hours until I had time to really pay attention to the Drobo again, and it was still in the same state, and still invisible to the Drobo Dashboard.

I’m a software developer, and I have a good understanding of networking. So I decided to see what I could do. I had the Drobo configured with a static IP ( so I pulled up terminal and was able to ping it with no problems. I wasn’t able to smb://, or even ssh to the Drobo. I got a connection refused message. I tried directly connecting the network cable to my computer, but no luck! At this point I was pretty frustrated, I powered down the Drobo forcibly (because it was still locked up).

About a day went by and a very nice friend of mine lent me her Drobo 5S and I followed the documentation to transfer a drive pack to a new Drobo, and it worked like a charm; all my data was available on the borrowed Drobo. My Drobo was another story, it wouldn’t come back to life. I tried resetting it using the pin-hole, which successfully removed the static network settings I had in place. I also tried leaving it unplugged for about a week, and opening it up and disconnecting the battery, same. Nothing has worked.

I reached out to Drobo Support but since my Drobo is out of support they wouldn’t even try and help.

Help me DroboSpace, you’re my only hope!

Best Wishes,

  • Simon

Do you have one spare drive somewhere? You could remove your diskpack and replace it with a single drive just to check if the enclosure is ok. If you manage to contact your Drobo with the single drive, then you can try to find out why the original diskpack is giving you trouble.

One of the reasons why is, as I mentioned in another thread, that one of the drives is about to fail but has not yet triggered the Drobo’s failure detection. You can take the drives to a PC and check the SMART counters to see if that is the case.

Someone recently found out that the DroboFS has a couple of serial ports: one gives a root console to the Linux system, one gives access to the vxWorks core. I wouldn’t be surprised if there is an equivalent couple of serial ports on the 5N.

Excellent question @ricardo; I do have two spare 500GB drives. They were previously in the now inoperable Drobo. I’m reformatting both of them to prevent whatever data is left on them from effecting the test.

An extra bonus question: Should the Drobo be accessible without any drives inserted? I assume not. I ask because it does receive an IP address, and is also responsive to pings.

Thanks for your help!

Actually, yeah, the Drobo should be accessible without any drives in. In fact, with a little bit of tweaking of the init scripts you can even get an SSH session very early on. Unfortunately, to tweak the init scripts you need either a serial console or a working diskpack (so you can install an SSH server to edit the init scripts).

I tired the 500Gb disks with no luck. I tried re-formatting them (writing zeros to all sectors) and still nothing. I think the enclosure’s init scripts are whats messed.

You mentioned that a user had found said serial ports on their Drobo FS; I’ve peeked inside (read: completely disassembled) and found what I believe are serial ports. I ordered and received a serial to USB cable. I’m now wondering if you can point me at the work the other user did so I can attempt to follow in their footsteps.

Undoubtedly uncharted territory, but at this point its this or bust.

Thanks for trying. The information on the FS is summarized here:

If you do manage to get in, please do share the results with us.