Gen3 won't mount or even show up in disk utility

I’m pulling my hair out here. I’ve followed all of the suggestions on the forum and all of the KB articles. I’ve tried literally everything from updating the dashboard to uninstalling and reinstalling it, multiple cables, restarting machines & devices, etc.

No matter what I do, I can’t get the drobo Gen3 to mount on my Mac. I’ve updated to the latest version of Sierra 10.12.5 and had the same trouble with El Capitan 10.11.6. I can’t even get the drive to show up in disk utility, Disk Warrior, or even show itself in the USB 3.0 Device Tree in the Mac System Report. The lights on the drive show that everything is in working order. After a while of no luck mounting, the drive goes into a standby mode of sorts where only the green power light is on.

And of course Drobo tech support is useless since the drive is a whopping TWO years old (this is my 2nd drobo btw… the first one failed due to “hardware” issues.

Please help!

I don’t know much about Macs, but could this be a USB driver issue instead?

Macs don’t have a way to edit or update USB drivers. But I’m sure it’s related to that somehow. I am most likely on a pretty old version of the firmware for the drobo, but if I can’t connect to it, I can’t update the firmware.

hi adam, do you have any way to try connecting your gen3 to a different computer at all, for example maybe if a friend visited you with their laptop, just to see if it can mount that way?

this could help pinpoint this specific mac, or if it is a usb port problem for example.

I just tried a 2nd mac that was older… still absolutely nothing. Doesn’t even show up in the USB bus in the system report. Tried two different cables too. Drobo sucks ass. This is the 2nd drobo to completely fail on me over the years, and the only way to get my data back is to buy yet another one.

Before making it possible, the individual should learn something good knowledge regarding the parent window.This SpeedyPaper review is useful for the betterment of this solution.