Gen2 to Gen3 Drobo. My Story.

Hi Guys,

I wanted to write a little about my moving from Gen2 to Gen3 Drobo as i haven’t seen too many other posts about it and spoiler i’m super impressed so far.

I bought a Gen2 Drobo with DroboShare back in July 2009. I was reorganising my media library at the time and wanted a central place of storage to run iTunes from. I remember having some problems with seagate drives at the time, but returned them for Western Digital Greens and ended up loaded with 2x1TB and 2x2TB which seemed like it would last me forever.

And it has, mostly. I never did add any more drives. As I got full from time to time I took it as a sign to delete stuff. Do I really need every episode of Alias and Charmed ripped from DVD? especially as they’re now on Netflix, so i’ve been pretty good about clearing out unwanted stuff. my iTunes library hovers at around 3GB.

I stopped using the DroboShare years ago when it was dis-continued and no longer supported in the latest firmware. Instead, plugging the Drobo directly into my Time Capsule using it’s ‘AirDisk’ function to share the drive over the network. Speeds were comparable and all has been running well.

Five years on and I’d seen the Thunderbolt Drobo 5D and been tempted. I’m a video editor and use thunderbolt SSD drives to edit from with USB 3.0 drives for larger storage. The SSD died a month after getting it. Luckily I didn’t loose too much and Lacie replaced it, but it rang an alarm bell that I shouldn’t be juggling my data across a bunch of different places. I had back ups but it was getting hard to keep track of things. I needed a long term plan.

I loved the Gen3 Drobo when it was announced but had to wait for funds and downtime between projects to make the switch I was planning. This month I bought a Gen3 Drobo with 3x 4TB Western Digital Reds. This would be enough to consolidate everything I was working on and leave room to grow with a spare slot. Having never really used the Drobo Dashboard before now other than random times throughout the years I was quite impressed with how that’s come along too.

Everything worked great. I was a little worried about the mount / dismount time of plugging the Drobo in directly but it works like any other drive. The read/write speeds I’m getting from the Reds are around 220/180. More than enough for editing. In fast it’s faster then the USB 3.0 drive i’ve been using for overflow.

I was so impressed, I immediately wanted to update my Gen2. I was looking at the Drobo FN which would seem like the logical choice for media streaming. But realised the FN disk pack wouldn’t be compatible with the regular Drobo as they use different file systems. I liked the idea of having two Gen3’s around so if the worst happened I could swap disk packs and carry on working. Which means rather than an FN it was another Gen3.

The arrival of the second Gen3 was less impressive - though this wasn’t Drobo’s fault. It basically came in a big box with no packaging. No white polystyrene chips or plastic packing. Just the actual Drobo box in a cardboard box twice its size and nothing else. I took photos. Worst unboxing ever, lol. Luckily the box had no signs of damage and the packaging inside the actual drobo box is great. Just a shoddy way to deliver something from the seller (cue angry email to reseller).

I loaded this with 2x 3TB Red drives having worked out that would give me the same capacity as I currently had for media and then could take the 2x 2TB Greens from the Gen2 and use them in the new one.

Why didn’t I just swap the disk pack over from Gen2 to Gen3? There was some confusing as to whether or not I could. Only disk packs formatted after a certain firmware revision could be upgraded. I’ve been rocking the Gen2 so long I figured I probably couldn’t and it’s better to copy across and start fresh anyway.

Here’s where I made a tiny mistake. When setting everything up I noticed the hard drives in the Gen2 were dusty. So pulled them one at a time to wipe them clean. Letting Drobo recover after each one. With the last one I must have left it too long before I replaced it as it triggered a rebuild. Which means while my data is accessible it’s much slower to access.

That was three days ago. The rebuild should finish today and I’ll copy everything across over night, ready to carry on from the Gen3.

So that’s my story. I now have a huge archive or everything I’ve worked on for over five years which will be super handy for a clips show I’m putting together where the ability to randomly pull footage from one central place will be invaluable.

The Gen2 is still going strong. Not sure what I’m going to do with it yet. Might use it for further backups or donate to a friend.

So, that’s my story. I hope it helps anyone else thinking of upgrading. Hopefully you won’t make the mistake I did of triggering a rebuild lol.

nice story :slight_smile:

i think you made a good choice getting a second gen3, rather then ending up with a gen3 and an FS.

if you do a search on syncback or mozy on the forums, there are some detailed posts about how one of my backup methods involves backing up a gen1 onto a gen2 using syncback.

if you can spare the second gen3 for use as an extra local backup/mirror of the actual DATA files you have on the first one, i think it will be good.

having an offsite backup of very important / sentimental stuff etc is also a good idea just in case.

Cool, thanks for the tip :slight_smile:

The story took a little longer to play out. I think it was another few days before the Gen2 eventually finished its rebuild. Then it took a few more to copy everything totally of it even at max USB2 speed. It’s kinda made me want to dispose of all my USB2 devices lol. But everything is up and running now.

The remaining drives now serve as backup. Though I take your point about off site backup. I saw the 4TB Seagate USB3 external was on sale for around £89. I might have to pick something like that up. Make a 3rd backup and then leave with a friend or at the office for safe keeping.[hr]
Oh, just a note about the Drobo Gen3 over AirDisk via my time capsule. It reads/ writes at about 12MB. More than fast enough for streaming but i’ve noticed the accessing and wake up times are snappier now too. Whether thats sole the new Drobo or a combination of new Drobo, the new iTunes and Yosemite i’m not sure. But it’s welcome all the same :slight_smile: