GEN2 Data intact but missing volumes that used to be there

Today I started up my computer and only one volume out of 6 on my GEN2 Drobo mounted, but that one volume is now read only and not all the files on it are available in the finder (111GB out of 1.1GB). The other volumes I had on this Drobo show up as unformatted volumes in Drobo Dashboard. However if I check the overall used space in Drobo Dashboard, it shows almost 6.5TB, the amount of data that is supposed to be on all the volumes together.

I tried restarting everything, swapping to another power adapter and Firewire cable, plugging in after the comp is started, and I ran Disk Warrior. Disk Warrior sees several of the missing volumes (along with phantom unformatted ones) but there doesn’t seem to be any way to mount the missing volumes to repair them. I haven’t run Disk Warrior on the one volume that is mountable yet because I don’t want to cause more trouble unintentionally until I know how to fix this.

I know the data is on there. I just don’t know how to access it or restore the missing volumes. I just ran Disk Warrior on all of the volumes two weeks ago and everything came up clean. The drives are all showing happy green and they are quite new, so I’m sure they are fine. I don’t want to do anything to lose the data on here. Is this a hardware problem?

Can anyone offer a suggestion for how I should proceed to repair this problem?


Some explanatory screen caps…

System Info http://www.vintageip.com/pics/drobo00.jpg
System Info on Drobo http://www.vintageip.com/pics/drobo01.jpg
Drobo Dashboard Status http://www.vintageip.com/pics/drobo02.jpg
Drobo Dashboard Capacity http://www.vintageip.com/pics/drobo03.jpg
Drobo Dashboard Volumes http://www.vintageip.com/pics/drobo04.jpg
Disk Warrior Mounted Volume http://www.vintageip.com/pics/drobo05.jpg
Disk Warrior Unmountable Volume http://www.vintageip.com/pics/drobo06.jpg
Disk Warrior Invisible Unmountable Volume http://www.vintageip.com/pics/drobo07.jpg

(just linking to your other post)

I had a similar issue back in 2009, and Disk Warrior ended up fixing the unmountable volume for me.

Disk Warrior will not modify your file structure (so they say) until you get to the end (after the scan) and click REBUILD, so it should be safe to run and learn what it would try to do.

I notice in your screen shots that all your volumes say “Drobo”. Did you give them custom names at one point? I have noticed that sometimes Dashboard will forget the names of my volumes, but they still show up properly in Mac OS X.