Gen 3 won't mount (solved)

Attempting to set up new Gen 3. Followed quick start guide. After first power up, drive lights came on, then suddenly it just shut off, no lights at all. Restarted using power toggle. This time looked good with capacity lights stacking, etc. Then Windows 7 said driver failed to install. Rebooted computer. Then driver installed successfully and Dashboard saw the Drobo. Didn’t say anything about formatting drives, but said it needed to “initialize.” After that completed, it said it needed to reboot Drobo. It appeared to do another normal startup, but now, no matter reboot/restart, it ends up with a solid yellow power light, it’s not discovered by Dashboard, and it doesn’t show up as a drive in Windows. Device Manager has a warning symbol on a USB mass storage device saying it failed to start. When I try to update driver, it says it’s got the latest.
Any ideas? Thanks.

Mine as well. On a Mac. Drobo Dashboard 2.6 for Mac keeps crashing. Also won’t see my Drobo 2nd gen. Working with the support desk. Will advise.

My new 4-bay Gen 3 also has difficulty mounting, which I discovered was resolved on my Retina MacBook Pro by downloading the Drobo Dashboard 2.6 for Mac, a version not offered by simply updating from inside my Drobo Dashboard application. After this, my Gen 3 immediately updated firmware once the Dashboard was run, and would mount on my machine.

NOW however I still find that my current Mac Mini will not mount the device, even after updating Drobo Dashboard on that machine as well. It identifies the drive in System Profiler under USB devices, but Disk Utility and Drobo Dashboard and Finder all do not see the drive.

I’m having pretty much the same problem. USB driver errors installing, then it states it can’t start the device. The Dashboard doesn’t see it. I have to leave the Drobo on, power my PC down, boot it back up and then I can see it… If I have to do any sort of Drobo reboot requiring event, it will fail because my PC will not pick it back up again. It just goes in to the endless loop of yellow exclamation point on the USB device and I ultimately have to power the PC down and back up.

Also, the write performance, when I can actually mount and write to it is utterly terrible. Like 15-20 MB/s. This is using a pari of WD 3TB drives that I currently run inside my machine on a cheap RAID1 card and they run much faster. I am certain it’s plugged in to my USB3.0 jack as well because my Samsung Note3 works just fine and at USB3 speeds.

I’m so utterly frustrated with this product at the moment. Not a good showing for my first Drobo product.

Any of my other USBtoSATA adapters install, mount and transfer with no real issues, so I’m surprised that a product such as this is having these kinds of problems.

Can you verify that you are running dashboard 2.6 on your Windows 7 machine? Also, is this a desktop machine or a laptop, and if a desktop, are you connected to the onboard USB ports or through a USB 3.0 PCI card? Have you filed a case with support yet?

Can you advise that you did the safe shutdown and powered the unit down correctly prior to disconnecting it from your Retina display? Also, when connected on your MAC MINI, if you go to about this mac-> more info and then select system report, do you see the DROBO under USB? More specifically, do you see it under USB HI speed or USB Super speed? You may want to verify that your MAC MINI does have USB 3.0 installed, as I know it was only recent MAC MINIs that had USB 3.0, maybe in the last year or so. I would recommend connecting your GEN 3 to your retina display, collecting logs and then filing a ticket with support.

Can you advise further if the USB port you are using is the onboard chip, or if this is a PCI card? The DROBO will use the mass storage drivers, so checking the USB drivers may be pertinent in your case. Does the DROBO appear in the USB tree when you connect it? Have you tried other USB 3.0 ports on your PC?

Yes, running Dashboard 2.6. Desktop, using onboard ports. Yes, working with support.
Since last post I have confirmed it will work on USB 2, but was unsuccessful with three different USB 3.0 ports. I don’t have another PC here with USB 3.0 to test. I have updated the BIOS, chipset, and USB 3.0 drivers, as well, but to no avail. I noticed that the Dell USB 3.0 driver (Intel is not the latest from Intel, so now I’m investigating whether my machine is compatible. Maybe Dell is slow to update their drivers and downloads. Support’s latest suggestion is that it could be the USB 3.0 cable. Since the Drobo connected successfully once, albeit briefly before “initializing,” I don’t think it is the cable, and I don’t have another to try at the moment anyway.
So my next steps are updated USB 3.0 driver compatibility, and finding a replacement cable.
Thanks for your reply, and please let me know if you have any other questions or suggestions.

This issue is resolved, it was the USB 3.0 driver. I thought I had the latest driver when Windows 7 reported the driver is up to date. Then I discovered an updated version from Dell’s Drivers and Downloads for my PC (XPS 8500). When that didn’t work, I found an even newer (and working!) version directly from Intel. So my lesson learned here is that I can’t necessarily trust Microsoft or Dell to identify or provide the latest drivers.
Thanks to all who posted with comments, questions, and suggestions.

Yes, point well made. I would always recommend downloading the drivers from Intel for your specific USB chip set, as Intel will update their drivers more readily than DELL would. Definitely well worth the effort to check Intel’s site for the latest drivers for your chip set, I just updated mine as I noticed there was an update a few weeks ago and I’ve seen better performance on my USB 3.0 connections as well.

[quote=“darth_maul, post:7, topic:139592”]
Can you advise further if the USB port you are using is the onboard chip, or if this is a PCI card? [/quote] This is two sets of on board chips. One from VIA and one from Intel. 6 external ports (3 pairs) and they all act exactly the same.

[quote=“darth_maul, post:7, topic:139592”]
The DROBO will use the mass storage drivers, so checking the USB drivers may be pertinent in your case.[/quote] Those are up to date as provided by MS. The chipsets I updated just now and it did nothing. I should point out that my USB Printer, USB Phone, USB WiFi Dongle, USB Hub with iPod and iPhone, USB xD/SD/cF/T-Flash, USB Thumbdrives of various makes and models and USBtoSATA converter with various SATA HDDs and Opticals plus a USB 2.5 HDD Caddy all work perfectly on all USB ports. The only device not working properly is the Drobo… So, that’s just odd and frustrating.

[quote=“darth_maul, post:7, topic:139592”] Does the DROBO appear in the USB tree when you connect it?[/quote] Yes, if I reboot it and the PC in just the right order and exactly once. If for any reason the 2.6 Dashboard has to reboot the thing, it’s dead in the water, Yellow ! over the USB Mass Storage Device in Device Manager. I have to term the Drobo apps and services, power off my machine and power it back on for it to work

[quote=“darth_maul, post:7, topic:139592”]Have you tried other USB 3.0 ports on your PC?[/quote] Yes. 4 of them from 2 different controllers. I have even plugged it in to my USB3 enabled MacBook Air and it allows me to do some volume operations, but in the middle of trying to actually write to it, the unit spontaneously reboots.

Now the unit is just stuck in a reboot cycle with the blue lights getting to this point
hanging and then rebooting again.

Where * = lit solid and X = not lit.[hr]
I had to shut the whole thing down, pull the drives, put in two different drives, let it see them an format them. That stopped the reboot cycle and brought it back up. I put in the 2 drives that I started with back in it and it saw and added those to the group. I’m trying a different set of drivers and will wipe the whole configuration, install, your dashboard, all related files and registry keys out and start the whole thing from scratch and see if that fixes it.

[quote=“humanwiki, post:11, topic:139592”]

[quote=“darth_maul, post:7, topic:139592”]
Can you advise further if the USB port you are using is the onboard chip, or if this is a PCI card? [/quote] This is two sets of on board chips. One from VIA and one from Intel. 6 external ports (3 pairs) and they all act exactly the same.

If you can get the unit to recognize on your MAC or your PC, collect logs and file a support case. Either way file the support case, but they will be asking for logs so collecting them on either the MAC or PC would be helpful.

I stripped everything down, pulled everything apart, wiped the drivers, installed all new and updated drivers directly from Gigabyte, Intel and VIA just to make sure nothing was lingering. Rebooted after each new update/install, rescanned the device bus for hardware and let it do its thing. I got a little farther, but still ultimately have the Yellow ! mark with direct connections.

If I run the Drobo through my Belkin USB2 Hub (connected to a USB3 port – but, all 6 of my rear ports are 3.0), the device will power on, off, reboot, etc, just like I would expect it to. The Dashboard sees it and can administer it. The problem with creating a backup volume locking up the system isn’t present while using the hub. I can R/W to the device. The Green drive lights stay on (when it’s direct connected, they blink on, then off).

For whatever reason, when this thing is directly interfaced with my machine on either the VIA or an Intel USB3.0 port it fails and goes offline (failed to start error) whenever it reboots while Windows is up and running. Only a power off or restart corrected the issue. Now, I can correct the issue on the VIA ports by pulling the cable from the motherboard side and reconnecting it. (At least that’s better than a full system restart, but still far from working).

I’m still a little concerned about the future of my ownership of this device if it’s going to be this finicky with drivers and such. That’s a very big concern if I’m going to depend on this device to correctly house backups.

for your reference, I’m using a GA-Z77X-UP4 TH Mobo on Win7 64bit.

When I have time later, I’ll pull the logs and open a case to see why this is so dang difficult. I just don’t want to get in to a position that I have to be concerned with functionality every time I do a driver update.

So far it sounds like:
USB 2.0 connection works (through USB 2.0 hub)
USB 3.0 connection fails on both VIA and Intel USB 3.0 port

Have you tried a different USB 3.0 cable between Drobo and the system?

USB 3.0 has extra lines on the cable, so if you one/more of the USB 3.0-specific lines of the cable is faulty, that would explain why things fail on a USB 3.0 port but are fine on a USB 2.0 port (because the faulty lines are not connected).

Without another USB 3.0 cable to test with, we can’t be certain whether it’s a problem with the USB 3.0 interface on the Drobo or the cable, but at least we can confirm it that it is a USB 2.0 vs USB 3.0 problem.

Now it’s locked up and not even working through a USB2.0 hub. I did get it to work a few times after my last post on the USB3.0 ports and the speeds were still terrible at ~15-20MB/s writes. The lights are green on the unit, but the device scan in Windows just hangs now and the Drobo installing drivers window never finished unless I unplug the USB.

Also, my machine will not even boot or POST when it’s like this and plugged in.

I don’t have another USB3.0 cable like this I can use, just the one in the Drobo box. My phone uses the smaller dual plug ports.

Have you filed a support case yet? You probably should given the logged troubleshooting efforts, as well as the ongoing issues. I would recommend filing a case with support right away.

Yeah, that was an utter waste of time. I’m done with Drobo as a company. You guys really need to work on your support model, interaction and ability to actually converse with a customer. Not just hit them with broken links, tell them to “just wait for them to start working”, then not really answer any questions as to what’s going on and then to actually explain why you need certain pieces of information.

I had to fix my own issue by buying another USB card. Not once during my case did anyone even bother to try and explain why I was having issues. I don’t have time to deal with this kind of “support”.

I apologize that you had such a bad experience with support in your case. Can you advise if what model USB card you installed that got it to work? Your support case will be reviewed and we will be looking to improve this process for the future, again I apologize for the experience you have had with support.

Kind Regards,

Drobo Support

I am having similar issues. My new Gen 3 Drobo came in yesterday and I initially had difficulty for my PC to be able to detect the unit. I reinstalled the drivers and got it to detect but now on USB 3.0 I’m getting around 10-15 MB/s write speeds with 4, 4 TB Western Digital drives in it. I am running Windows 8.1 with 32 GB of RAM and a Asus Maximus VI Hero motherboard. I reinstalled the most recent USB drivers from the Asus website.

Is there a USB expansion card which others have had better luck with? Also does anyone have benchmarks for what they’ve experienced running the Drobo 3 on a Windows box?

I would recommend reviewing if there are any updated driver sets for your USB Chipset. I understand that Intel has integrated the latest extensible drivers into windows 8, so you may want to see if you can find anything specific for your ASUS motherboard. Can you advise if you have any other USB 3.0 devices connected to your motherboard, and if they are seeing similar transfer rates?

This customer just posted some performance for windows 7, which may provide some help.

For Windows 8 you should be able to see performance similar to what you may find on a MAC, as the buffer size on windows 8 was increased from windows 7. Please let us know if you have any further questions around USB 3.0 connectivity with your GEN 3.