Gen 3 weird behavior


I wondered if anyone else has had this same problem and what their solution was (if any). I have had a 3rd gen Drobo (USB) for 14 months. I have 4 WD 2TB drives in it. A few times since owning it the Drobo has complained that the last drive (bay 3/drive 4) is corrupted. Unplugging that drive and plugging it back in (with subsequent repairing) has fixed the problem.

Fast forward to 2 days ago. The power went out in my house and the Drobo was shut down. It’s on a UPS (as well as the Mac Mini it’s connected to) so it was not a harsh shut down. Upon startup, the Drobo complained that the last drive was again corrupted. Not thinking twice about it, I unplugged the existing drive and plugged it back in. The Drobo did not recognize the drive was inserted and is still wanted me to replace the drive. Thinking that the drive was indeed bad this time, I purchased a new 3TB (Seagate) drive yesterday. I inserted it into bay 3 (the bottom bay) and immediately the Drobo gave a red light for bay 1/drive 2 and still no light for bay 3/drive 4. So now it was green/red/green/off and was critical. The Drobo would not recognize the new 3TB drive in bay 3. I plugged the “old” bay 3/drive 4 2TB drive back in and it recognized it and successfully repaired. But it still thinks that bay 1/drive 2 is corrupted. I unplugged that drive and plugged it back in and it recognized the drive but now it doesn’t recognize bay 3/drive 4 again and while it is repairing/rebuilding drives 1-3 it wants me to “add a drive” in bay 3 even though there is a drive there that it just recognized!

Do I just have a corrupted Drobo? It seems unlikely that this is a hard drive issue given the flaky behavior. Any ideas on a fix?

Latest firmware (3.21) and latest Drobo Dashboard (2.6.10) on a Mac Mini running El Capitan (latest).


hi am just linking the 2 related posts together:[hr]
hi ben,
as i was reading it sounded as though the drive in the 4th slot was either starting to encounter some problems (or possibly the backplane)

i think having a powercut never helps a situation, though at least you had a ups.

can i check if the red light you now mention for the 2nd slot, is a solid red light, and if any lights are actually flashing currently? (such as still rebuilding?)

also, when you said that the drive in the 4th slot was corrupted, what was the drobo and dashboard doing to show this?

Hi Paul,
Thanks for the reply.
As soon as I plugged in a different drive in the 4th slot, the 2nd slot turned solid red. I unplugged the 2nd slot and plugged it back in and the Drobo then turned OFF the 4th slot light and rebuilt using the first 3 slots. Now, 24 hours later, I have 3 green lights and a yellow light for the 4th slot (all solid) even though there is a drive in the 4th slot. I’m scared to mess with the 4th slot drive as that is what got me into this mess. It’s like playing wack-a-mole because if I put a new drive in the 4th slot, it instantly says slot 2 is corrupt.

Edit: I have 4 2TB WD greens in the Drobo.

ok thanks for the info.

no worries its ok to be concerned - do you have any spare drives currently that you could use to do a verified backup of the data in the meantime? and then maybe that can help provide some more peace of mind to try some more slot work?

Yes, I have 4 hours left in the complete backup of the data. I am thinking of completely resetting the Drobo to default and reinitializing the hard drives? I have a new 3TB drive but now am unsure if any of my 4 WD green 2TB drives are actually bad.

Edit: Something is definitely weird with the Drobo as I do NOT have dual drive redundancy turned on and it now shows only 2 green lights out of 4 with one red and one off. But the Drobo is still useable. This happened just by rebooting the Drobo.

hi ben, ok thats good that you were backing up and hopefully your backup has finished by now successfully?

it sounds more like it is the backplane, (sometimes its just a loose connection and a full power down and eject+firm reinsertion does the trick, and then powering back up) but can i check if your drobo is perfectly flat on its surface, and if that surface is also fully flat?

would you be able to cross-reference the drobo’s led lights, with those on the dashboard?
(just in case the drobo blew an led etc)
also does dashboard still show the same info if you exit and relaunch dashboard?

if you now have that backup, i think its also a good idea to run a diagnostics log and to send to support, as it may contain useful info)

Hi Paul,
Here is where I am at. Full backup performed successfully. I noticed that on drobo’s website, it mentions that Disk Utility (Mac) can be used to correct any errors on the Drobo hard drives. I didn’t realize this was possible in the past so I tried to run it but Disk Utility failed when trying to run “First Aid” on Drobo.

The Drobo is flat and is never moved. The LEDS all work (i.e. not burned out). When I try to plug a hard drive back into a slot that the Drobo thinks is empty (i.e. no light), it still ignores it. The Dashboard shows the same information as the faceplate. I thought backplane #4 was a problem but now the Drobo has shown errors with backplane #2 as well as #3. Rebuilds in those cases have fixed it but I am still unable to get all 4 drives recognized at once. Thanks for any additional thoughts!

Edit: I was able to successfully run Disk Utility First Aid on the Drobo volume and it showed no errors.

Edit2: I shutdown the Drobo with Dashboard and it rebooted with all red LEDs. Therefore, I “Reset” and now all drives are green and recognized by the Drobo. I ran Disk Utility and all is well. Saving backup to the Drobo currently (will take 5 hours). Still not convinced there isn’t something wrong with my Drobo.

hmm its puzzling what could be the cause, though good that it has a happy ending…
the backplanes might be similar to bones on the spine where all the vertebrae are connected to the spine (if my medical knowledge is accurate) :slight_smile:

that being said, maybe one slot had worked its way a bit loose, possibly if a drive had not been firmly in place, or some strain affected another slot. as the gen 3 is fairly new i think its a good idea to raise that ticket with the diagnostics just in case.