Drobo

Gen 3 not mounting in Finder

Hello,
I am running Mac OS Sierra (10.12) on a Mac Mini (late 2012). All was working fine for a few days and then the Drobo disappeared from the Finder. Drobo Dashboard shows everything as fine and all the lights are normal on the Drobo. I ran disk utility and First Aid and it ran successfully without errors detected. I have safe shutdown the Drobo and switched it to another USB port (it’s never been on a hub). Has anyone else had this problem? I realize that Sierra is not “officially supported” but wanted to make sure this problem wasn’t unrelated before going back to 10.11.
Thanks!
Brian

Edit: FYI for anyone else with this issue. I used Time Machine to restore to 10.11. I purchased Disk Warrior (ouch). Disk Warrior fixed the directory issues and all is good now.

TL/DR; Buy Disk Warrior

hi brian, thanks for sharing your info (and how you fixed it)

am not sure about sierra, though i remember reading up about how it was not good to leave devices plugged into a mac, while updating or upgrading into el capitan… can you remember if maybe something like that happened when you went to sierra?
it could be that, though am glad you were able to sort things out and access the data again.[hr]
btw what does tldr mean?
in html programming, theres a TR followed by a TD very often :slight_smile:

Hey benichols,

I have the same exact problem here. Drobo wouldn’t show up in Finder anymore. Manual mount with disk utility didn’t work. I also had to run Disk Warrior to get to my file - BUT, after a secure shutdown and restart of my Mac running Mac OS Sierra I have the same issue again. Disk Warrior did help again, but guys what is going on here?

Btw, newest Firmware 3.5.2 and Drobo Dashboard 2.8.3 is installed.

Thanks for any suggestions…
Sven

(just linking to your other post here, with reply)
http://www.drobospace.com/forums/showthread.php?tid=145948&pid=201987#pid201987

Same thing happened to me today: returned after a day out and could not open Photos on my Mac (the library is located on my Drobo). Updated to the most recent version of both Dashboard and Drobo firmware, restarted several times, tried switching Thunderbolt ports on my MacBook Pro but no luck… Dashboard sees my Drobo and reports its health as “Good”, but no sign of my unit in the Finder. This is serious since I use my Drobo for my job. Hmm… not happy.

hi do you have a usb3 that you could try as a test twobikes?
it might be worth a test just to see.

being a das model, if you have acces to diskwarrior, (or at least disk utility) it might be worth running a maintenance check just in case something needs correcting there? (for example, on windows, if a program using the drobo or explorer crashes, i try an reboot everything and then run a checkdisk on each volume, 1 at a time) maybe a maintenance check could help fix things for you like it has for others recently too?

Same thing is happening to me. I’ve also recently updated MAC OS Sierra. It was working fine on Sierra and it was working last night, but then this morning I came to access files and it couldn’t be found. It’s not in finder but in Drobo dashboard it’s available and ingood health. In disk utilities it’s there but I can’t unmount it or anything. Tried rebooting the mac and the drobo several times. Unconnected, reconnected, used every single USB port. NOTHING. I too use this for work and I can’t access anything. Really really not happy Drobo… I’m not going to buy additional software to resolve this, it should work out of the box. What is the issue drobo???

btw, All drobo updates are up to date…

hi simon, do you know if you can find out whether any sierra-features are currently running?
for example, is maybe spotlight running an index scan and maybe locked out the drobo volume or something else like itunes or time machine?

Paul, thanks for the reply.

Regarding the USB3 you mentioned, were you referring to a cable? My computer “sees” the drive—and Drobo Dashboard is able to access the the unit—so I assume that means the cable is OK.

I ran First Aid (from Disk Utility) on the the Drobo and it found no problems. The volume is still grayed out, though, and will not mount.

Here’s something interesting: I tried connecting the unit to a second computer (an older MacBook Air running Yosemite) and had the same problem. So it seems that something on the Drobo itself went screwy—whether attributable to Sierra or not.

It’s encouraging to hear that others have had luck running DiskWarrior, but what’s the point if the problem just returns again? I hope this is a software issue that Drobo will be able to fix through an update in the (very) near future.

David

I’m having the same issue with my drobo currently.

I had the problem last year a few times and disk utility could not find it; Mountin could not keep it from unmounting; Disk Warrior did work. iMac, was El Cap. Happened occasionally, and this computer only used occasionally- thought it was my fault. Now on Sierra happens once or twice a week. Disk Warrior rebuilds directory and it mounts but obviously something wrong. Last year my iMac was in the recall program for HD problem and went in for warranty replacement (not fusion drive, just 3T spinning). I can’t recall if mounting problem started before or after.
any ideas?

thanks twobikes, yes sorry i somehow forgot to type the word “cable” :slight_smile:
in most of the cases in the past, it was macs and firewire that were having problems, and in some of the cases it was down to a cable that suddenly had some problems (such as one of the wires on a pin/connector or just a cable that got squashed somehow…

…though now that you mentioned trying in another computer, it also sort of eliminates a bad port as causing problems.

while it is still not known what definitely causes the problem, for you (and abaggett), it could possibly be that sierra caused something, and that its a case of the damage already being done (and hence why an older mac version also has the current problem), but its also interesting what mark found…
maybe something has changed from apple from elcapitan onwards which doesnt play as nice with non-apple products?

(btw maybe time is passing by slowly, but it still seems to me like El capitan just got relased recently… why is sierra here now too - slight joke on the way too… but maybe the next new mac version will come out next month called “predator”) :slight_smile:

i sometimes think that os versions are getting pushed out way to quickly nowadays, and while im not old, and im not danny glover, theres a chance that were getting too old for this SH(enanigans) :smiley:

also, abaggett right about now sounds cool (with ham and cheese) :slight_smile:

My Gen 3 Drobo finally mounted after doing volume rebuild with Tech Tool Pro. How long it will last I don’t know.

I’ve been suffering the same problem.

Re Formatted drives twice. Had to pay for 3TB discs to be sent from USA to UK.

Not happy with the stability of this product. If you don’t come up with a solution roadmap I’m likely to be sending back to Amazon for a full refund. This is not funny. I feel like I’d be better off with two USB drives and manage my own back up process.

Please update with suggested fix.

Regards

I’m experiencing the same issue. My Gen 3 will not mount after upgrading to macOS Sierra. Drobo Dashboard shows that everything is supposedly fine. I have the latest firmware and Dashboard (2.8.4) will all lights green.

If anyone from Drobo monitors these forums, push out a fix quickly!!!

After experiencing problems after upgrading to Sierra, replacing all the drives in the unit, and getting ALMOST 3 weeks of successful usage of the drive (specifically the Time Machine volume) after turning off Power nap, I am here again. ( Original post http://www.drobospace.com/forums/showthread.php?tid=147059 )

All was going well until yesterday when the drive reported that both volumes were improperly ejected, yet they still showed in the Finder and I could access it. I tried to initiate another backup, which started, then midway through the process it again reported that it was improperly ejected which of course cancelled the backup.

Today I cannot even mount the Time Machine volume and Disk Utility reports that it is corrupted, which is just perfect because I need to access something on it. This is getting ridiculous.

Drobo Gen3 doesn’t mount in finder after firmware update. “Drobo-3rdGen-firmware-3.5.3”.
Drobo was mounting and working fine until update of Drobo Dashboard(2.8.4) then firmware update. Running late 2012 iMac 27" macOS sierra version 10.12.1.
Drobo Dashboard can see the drive. But is calling it Drobo disk pack with heath Good. Gives performance values, 93 IOPS, Read 2MB/s, Write 0MB/s.
Volume Name is Drobo with a File System of unknown, Used -, with a Max Capacity of 16TB.
Get the error “Error occurred while uploading the Diags for your Drobo device” when trying to do the “Get Diags”. Even though a zip file is saved to the desktop.

What should I try to get the Drobo to mount?

Contact Drobo support then join the queue. I will share the solution I’m given when it works, otherwise I’ll let you know when I’ve returned the drobo to Amazon for a full refund.

4 weeks of non use. I’m not sure how much patience I have.

Regards

I waited for a quality solution to this problem from Drobo.

I got this today.

Starts ----
it looks like you are encountering file system corruption due to a sleep issue on the Mac.
I’d go ahead and have First Aid tool repair the drive. If that won’t help, then please purchase Disk Warrior and have this tool repair the drive.

I’d recommend you to turn off power nap on the Mac for the time being as a new firmware is being worked out.
Ends -----------

I tried First Aid tool on Disk Utility to no avail. I feel that purchasing a $119 package that may or may not solve a Drobo issue to be a very poor service which I am unlikely to continue to use or suggest to others.

Fortunately I bought it from Amazon so will push for a full refund as it’s not fit for purpose.

Sorry for the negative update but it is a truthful outcome of my real circumstances.

Regards

John

hi hemsley, that is understandable and fair enough,
i guess if you still do have your drobo, maybe if one of your friends happens to have diskwarrior, it probably would be good to invite them for a cup of tea and then if you happened to “try” it on your drobo, you could see if it did actually fix things for you (without wasting any money in case the makers of diskwarrior dont offer any refund if it didnt work)

(then if it did actually fix it, you could sort out any moral issues about getting it, but only after you at least knew if it would fix it for you)