GEN 2 - Cannot Access Drive - Help

My GEN 2 is setup with 2 drives shown as (Drobo) H: and (Drobo) J: Suddenly I can no longer access H: and it now show as Local Disk H: vice (Drobo) H:

It takes up to 5 minutes for Dashboard to find the attached device and then only shows 1 volume. Also when trying to access with explorer, it recognizes but is initially slow to access the J: but does show contents and as long as I do not close explorer it is fine after the fist access. The Local Disk H: however after a minute of to gives error " H:\ not accessible".

I am using WIN7 Home Premium. So far I have tried uninstalling dashboard 2.6.4 and re-installing; uninstalling and re-installing 2.5.x. I have also re-installed the firmware 1.4.2. Nothing restores the H: to Drobo or explorer accessibility. I have no obvious errors showing, all 4 drives are green and 3 blue showing plenty of storage space remaining.

I had ordered and received a new 5N today but do not want to move the HDs over until I exhaust all possibilities to save my data (~20K pictures).

Oh yeah, I have tried on both my desktop and laptop. The only difference is that the drive letters chance due to extra internal HDs in the desktop.

Have you tried chkdsk on the affected volume?

No sir, that is one thing I haven’t tried. Thanks for the suggestion.[hr]
KelvinY – Thank you sir. The chkdsk worked perfectly an now I can migrate everything over to the 5N. Don’t know why I didn’t think of it but you did and I am so grateful. Blessings.