Drobo

Fuppes question for Drobo FS

I am new to using DroboApps, so bear with me. I have the DroboApp configuration utility app working, as well as Fuppes installed.

I can get to the “configure” link on the utility page. When I am there, I don’t understand the format for adding additional folders to the shared list for the DLNA server.

The format seems to be /mnt/DroboFS/Shares/DroboApps/fuppes/media by default.

I don’t want all my media in the DroboApps share though. What format would I use to add a directory object for the default share Z: Drobo-FS vs. Y: DroboApps. I have tried /mnt/DroboFS/Shares/Drobo-FS/ but the PS3 doesn’t see any files.

Can anyone help out with some more detailed instructions regarding adding shared folders and anything else I should know when using this App?

Thanks

I have been reading the fuppes wiki, and I’ve come across some more information. I’m trying to get this to work on a PS3 by the way.

First off, it seems that fuppes is crashing when I tell it to rebuild the database while pointing to a very large directory (~1TB). I’ll have to work on that some more. I did copy one mkv file into the default /DroboApps/fuppes/media and told fuppes to rebuild the database, which worked. I can now see it in the directory. I’ll mess with adding directories later.

The mkv file I put in there will not play either. I added this section to the fuppes.cfg file:

VIDEO_ITEM video/x-matroska ffmpeg mpg video/mpeg mpeg2video 1800000 mp2 44100 192000

This places the .mkv information in the “status” page of fuppes config. I still can’t get it to play the file. If I have the line , then I get a “Media Server Error: A network error has occured (00000000)”. If I have the setting to enabled=“false”, I get “Corrupted Data” when I try to play it.

It seems that if you go to the “status” page of fuppes config, it says Video Transcoding (experimental) = false. I have tried to find out how to enable it, but everything I’ve found says it has to be compiled with that option enabled, and that it is not just a software switch that can be turned on and off.

Does anyone have a build of fuppes for Drobo FS that has been compiled with this on? Does anyone have a newer version of fuppes compiled in general? The fuppes site shows version 660 as being the latest released version, while the DroboApps version is 578. Are we able to compile fuppes as it stands and use it on Drobo or does it have to be customized before it will work on Drobo?

I also ran across this tidbit on the site regarding a setting that has to change since the 2.70 PS3 firmware.
http://fuppes.ulrich-voelkel.de/wiki/index.php?title=Ps3

As of the firmware update 2.70 - 5th April 2009, you will need to alter the user_agent description from 1.00 to 1.50 in the config file.
<user_agent>UPnP/1.0 DLNADOC/1.50</user_agent>

Are many people using Fuppes? I don’t see much talk about it on this board. I would think using the Drobo as a media server would be quite common.

I’m about to join a Drobo FS teleconference with Sarah Sawulski. I’ll ask some questions regarding this application and the revision.

Well, she didn’t get to my question about revisions 578 and 660. The quest continues…

Bump? Does anyone on this board use FUPPES?

Im in the same boat as you. It’s not so user friendly!

I got it working after lots of trial and error, in addition to an email to the app publisher…

Mine is working fine now.

  • Jon

I eventually got FUPPES working, but switched to MediaTomb and removed FUPPES completely.

http://www.drobospace.com/forums/showthread.php?tid=1254&highlight=mediatomb