Drobo

Full power removal reset needed for FW 800

Here’s an interesting data point. I have two Drobo S units. On one of them, both Firewire 800 ports became unresponsive: plugging it into either of the two Macs I have with FW 800 wouldn’t wake up the unit, but USB or eSATA would. (One of the Macs has no eSATA ports, hence the keen interest in getting FW 800 working.)

I used the power switch to power the unit down, then pulled the power connector out of the chassis for about thirty seconds. This cure has been known to be necessary to get certain balky Mac Firewire controllers to unstick themselves, so I figured it was worth a try.

Rather to my surprise, it worked. FW 800 now works perfectly on that unit. So apparently the FW controllers used by Drobo Inc. in their Drobo S units (at least) are susceptible to the same malaise as some (generally older) Macs, and can be cured by the same method.

Thought I’d document this in the forums.

You shouldn’t have to reboot the DroboS to get the FW800 ports to work. If you see this happen again, please open a trouble ticket with an attached diagnostic file.

Good data point. (Good) Firewire interfaces have resettable fuses that generally require a full power-down to reset. I’ve had similar happen on desktop Firewire cards in the past, if there’s a short or surge, it’ll knock the port offline until the system is completely powered off, discharged and powered up again.

…but based on Sky’s response, perhaps this is not the case for Drobos…

I suppose I need to qualify my answer. If the unit is needing to be constantly rebooted just to get it to respond over FW, then it would be best to open a ticket with a diag. I have seen power outages cause a Drobo to need a reboot to get the FW connections working again.

That in fact was the likely cause of this outage: we had a couple of power failures in one day, and I noticed FW 800 wasn’t working after those events. On a Mac, you need to remove all power to get the FW controller back, as the earlier poster notes. I just did the same thing to the Drobo on general principles and it worked. Whether a simple reboot would have done the trick without bothering to remove AC power is not something that I bothered to try, given that on a Mac it doesn’t work like that, and it was easy enough to do. Bigger hammer technique.