Drobo

ftp into DroboFS with pure-ftpd and first ls causes delay

I am wondering if anyone else has noticed this.

When I ftp into my DroboFS (running pure-ftpd) and type ‘ls’ there seems to be a delay of about 20 seconds before it responds. At first I assumed it was probably the drives spinning up. I then tested ftp-ing in several times in a row. Each time, there is the delay on the first ‘ls’ command, but any subsequence ‘ls’ command during the same session returns immediately.

Not a big issue, but I was just curious as to why this happens.

Burl

It is probably caused by reverse DNS failing.

Is there something I should change in resolv.conf?
All i see in there is two lines:
nameserver 192.168.1.1
nameserver 0.0.0.0

Burl

Probably not since you’re probably coming from an rfc1918 IP address (192.168.1.1)

Try adding your workstation IP to /etc/hosts (on your drobo):

192.168.1.100 workstation.local

(where 192.168.1.100 is replaced by your real workstation IP address).

That would be difficult since I am coming in through the internet and the ip address of my workstation would be different most everytime I connect to the DroboFS.

Oh, ok… then it won’t be that.

I’ll download the same ftp package you’re using and see if I get the same results. If I do, I’ll debug it and get back to you.

I tried this today from my home system and the response is instant. I tried this both from ftping to the local ip address as well as ftping to the internet domain name.

I try from work and still the same thing.

$ ftp ftpuser@xxxx.homeftp.net
Connected to xxxx.homeftp.net.
220---------- Welcome to Pure-FTPd [privsep] ----------
220-You are user number 1 of 50 allowed.
220-Local time is now 11:08. Server port: 21.
220 You will be disconnected after 15 minutes of inactivity.
331 User ftpuser OK. Password required
Password:
230 OK. Current directory is /
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
229 Extended Passive mode OK (|||35284|)
(Delay of 20 or 30 seconds before the following comes back)
ftp: Can’t connect to `173.74.xxx.xxx’: Operation timed out
200 PORT command successful
150 Connecting to port 51211
drwsrwsrwx 2 0 0 4096 Apr 25 19:21 Docs
drwsrwsrwx 2 0 0 4096 Jun 3 07:49 Friends
drwsrwsrwx 2 0 0 4096 Apr 25 19:21 Movies
drwsrwsrwx 2 0 0 4096 Apr 25 19:21 Pictures
226-Options: -l
226 4 matches total
ftp>

I do know that 173.74.xxx.xxx is the ip address that is currently assigned to my router and DynDNS shows that it is currently associated to xxxx.homeftp.net.