Drobo

FS slow to initially index

Hi,
Been a while since I’ve posted, but just got a new Drobo FS installed on my home network & was looking for some feedback on it.

I’ve got the FS plugged into a hardwired gigabit network, and with the latest 1.1 firmware it seems to be able to serve a few users at a time ok (e.g. managing to stream a couple of SD movies and music to 3 different clients without stuttering).

However what I do find a bit frustrating is that when I initially open a share, and then start to ‘drill down’ through the folders & files, the first time I do it, there’s a long delay (2-3 minutes) where the FS appears to index the files (is that the right term). So I have a blank finder window, with the spinning thing whilst this is going on. Once the files are displayed, I can flick through them quickly. If I don’t open the share again for an hour or so, it’s back to the long wait.

Is this standard behaviour, or is there something I can do to improve response time ?

For info it’s all Macs on my network (so AFP). All network users connecting at gigabit speeds (according to the switch !).

Andy

2-3 minutes seem excessive.

My experience has been that if the FS put the disk pack to sleep it may take a few seconds (less than 10 usually) to spin up all the disks, but after that it is usually instantaneous.

It could be a problem on the client side, though. How many files do you have on that structure? It is a know problem that folders containing a lot of files (especially pictures or music) may take a while to load, since clients tend to peek inside each file to grab thumbnails and metadata. Since each new file requires a new connection, this may be the cause of the slowdown.

You could try browsing the folder structure using a view that has as little extra information about the content of the files as possible, i.e., a simple list without metadata columns, and disable any previews.

Thanks Ricardo,
I think you’re right as the folders that I’m accessing contain music & photos. I’ll give your suggestion a go & report back.
Andy

I’ve had this problem too – it’s really frustrating. I’ve not been able to figure out a workaround yet, and technical support has told me that this is “normal”. I find that pretty hard to believe, since for folders with lots of files, the Drobo FS is basically unusable.

If Mac builds thumbnail databases like Windows, it may take a little bit to go through and build that, but 2-3 minutes is quite a while… unless you have thousands of files in the same folder and not subfolders.

MY understanding is that AFP is a really inefficient. Samba seems to be a lot more effective. You may want to consider a switch.

Or even better, take the plunge and go for NFS. That is the lightest protocol, although it can be a bit of a pain to setup on the FS. Navigation and folder browsing is quite snappy on my MBP.

It took me a while to figure out a simple (albeit a bit insecure) configuration for the uNFSd DroboApp. Check it out here.

Sounds like an AFP issue then. The folders that I have bother with are pretty full (the biggest being music with 984 folders & a total 560 GB of data - music & movies).

What would switching to Samba involve ? Is this a good alternative for me given that with the exception of one machine all my network clients are Mac based ?

Andy

Instead of command+K then “afp://…”, use “smb://…”.

Just make sure that you don’t use extended, special or Unicode characters on filenames. Otherwise there should be no problems. Also, you might have trouble settings Unix-style file permissions (not a big deal if you do not use them).