Drobo

FS Firmware 1.0.5

I see this just came across the wire.

I see from the pdf, the following changes:

• • •
Fixed Drobo FS Disk Drive Spin Down support (#10-097) Minor improvements Previous Fixes from 1.0.1, 1.0.2, 1.0.3 and 1.0.4
o Improved AFP support when there are multiple users connected to the same share o Fixed problem where the MTU setting was not used when the Drobo FS has a DHCP
assigned IP address o Enhanced the handling of file copies when the Drobo FS is running low on capacity o Fixed issue with volume renaming when using the same share name o Enable Time Machine support on Drobo FS from Dashboard
http://support.datarobotics.com/app/answers/detail/a_id/435
o Apple Filing Protocol (AFP) as the default file service for Mac OS X

Any idea what the “Minor improvements” are?

Unfortunately, the problem with DroboDashboard overwritting of /etc/passwd file was not corrected yet.

Burl

As I understand it, it’s not Drobo Dashboard overwriting the passwd file, but the FS itself.

How can you see what password your drobo is currently configured with? It’s just a bunch of stars in the tools dashboard.

Bhiga, no matter where it gets overwritten, it is caused when making a change to a user in the admin section of the tools, or when rebooting the FS. It is still a problem that DRI needs to correct so that when using the DroboFS as a FTP server, there doesn’t need to be changes to the passwd file after every reboot or changes to any of the users.

void2258, this only effects people who are using DroboApps. If you’ve installed the apps and ssh into the DroboFS and look at the password file, you’ll see what I’ve been talking about.

anyone having trouble SSHing into their drobo after this update? I"m getting a connection refused.

Yes,

After the FW update and reboot, I was getting connection refused when I tried to ssh into the DroboFS. I did one additional reboot of the DroboFS and all was back to normal.

Burl

I didn’t have any issues with SSH after updating to this firmware. If rebooting doesn’t fix it, try removing the dropbear app, restarting, and then reinstalling the dropbear app. I had that issue once and that was how I fixed it.

As far as the password issue, i’m pretty sure this doesn’t fix it. My support ticket for it is still under investigation.

Has anyone with the drive spin down issue having luck with this update? After updating, my drives still don’t appear to be spinning down. I went as far to eject one to make sure it was spinning after 30 minutes…and it was.

2nd reboot after the initial reboot did the trick for me.

I have installed the new firmware. A second reboot was necessary. My drobo doesn’t spin down anything. Neither the fan nor the drives.

[quote=“Microxot, post:4, topic:1656”]
Bhiga, no matter where it gets overwritten, it is caused when making a change to a user in the admin section of the tools, or when rebooting the FS. It is still a problem that DRI needs to correct so that when using the DroboFS as a FTP server, there doesn’t need to be changes to the passwd file after every reboot or changes to any of the users.[/quote]
Agreed - just pointing out that people looking at the Dashboard Release Notes will likely never find what they’re looking for.

I have to correct my previous post. I changed the spin down setting to a different value and now it’s working. I just wish the fan would be less noisy.

rebooted mine twice as well to get the new FW to take 100%

I have installed the new firmware and now my FS will not appear inDashboard on any if my networked Macs. Can anyone advise what todo here? I do not have ssh enabled.
Thanks

I had the same problem with mine.
After the firmware update and reboot, Drobo Dashboard couldn’t find the FS. I could ping it but couldn’t connect to it with SSH or Samba.

I left it for a while then restarted it via the switch on the back and it came back up fine after that.

Thank you. I will give that a try… It’s interesting that ssh did not work for you.

still hasn’t fixed using multiple email addresses for drobo alerts on the drobo itself. says you can separate them with “,” commas but it won’t accept them. the desktop agent works just fine.

Yes. Several restarts later, I’ve now uninstalled and reinstalled dropbear, that finally got me past the connection refused I was seeing. Now though when I try to login with the root password I had set I’m told it is wrong, and when I try to login with the default I get thrown out.

root@172.16.42.222’s password:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Requesting authentication agent forwarding.
debug1: channel 0: free: client-session, nchannels 1
Read from remote host 172.16.42.222: Connection reset by peer
Connection to 172.16.42.222 closed.

The dropbear log file is saying the following:

[572] Aug 02 22:32:27 password auth succeeded for ‘root’ from 172.16.42.209:53536
[572] Aug 02 22:32:27 exit after auth (root): failed to revert euid

One more reboot after that seems to fix it. But then I had it working before after the 1.0.5 firmware loaded and it stopped on a restart… so hopefully it will continue to work.

FWIW, upgraded from FW 1.0.4 to 1.0.5 The Drobo FS still does not spin down, even when all computers are turned off or asleep. JFYI, Before the FS, I had one Drobo v2 connected via a Droboshare, and that unit dis spin down.

What gives. Same OS same main computer, just upgraded from a v2 to an FS.

Try restarting the Drobo FS and your computer.

I have updated mine as well to 1.0.5 and the disks still do not spin down. I also tried to change the spin down time, and still no affect.