Drobo

(French) Comment configurer Pure-FTPd avec un drobo pro fs ?

Bonjour,

Tout est dans le titre.

Comment configurer Pure-FTPd avec un drobo pro fs ?

Ce que j’ai fait :

  • Sur le drobo j’ai plusieurs utilisateurs user1,user2 etc… avec des droits différents.
  • afp /smb fonctionnent en local et à distance et les ports pour tous les services sont ouvert.
  • j’ai installé ssh et Pure-FTPd
  • Pure-FTPd est accessible via la commande terminal ssh root@monip

Ce que je souhaite :

Que tous les utilisateurs n’ai pas accès aux points de partage en FTP mais q’une personne qui se connecte en anonyme ou avec un log personel (peu importe) puisse accéder librement au dossier public en écriture et lecture.

en gros faire du dossier public un point de partage FTP classique.

Actuellement le FTP fonctionne en me connectant avec user1 par exemple mais user1 à accès à l’ensemble des fichiers du drobo (vraiment gênant)

j’ai lu toute la doc de Pure-FTPd et le site/forums de drobo mais cela aucune technique marche.

pourtant sur Pure-FTPd.org ils disent “An excellent choice for newbies”

Merci d’avance pour votre aide.

Ce que je peux te conseiller est d’utiliser ProFTPd au lieu de PureFTPd. Il me semble que PureFTPd n’est pas vraiment fait pour les newbies.

Tu peux trouver ProFTPd pour le DroboFS ici: http://www.droboports.com/app-repository/proftpd-1-3-3d

Cette version possède déjà une configuration qui resemble un peu ce que tu as demandé, et le site de ProFTPd contiens des examples beaucoup plus faciles a suivre.

Attention: cette version de ProFTPd est compilée pour le DroboFS, mais tout le monde me dit que les DroboApp pour le DroboFS devrait aussi marcher avec un DroboPro FS.

j’ai effectivement trouvé proftpd sur internet mais je n’arrive pas à l’installer.

j’ai suivi scrupuleusement l’installation sur le site mais les scripts ne fonctionnent pas que cela soit sur le terminal macosx ou linux (ça marque des erreurs sur chaque ligne).

je ne comprend pas pourquoi ni drobo ni pureftpd ne donne pas un minimum de documentation technique, ni même un Pdf tutorial en ligne. avec les lignes de commande à taper pour établir des quelques opérations simple.

Je crois que tu n’as pas bien compris ce qu’il fallait faire.

Tu dois copier le fichier http://www.droboports.com/app-repository/proftpd-1-3-3d/proftpd.tgz dans le dossier “DroboApps” de ton Drobo, et réinitialiser le Drobo.

Après ça, ProFTPd devrait être déjà disponible chez le Drobo. Il se peut qu’il ne le soit pas, parce que cette version a été compilée pour le FS, et pas pour le ProFS. Il faut installer ProFTPd et voir si ça marche.

Les instructions sur la page sont nécessaires seulement si tu veux compiler ProFTPd toi-même.

Malheureusement, PureFTPd ne supporte pas des fichiers de configuration. Ce qui veut dire que tu as besoin de créer une ligne de commande avec toutes les options que tu as besoin. Il n’y a pas de “recette”, il faut visiter la documentation officielle et lire.

Ni DRI ni PureFTPd peuvent deviner ce que tu as besoin.

L’avantage d’utiliser ProFTPd est qu’il permet d’utiliser des fichiers de configuration, ce qui facilite beaucoup de trouver une configuration toute prête sur leur site.

ok j’essaye ça, et je vous tiens au courant. merci beaucoup.

j’ai téléchargé proftpd.tgz, j’ai reinitialisé le drobo mais rien ne fonctionne en local comme à distance.

Est-ce qu’il y a un dossier “proftpd” dans le share DroboApps?

Dans le cas ou j’installe pure-ftpd le ftp marche direct. Mais ne respecte pas les droits d’accès aux différents points de partage.

Comment retirer tous les utilisateurs de l’accès FTP sans changer les paramètre de drobo dashboard ?

et comment créer un utilisateur qui a accès uniquement au dossier public ?

voila ou j’en suis, je me connecte en via terminal :

ssh root@monip
taper votre mot de passe : ***
#[hr]
oui il est bien dans le dossier et il s’est bien déployer mais rien ne fonctionne.

même les ping vers le ftp ne fonctionne pas.

je suis passé également par drobo admin pour vérifier et il est marqué comme installé.

autre point le serveur web proftpd marque 404 - Not Found

Est-ce que par hasard tu as pureftpd et proftpd installés em même temps? Tu dois enlever pureftpd avant d’installer proftpd, parce qu’ils sont tous es deux configurés pour utiliser le même port.

Mais a part ça, pour configurer PureFTPd, tu peux essayer ça:

  1. Ajoute les noms de tous les utilisateurs que tu ne veux pas donner accès par FTP dans le fichier /etc/ftpusers. PureFTPd devrait respecter ce ficher.

  2. Ajoute un utilisateur virtuel pour la partie publique.

il etait installé mais je l’ai désinstallé pour tester proftpd.

j’essaye la manip pure ftpd[hr]
/etc/ftpusers n’existe pas à la racine du drobo

et lorsque je tape la commande voila ce qui se passe :

ssh root@monip
taper votre mot de passe : ***

pure-pw useradd user -u 120 -g 120 -d /home/user -m

-sh: pure-pw: not found

Poutant le ftp est actif

je m’y connecte avec n’importe quel utilisateur du drobo mais sans les droits

sur le tuto pour compiler une machine virtuelle pour proftp je bloque à cet endroit :

http://www.droboports.com/setting-up-a-vm

log in and edit http://www.drobospace.com/forums/member.php?action=profile&uid=6128/etc/network/interfaces and add these two lines at the end:

auto eth1
iface eth1 inet dhcp

que faut il faire ?

je ne comprend pas.

Fais ça:

  1. Depuis la fenêtre de la machine virtuelle:

sudo apt-get install nano nano /etc/network/interfaces
2) Vas jusqu’à la fin du fichier, et écrit ce deux lignes:

auto eth1 iface eth1 inet dhcp
3) Appuis CTRL+O pour sauver, CTRL+X pour sortir.

lorsque je fait la manip ça me marque à la fin erreur lors de la lecture permission non accordé

PS: avant de modifier ça me met lecture de 10 lignes en lecture seule !

re: re: c’est bon il faut ajouter sudo nano /etc/network/interfaces

j’abuse peut être un peu, mais je suis vraiment un débutant en lignes de commande.

comment faire un copier coller vers la vm depuis Mac OS X.

Dans les paramètres, il y’a partage du presse papier bidirectionnel mais rien ne se passe.

PS: Sinon la manip fonctionne. Il faut que je finisse la configuration de la VM. Merci beaucoup

Seulement avec l’interface de ligne de commande ça ne marche pas. Il faut connecter via SSH pour pouvoir copier/coller en utilisant le Terminal de Mac OS.

ok donc je passe par le terminal d’os x pour configurer la VM et ensuite lorsque je voudrais compiler proftpd sur le drobo je passe par la VM ?

Au contraire. Reste dans la fenêtre de la VM jusqu’à ce que SSH marche. Après ça, toujours avec Terminal.

ok ssh marche !

et comment faire ça ensuite :

Also create the file ~/uncrosscompile.sh (which will remove the exports from the previous script) containing this:

export -n CFLAGS
export -n CPPFLAGS
export -n CXXFLAGS
export -n CC
export -n CXX
export -n AR
export -n RANLIB
export -n STRIP

Tout simple. Il faut taper dans une fenêtre SSH:

nano ~/uncrosscompile.sh

Puis copier/coller ceci dans la fenêtre:

export -n CFLAGS export -n CPPFLAGS export -n CXXFLAGS export -n CC export -n CXX export -n AR export -n RANLIB export -n STRIP
Ensuite CTRL+O et CTRL+X.

yes ! tout fonctionne jusqu’a :

Finally, create the file ~/bin/package.sh, containing this:
#!/bin/sh
appname=basename \pwd``
appfile="…/${appname}.tgz"

if [ -f ${appfile} ]; then
echo Removing old ${appfile}
rm ${appfile}
fi

sudo chown -R root.root .
tar czf ${appfile} .
echo New ${appfile} created

ca me marque dans nano

Erreur lors de l’écriture de /home/user/bin/package.sh : Aucun fichier ou do ]