Drobo

Format drive removed from Drobo?

How can I re-format the drive I have just removed from my originaal Drobo? It’s 300GB and I would like to store some material on it but Windows (XP & Vista) won’t allow me to format. I can only see the drive through disk management, but it appears (to windows) to be malfunctioning. It was fine when removed from the Drobo.

Thanks,

Ian Leonard
Wiltshire UK

you need to create a volume/partition on it first in order to format it

drobo does nothing special to the drives, but in windows they will appear as totally blank, with no partitions, so they need to be configured before they can be formatted…

Thanks, but that’s the problem, Windows sees that a drive is attached, but right clicking it brings up no options to format/partition etc. I’e tried all the ways I can think of from Drive management on. Maybe it has died since removal?

Ian Leonard
Wiltshire UK

[quote=“Docchris, post:2, topic:1671”]
you need to create a volume/partition on it first in order to format it

so in disk management who does the space on the drive show up? i would expect it to be black, and unallocated/raw as Disk 1 is in this screenshot

http://www.eastservebroadband.com/images/click-disk-management.gif

Running Xp Pro SP3 when I attach a Drobo drive and open Disk Management I get a popup Window that says “Welcome to the Initialize and Convert Disk Wizard”.

I just did this because I happen to have a Drobo volume that hasn’t been formatted yet.

If you don’t get that popup, that may be the issue. If I cancel that popup (trying to pretend I didn’t get that window), then there is no enabled option in Disk Management to create a Partition. There is a disabled right click option to Create Partition but that obviously is of no help to you and is likely the problem you have??? Typical lame MS “feature”.

I also usually have Paragon Partition Manager installed on that XP box (but not now, apparently). That utility will partition a Drobo drive but you would have to buy a copy or find someone that has it. I initialized my prior Drobo outcasts with Partition Manager so I don’t have a lot of real world experience with XP’s Disk Manager and don’t have a clue why you are apparently not getting the popup window but this gets you one step in the right direction for maybe some google searching of your problem. You might also find a cheaper utility somewhere?

My recollection is that the same thing happened the other day when I needed to format another Drobo drive in Win7 - I got a popup window when I stuck the drive in another similar BlacX dock, via eSata.

I installed the Drive in an open BlacX USB dock on my XP laptop, the style that you just pop the drive in the top without installing it in a closed enclosure.[hr]
Here is another idea if you have your XP or presumably Vista Setup disk. I would try this with Vista because the setup is newer and more likely to accommodate large drives. Just follow the directions in this KB article but then CANCEL the setup before you reinstall the OS :-). I would backup first, just in case you forget that :slight_smile:

http://support.microsoft.com/kb/313348

You may also want to retry using Disk Management after turning off your security app, which could conceivably be blocking that popup window but that’s probably a long shot. And/Or turn off UAC in Vista.

You could also download a trial of Partition Manager to do this. If you ever create multiple volumes on a drive and then need to resize them or do other things that XP Disk Management won’t do you may even want to buy a copy, as I did years ago.

http://www.paragon-software.com/downloads/home/

I would download that demo version rather than trying to find freeware on the net to do the same, not knowing what’s in that freeware :slight_smile:

Docchris, Thanks, That is what I would expect too. The disk shows up as disk 5 but there is a small red circle with a cross in it in the Left hand Bit of the drive description, the Right hand area is just blank, no black line or anything else!

NeilR, Thanks too, No initialize & Convert wizard for me and no right click pop ups offering the same features.

When I tried it on my Visata machine I was in the “Proper” all access admin mode.

I did download and install the seagte disk manager, by Acronis (It’s a Maxtor drive, same company now I believe) but it didn’t even see the drive saying that the only drive attached was the internal C:\ drive.

BTW I am attaching the drive to the USB port via a multi adapter, a bit like your BlackX thingy I guess. I will try the trial of Partition Manager.

Ian Leronard
Wiltshire UK

Red circle with cross is generally not a good thing.
If you had canceled the Initialize Disk wizard, then the option would be there but disabled as Windows won’t write to an unformatted drive that doesn’t have a signature. Not sure what the reasoning is for this, but that’s how it works.

Also be sure you are applying both power and data to the drive with your USB multi adapter (usually means attaching a power brick as well as the SATA cable to the USB adapter) - the USB port won’t provide enough power to run the drive, though sometimes it provides enough power to put the drive in a seen but inaccessible state like you’re having.

if you right click on the actual “disk 1” part of it - to the left of where the volumes/raw would be, then initialise is in that menu - so you are initialising the disk - until you do that, then no you cant create or partition an un-initialised disk

like here

http://blogs.technet.com/blogfiles/askcore/WindowsLiveWriter/ConfiguringPassthroughDisksinHyperV_B07D/image_thumb_3.png[hr]
oh and i agree with bhiga, the red cross offically means:

The red X means disk 0 is unreadable by Disk Management.

which isnt really something drobo could have done to it, it does sound like the drive electronics has powered up but it hasn’t got enough power to spin the platters

You guys are correct; I apparently clicked in the wrong place on Disk Manager when I tried previously. Works for me.

Yeah but that’s with a red circle with White line through it, like a no entry or stop sign, that’s an uninitialised disk

He has a red cross, that’s an unreadable disk

Actually, can you try the disk on a different machine? Just in case there’s some weird incompatibility

Duh, I feel a bit of a prat now. Unplugged all the cables and replugged, all OK. I just assumed it was the Drobo!

Ian Leonard
Wiltshire UK.

Probably was just the power not quite connecting