Drobo

Firmware 1.2 Killed FS

Upgraded to Firmware 1.2. Now, none of my shares will mount, Drobo Dashboard just says “Please Wait” (or some such) interminably.

Whatever is happening has borked the Finder (Snow Leopard & Lion) so badly, I have to turn the machine off to get use back (Finder won’t force restart). Without the Drobo connected, I have no problems.

Any suggestions for restoring functionality to my DroboFS?

is there any chance that you also upgraded the Dashboard? I had the same problem and once I went back to the old Dashboard, I was back in business.

Thanks for the reply.

Because of Lion, I have two boot disks: 10.7 and 10.6.8. On the second, I run Dashboard 1.7.x. The same issue occurs there as well.

What version of Dashboard would you recommend for 10.7?

My Drobo FS is now basically useless after upgrading to the latest firmware, upgrading Dashboard and upgrading to Lion. AFP will mount my shares but then everything is very slow. I can’t use smb on the Mac, as I used to, to mount the share. It doesn’t recognize my user password. My Windows Home Server is running great so I don’t think this is just Lion. I’ve had issues in the past where my Drobo FS would be incredibly slow via AFP but then smb was ok. It’s not clear what to do at this point. Upgrading dashboard and the firmware took forever.

philip

[quote=“pmcd, post:4, topic:2761”]
My Drobo FS is now basically useless after upgrading to the latest firmware, upgrading Dashboard and upgrading to Lion. AFP will mount my shares but then everything is very slow. I can’t use smb on the Mac, as I used to, to mount the share. It doesn’t recognize my user password. My Windows Home Server is running great so I don’t think this is just Lion.[/quote]

Not sure what to tell you, but I can connect via SMB (Lion client, current firmware on DroboFS) with no problems whatsoever, even to authenticated shares.

Also, I find AFP performance with large files (i.e., where it doesn’t have to make lots of database updates and doesn’t have to list a bunch of directories) to be the same as it was before. Sadly, small files and lots of directories are exactly the things that Time Machine hits hard.

Are you using the latest firmware? I enabled legacy logins for AFP and it does connect. I can even copy a text file from the Drobo to my Mac. Anything larger is a no go. Also, Time Machine doesn’t recognize the FS. Everything is working great from my windows 7 PC. It is from Lion where the trouble is. I bought the Drobo FS for a mixed environment. It doesn’t work properly for that at this point. I hope they get around to fixing it soon.

I wish I knew what you did to get it to work. I don’t really have the energy anymore to mess around with the FS. I’ll use it for my PC where it’s fine. Ironically, my Windows Home Server v1 works great with Lion.

philip

If you’re running the latest firmware, you don’t need to do that.

Like I said - Lion, Firmware 1.2, Dashboard 2.0.3 - works fine, both AFP and SMB (and NFS, since ricardo pointed that out). Slow for small files on AFP (and I would assume Time Machine), but it works fine. I’m not saying the FS is definitely innocent because it frequently is the culprit, but I don’t think it is in your case.

@diamondsw

My Drobo FS has worked perfectly for months with Mac’s and PC’s. I made 3 changes. I upgraded one Mac to Lion. Time Machine failed but I could still transfer files. I upgraded my other Mac to Lion and it also was able to transfer files at good speeds. Again, time machine would not work. I then upgraded Dashboard and the Drobo FS to the latest sw and firmware. Now both Mac’s will not work with the Drobo. This tells me that the latest firmware is the culprit in dealing with Lion. I don’t know why your system is working but you appear to be in a minority. As I said my PC’s have not been affected. Moreover my Mac’s continue to work fine with my WHS using smb.

Philip

There are several issues at play here, and you’re conflating them mightily. You really must keep straight exactly what OS version, DroboFS version, and connection protocol you’re using. That could be any of (10.6|10.7), (1.1.2|1.2), (AFP|SMB). You also need to be aware of how the Drobo supports the various protocols to know where the blame is - things like netatalkd, samba, etc.

The AFP issues are most definitely not Lion’s fault. The blame for that lands squarely on netatalkd and DRI. You may have yet another issue, but at this point most 10.7/1.2/2.0.3 issues are at least vaguely understood.

Cannot connect via AFP under Lion - “The version of the server you are trying to connect to is not supported” (10.7, 1.1.2, AFP)
FIX - Upgrade to firmware 1.2
Lion removed support for “DHCAST128” - mind you, this was deprecated in 2002, so it’s not like they yanked the rug out from under anyone. You can force Lion to use it again, but that’s just delaying fixing it until Apple removes it completely from the code - which could happen in 10.7.1 for all anyone knows. The only reliable solution is to upgrade the NAS to support authentication from more recent than 9 years ago.

Time Machine not working under Lion (10.7, 1.1.2, AFP)
FIX - Upgrade to firmware 1.2
When you upgraded to Lion, but did not upgrade the DroboFS firmware, you could connect but not run a Time Machine backup because netatlkd in firmware 1.1.2 did not support the encryption updates now required by Time Machine. Firmware 1.2 updates the netatalkd package to support this. Slowly though, as seen below.

Shares not mounting for AFP connections after 1.2 firmware update (10.6|10.7, 1.2, AFP)
FIX - Delete the “.Apple*” directories at the root of the share
When you updated the firmware 1.2, that included updates to netatalkd to enable Time Machine - but also changed the way netatalkd (and AFP connections by extension) did many things, especially folder listings and metadata storage. The issue of shares not showing up has been discussed in several active threads, and seems to go back to the netatalkd upgrade botching the conversion of several “.Apple*” databases it creates at the root of the share. Deleting those will cause netatalkd to recreate them from scratch, and the shares then mount normally. I’ve experienced this firsthand.

Poor performance for AFP connections with small files and lots of directory checks (10.6|10.7, 1.2, AFP)
FIX - Patience. lots of patience…
AFP performance has long been miserable with small files due to the way it handles metadata storage - quite simply, lots of updates to it take lots of time, whereas with a single large file it can make one metadata update and then blast bits across the network (for the programmers out there I’m assuming this is O(n) complexity - if not worse, depending on the data storage design). Now we have an additional issue in play where the method netatalkd uses to examine directories for size and changes is very, very slow - and that just makes the “lots of changes” case worse - which hits Time Machine like a brick. People have reported success leaving the backup to run for days, as excessive as that is. I don’t run Time Machine, so I can’t really comment, but I deeply sympathize and think DRI should be taken to task for this - if not sued outright.

Problems with SMB connections from Lion (10.7, 1.1.2|1.2, SMB)
FIX - Um, what problems?
Lion did replace the samba networking layer in Mac OS X with an Apple-created stack, and this has caused some issues - for instance, you can’t use Lion Server as a Primary Domain Controller. I haven’t seen any reports of SMB connections to NAS units like the DroboFS failing, however, and it works just fine here. SMB connections stores metadata differently, presents some filenames differently, and cannot be used for Time Machine, so it may not be a usable solution for many.

@diamondsw

I am not confounding them. I am familiar with the issues though not the details you nicely summarized.

  • smb

Under Lion and fw 1.2 I could not authenticate. Under SL and pre 1.2 I could and performance was fine. Under Lion and fw pre 1.2 I could connect and performance was fine. After 1.2 performance was bad.

Under SL and Lion transfers to my WHS were fast.

I can connect just fine to my WD NAS and a DNS 323 with smb. The only one that no longer works is the Drobo FS. Meanwhile the Drobo FS works with my win7 PC’s.

I can’t see how it is not the Drobo FS with 1.2 and Lion. That is the only situation that fails.

It may be that there is some strange combination going on here. All I know is Drobo FS 1.2 + Lion + smb doesn’t work for me and many other people. If I boot back to SL it does.

Philip