Failing Disk, rebuild not working, drobo stops answering.

Hello all,

I had a disk WD Green 2TB fail and when i replaced it with a WD 2TB NAS. I keep getting these fails. It never completes restoring the disk, no matter what sequence I use. Single or double drive.
I’m at less than 40% full disks. When i try and do backups it fails, it looks like it’s still working and I can most often SSH into the box but at times the disks are unmounted, the dashboard doesn’t see it and it stops sending data back out.
I have reinstalled the FW manually on an empty FS.
So the thing i have left to try is the link to post
For you who are familiar with that thread it’s about getting a more CPU powerful machine to the e2fsck for you via nbd. I have gotten all that to work. Besides a tiny tiny thing. I can’t for my life figure out how to “unmount” Sda1 from ssh. Anyone please help.

No one knows how to unmount the Drobo FS from Shell ?

I found out how to do it. unmount -l /dev/sda1 Not sure if this is safe or not but efter all this time… my system can’t be any shittier :wink:

Problem with that is, when trying to follow the post above and using the nbd-server Droboapp ( ) is when you do umount you umount your DroboApps share as well. So before you do that copy the nbd directory to your /root directory. Edit the /root/etc/nbd-server/config file to say sda1 instead of sda2. Then you start the server like this from /root/nbd/bin/nbd-server
./nbd-server -C (absolute file path) /root/nbd/etc/config
This start nbd even from an unmounted server. The go back to follow the guide.
i have just started sudo e2fsck -v -y /dev/nbd0 for the 2nd time after trying to fix some broken superblocks.
We will see what happens

hi bevier its good you found a way of unmounting,
can i check what the drobo is doing, when you mention it never seems to complete restoring the disk? (are any of the drive bay lights flashing yellow and green?

also how much data do you have on the drobo (as an estimate)?

Hello Paul,

I have around 4TB over 5 disks. It all started with a failed disk.
The lights starts with yellow and sometimes one bay the previously faulting one is red. It feels that it never really get’s finished restoring/protecting the data. I have had it wait for days. IT all ends with that the DroboFS stops responding to the gui, or stops sending out data by having unmounted /dev/sda1 it self. At this time the lights can be either all green or yellow still. I hav tried triggering this by making the system double disk redundant no change.

I can’t make a backup either since it reading through the disks causes the same behavior as above.

After trying to fix it over nbd still no luck, the only change is that the gui triggered that it wanted to do a repair, which I did… But i suspect it will complain about bad superblocks etc. Looking at the logs it get’s a lot of error.

thanks for more info bevier,
usually when an actual (properly visible) rebuild takes place, the drive bay lights flash yellow and green, and can usually last for approximatley 1 day per 1TB of data that you have.

am not sure if your e2fsck process has finished, or if you have tried this already, but even though it is not doing a visible rebuild, have you actually tried leaving it on for at least 4-5 days?

one other idea you could try would be to try putting the drobo into ReadOnly mode, as mentioned here:
(it is usually used to help with reboot loops, though could help to put your drobo into a more stable state which might let you access and read your data from it before it becomes unresponsive)

some other ideas could be to try creating a 1 time ticket with support (which has some cost as the fs seems to be out of warranty) and the other could be to try booting up empty, i can help with the latter process but if you feel the drives are doing something (or being used in some way, then i would wait some more time if you can to try the other ideas first.)