Extremely slow read speeds only on certain files; want to test drive integrity issues

Hi everyone. Hope someone can help.

I own an original Drobo 4-bay and it’s been serving me fairly well for years now. Recently I’ve noticed considerable slow down with write & read speeds that is making it almost unusable.

Currently packed with 4x WD Green 2TB from late 2012, single volume thin provisioned past actual physical storage capacity.

Drobo is connected via FW800 to MacBook Pro 2013. Also tested with 2008 iMac (this was its primary connection for years before upgrade to MBP. Behavior is same on both machines, and USB2 as well as FW800)

I’ve noticed slowdown for a while now (few months) but it’s becoming painfully apparently this week as I’m trying to move a large amount of data from the drobo to a NAS unit. I’ve tested the NAS (Synology 1-bay with enterprise class WD drive) and it’s read / write speeds are a consistent 40-50MBs from all sources except Drobo.

While copying files from the Drobo, however (either to the NAS or to the directly attached computers), some files will transfer at acceptable speeds (~20+MBs) while some slow to a crawl, maxing out at 2-5MBs. The bulk of these files are 4-7GB video files which I’ve collected over the years. Some transfer in as little as 3-5 minutes, some take half an hour. The slowdown behavior is limited to certain files, and seems to occur more often with files that have been on the drive longer - although this is just conjecture and may not be entirely the case.

The behavior makes me believe that one or more of the individual drives may be experiencing considerable slowdown with any files residing on it. However, Drobo has never alerted me to any problems with the drives or need to replace.

I also tried running Disk Warrior on the Drobo (from both computers, and from a USB-bootable copy of Disk Warrior on an external) and each time it gives me an error that said it was unable to correct directory structure due to too many hardware errors. Again - reinforcing the faulty drive hypothesis.

Does anyone have any ideas on what I can do? Is there any way to test the individual drives while maintaining the integrity of the data so it can be read when re-inserted in the Drobo? I have access to a PC running Win 8 as well, so solutions do not have to be Mac Based.

I’m not opposed to replacing drives in the Drobo, but currently I have no way of knowing which drive is causing the issue - or if that even is the issue.

Hope someone is able to help. Sorry for the wall of text. Thanks if you’ve made it this far.

As long as you told Disk Warrior not to check for bad

It’s possible that some drives are encountering correctable failures and slowing down as they’re correcting them (moving data from bad/going-bad block to a spare block).

If it’s still under warranty/support you can ask them to look at your logs. But if it’s an original v1 4-bay Drobo then it’s definitely no longer under warranty/support.

You can shut down Drobo then remove and test the drives at a physical level with Western Digital’s Data Lifeguard BUT I would go through the time/trouble to make sure you have a COMPLETE BACKUP before doing so.

The drive test will stress the drives and could be the straw that breaks the camel’s back. IOW, testing the drives might take you from “hobbling but accessible” storage to dead storage if more than one drive dies in the process.

btw how much free actual space does the drobo have?
if its very full it can slow down

also as docchris said, if you have access to your data currently, then let it copy from drobo even if slow, just in case :slight_smile:

The drobo is 50-60% Full. Never been much more than that since the last time I expanded from 4x1TB to 4x2TB.

All business-related data is already backed up twice, and offsite. Personal data (movies / music / media) is currently being offloaded to the NAS. It’s been copying steadily since my original post (before, even) and I haven’t had a file fail to copy yet, but the speed issues are still present. Looking at the access monitor for my NAS device I can see where it is a steady 3-5MB/s for one file, then jumps up to 20-40MB/s for the next, and then returns.

At this point I’d like to run some diagnostics on the drives once everything exists in at least one second location. Is WD’s tool mentioned above the best way to do this? Do any solutions exist on a Mac?

I only ask because the easiest way for me to do this would be through the external SATA->USB dock I have, but it only works reliably on my Macs. If I have to use PC, I’d have to connect them one at a time to internal SATA connectors, taking apart the case each time in the process. If that’s my only solution (or if it’s a better one, all things considered), so be it, but curious to see if any solutions exist on OSX.

Thanks for the replies so far.

hmm, do you have any other processes/programs running, such as an indexing/spotlight service, or antivirus?

i remember on a windows computer when i disabled antivirus and internet, lots of file operations sped up (due to scans for read/write)

maybe if you have other things running, you could try disabling/closing them (but disconnect your internet before you remove firewalls and such for safety)[hr]
it might speed things up.
(also as a thought, Dont defrag a drobo, but am just wondering, is the destination drive ok? (with no errors and was it badly fragmented before?)

Nothing else running. The transfer from Drobo -> NAS is currently running on my old iMac, which has been freshly formatted in preparation to sell. The transfer itself is being handled through ChronoSync due to pause / abort / resume functionality, but the drive behaves the same way through this software as it does just dragging and dropping files though finder (tried both). I’m transferring through the old iMac for the sole reason that I wanted to make sure nothing else was interfering with it (and because the transfer of 2.5 TB of movie data is going on 4 days now and I wanted to be able to use my laptop in the meantime)

Spotlight indexing was disabled on the iMac through terminal system wide as a prior troubleshooting method. Other than ChronoSync it is a fresh install of OSX 10.9.1. No A/V, no firewall.

Drobo has never been defragged manually. The only drive maintenance I’ve tried to do was the previously mentioned DiskWarrior which failed due to ‘hardware errors’. DriveWarrior has run successfully on the Drobo in the past, but last successful run was months ago, prior to these severe speed issues.

The behavior is the same regardless of transfer destination. I’ve tried copying files to: Internal PCIe SSD drive on 2013 MacBookPro, Internal SSD on iMac, and brand new (SMART verified no bad sector) 4TB WD Enterprise SE drive on a single-bay Synology NAS over gigabit wired ethernet.

when you say “The slowdown behavior is limited to certain files”

  • have you been able to further ascertain any specific culprits?

  • have you raised any ticket with logs for support to at least have a look at? (as per my understanding, they are good teams who will still let you know if the logs show anything bad)
    (if you are in the middle of copying stuff, it’s probably best to let the copy finish, or to stop it before generating fresh diagnostics logs)

  • it could simply be as what bhiga has mentioned, and the drobo is performing its internal error-correction processes to let you accesss the data as best it can get it from the drives.

(just to glace back in time… was there anything else which might have changed, following on from all the years you had a quicker drobo, such as maybe a patch or os/update etc? am just trying to see if anything else can be pinpointed in case it was overlooked?)

(actually one thing i overlooked… was the benefit in led/back-lit keys for my keyboard LOL i wish i spent the extra £15 back then) :slight_smile: