Expired Certificate using Drobo Access.

I set up Drobo Access for MyDrobo.com which worked without any problems.
Now I’m getting a warning from my browser that the SSL certificate has expired. Doesn’t Drobo keep these certificates current?

hi mikey, if you get a moment, would you be able to have a quick look at this page, just to see if you also get a similar error code?
http://www.drobospace.com/forums/showthread.php?tid=147021
(just wondering if the two issues by others are also related to yours, or if it is just coincidence)

Thanks for the reply. I believe you have a different problem in that you are unable to register.

For me, I was able register and use it for a while with no problems. The error I’m gettings depends on what browser I’m using. They all say there something is wrong with the certificate, something adding it is unsafe to go to the website and/or hacker may be trying to get my information. Further investigation shows the ssl certificate was only valid tor 3 months. The certificate is basically out of date.

For your problem, I believe drobo gives free tech support for 90 days. So give them a call.

Hello MikeySoft,
Paul alerted me to your issue. Would you email me directly at followup@drobo.com. I would like to get some more information from you.

  • Version of Dashboard
  • Screen shot
  • Drobo diag.

Thank You.
DroboMod

DroboMod, I have emailed you the info you requested. Thanks for your help.

I just logged in from work and had no SSL issues. I did notice the current certificate expires in Dec though.

Yes, I had no issues at first but after a few months the SSL certificate expired. It was never renewed by Drobo which I believe is responsible for maintaining the certificate.

This issue only shows up when using a web browser. Apparently the Drobo app ignores that the ssl certificate is invalid & out of date.

I would appreciate if users of Drobo Access verify the date range of the ssl certificate. The method of finding the certificate depends on which browser you are using. However clicking on the lock icon when connected to a https sight usually leads you to view the certificate information, including the dates the certificate is valid for.

You may not be presently having the issue but may see the date of the certificate will expire in the near future as AzDragonLoard found.

I am especially interested in users who have been using Drobo Access for over 3 months but would appreciate everyone report what they find.

Thanks to everyone for their help.

Status on my trouble reports:
I submitted my trouble report on Monday, October 17, a week ago. They have been unable to resolve the issue and have raised it to the next level.

Now mine shows “****.mydrobo.com didn’t accept your login certificate, or your login certificate may have expired.”

I can no longer use Drobo Access. Is DRI even maintaining this??

I think the more this is reported here and directly to Drobo support, the more likely they will realize they have a systemic issue, not something local to a unit or owner.

My issues has been given to a second support agent. So far, he is requesting me to do the same things the first one did like making sure the apps are update.

Today it’s working again, but still expires in Dec.

hi mickey, can i check something please?
is this issue mainly about the fact that a certificiate (which for the most part) is working ok via the drobo/app (aside from dragons recent issue which was then working again)?

if so, it may just be that the certificate is planned on being renewed etc, but is still a valid certificate, though is getting warnings due to the browser’s settings?

does it still let you use the service, or access files on your devices via the apps?
(i may have misunderstood something as i only use the das models myself, but maybe you could help confirm when you get a moment?)

Hi Paul, thank you for your help.

I got my new Drobo 5N last June and both the Drobo Android App and the web site xxxx.mydrobo.com were working great with no problems.

I did not use the MyDrobo for a while until 2 weeks ago when I got the SSL certificate invalid date error from every browser and different computers I tried.

I have submitted this problem to Drobo tech support two week ago but so far they have not solved the issue. All they have suggested so far in to insure I have the latest firmware and apps installed which I did several times including rebooting my 5N.

The other day I was away on a trip. The xxxx.mydrobo.com web site said my Drobo was off line and the Drobo Android App just hang. I got home today and for some reason the MyDrobo app (on my 5N) was stopped while the others, MyAccess, Apache, MySql, Python 2, were running. The last 3 drobo apps were not installed by me. I assume the MyAccess or MyDrobo apps must have installed them. Anyway after restarting the MyDrobo app on the 5N, the xxxxx.mydrobo.com web site no longer states my 5N was offline but I get the out of date SSL certificate as before.

I don’t think the issue is from improper settings as it worked before with the same browsers and settings. Also several browsers on different computer, tablets, and smart phone now all have the same issue. They all states the SSL certificate expired on Sep 22, 2016, about 3 months after I first set it up. The Android app appears to transfers files but I believe it is poorly written and ignores errors and also hangs when my N5 was off line. I need to securely, with confidence they are secure, transfer files between my laptops and my 5N.

Thank you again for your help and suggestions on trying to fix the issue.

thanks for the extra info and clarifications on that mickey,
it might be worth dropping another note to the support team when you get a moment, about which browsers (versions) and tablet/smart phone version, just in case useful for the team, but yes, hopefully things can get resolved again for you to be able to do the stuff you usually do,

Question to the Admin and status update for the SSL certificate issue.

Admin, this was the first thread I started in the forum. I realize now I should have posted in the DroboApp section. Is it possible to move this thread to that section while still maintaining followers to this thread?

Status Update:
The issue appears to be resolved. Apparently there was a problem renewing expired SSL certificates. Below was the latest response from tech support:

[quote=‘TechSupport’]“Thank you for the update. We are seeing a problem with the certificate renewal due to the age. Please de-register the domain and register it again. You should not have to do this again as the latest update should resolve the issue.
Once you have registered the domain again, please upload a fresh diagnostic file for review.”[/quote]

thats cool the issue is resolved for you for the certificate micky :slight_smile:

Two issues here:

  1. Using Safari as web interface: error = “expired certificate”
  2. Using iOS app: all data adds since expiration date do not show.

How to …

Coen

The simplest way you can handle this is to release and re-register the same domain again. This will force the generation of a new certificate.

is there any automated way for this to occur?