Drobo

Error on DroboAdmin

I am getting an error when I access DroboAdmin
http://drobo-fs:8080/droboadmin/
The error is when I click on “Install DroboApps” I get this message :

Warning: file(http://www.drobo.com/droboapps/feed/textfs.php) [function.file]: failed to open stream: Network is unreachable in /mnt/DroboFS/Shares/DroboApps/droboadmin/www/index.php on line 301

Also When I click on “Upgrade DroboApps” I get the following message:

Warning: file(http://www.drobo.com/droboapps/feed/textfs.php) [function.file]: failed to open stream: Network is unreachable in /mnt/DroboFS/Shares/DroboApps/droboadmin/www/index.php on line 224

The error does not happend when I click on “Configure DroboApps” or “Uninstall DroboApps”
Any help appreciated.

Is your Drobo connected to your router or just to your computer?

My drobo-FS is connected to the router. its a gigabit router. I must say that his was working fine for almost 6 months. Then I did an upgrade to the latest firmware. sometime later… it just stopped working. Still not sure if its because of the upgrade or not… I tried it few weeks after the upgrade and I got the error.

/facepalm

I just tried to access that URL (http://www.drobo.com/droboapps/feed/textfs.php). Turns out it is just a page listing all the droboapp on DRI’s web server.

It seems to me that there may be a network connection problem between you and DRI. Try to access that URL from your own machine. If you see a bunch of text, then the problem is in the Drobo. Otherwise, you have some networking problem.

Accessing the URl gives me the following:

DroboApps Admin Utility|http://www.drobo.com/droboapps/apps-for-drobofs.php#50|http://www.drobo.com/droboapps/apps/50/droboadmin.tgz|The DroboApps Admin Utility makes installing, configuring, updating, and uninstalling DroboApps even easier.|1.3||^|Apache|http://www.drobo.com/droboapps/apps-for-drobofs.php#51|http://www.drobo.com/droboapps/apps/51/apache.tgz|Apache is a secure, efficient and extensible server that provides HTTP services in sync with the current HTTP standards.|1.3.41_1||^|CTorrent|http://www.drobo.com/droboapps/apps-for-drobofs.php#52|http://www.drobo.com/droboapps/apps/52/ctorrent.tgz|CTorrent is a command-line bittorrent client.|dnh3.3.2_1||^|Dropbear|http://www.drobo.com/droboapps/apps-for-drobofs.php#53|http://www.drobo.com/droboapps/apps/53/dropbear.tgz|Dropbear is a small SSH 2 server and client.|0.52_1||^|Firefly|http://www.drobo.com/droboapps/apps-for-drobofs.php#54|http://www.drobo.com/droboapps/apps/54/firefly.tgz|Firefly serves digital music residing on the Drobo FS to the Roku Soundbridge and iTunes.|0.2.4.2_2||^|FUPPES|http://www.drobo.com/droboapps/apps-for-drobofs.php#55|http://www.drobo.com/droboapps/apps/55/fuppes.tgz|FUPPES is a free, multiplatform UPnP A/V Media Server with DLNA support.|r578_1||^|Lighttpd|http://www.drobo.com/droboapps/apps-for-drobofs.php#56|http://www.drobo.com/droboapps/apps/56/lighttpd.tgz|lighttpd is a HTTP server with a focus on security, speed, compliance, and flexibility.|1.4.26_1||^|Pure-ftpd|http://www.drobo.com/droboapps/apps-for-drobofs.php#57|http://www.drobo.com/droboapps/apps/57/pure-ftpd.tgz|Pure-FTPd is a free (BSD), secure, production-quality and standard-conformant FTP server.|1.0.28_1||^|Rsync|http://www.drobo.com/droboapps/apps-for-drobofs.php#58|http://www.drobo.com/droboapps/apps/58/rsync.tgz|rsync is an open source utility that provides fast incremental file transfer.|3.0.7_1||^|Unfsd|http://www.drobo.com/droboapps/apps-for-drobofs.php#59|http://www.drobo.com/droboapps/apps/59/unfsd.tgz|UNFS3 is a user-space implementation of the NFSv3 server specification. It provides a daemon for the MOUNT and NFS protocols, which are used by NFS clients for accessing files on the server.|0.9.22_1||^|Wake on Lan|http://www.drobo.com/droboapps/apps-for-drobofs.php#60|http://www.drobo.com/droboapps/apps/60/wake-on-lan.tgz|This program generates and transmits a Wake-On-LAN (WOL) “Magic Packet”, used for restarting machines that have been soft-powered-down (ACPI D3-warm state).|1.09_1||^|Perl|http://www.drobo.com/droboapps/apps-for-drobofs.php#61|http://www.drobo.com/droboapps/apps/61/perl.tgz|Perl is a stable, cross platform programming language. It is used for mission critical projects in the public and private sectors and is widely used to program web applications of all needs.|5.10.0_1||^

Still the problem exist. I am not sure if the above output is normal or not.

Yes, it is normal. Somehow you Drobo can’t get that same information from the drobo.com website, causing the error message.

Why that is happening could be any number of network problems. I can’t really help you anymore without more details about your network.

But the feeling I have is that this is somehow a temporary problem, that the proverbial reboot would solve.

Finally… got it to work… I had to remove all DroboApps and Apache and re-install them one by one…