Error Code 21 when registering DroboApps

I keep getting an Error Code 21 when trying to register my DroboApps. The screen I’m talking about is accessed from the Drobo Dashboard >> Drobo Apps >> my Drobo >> Configure >>DroboAccess >> Register App.

Anyone know what Error 21 is?


This means the device you are using already has an account, and the credentials for that account do not match your device’s.

Did you recently:

  1. Change the admin password while myDrobo was not installed?
  2. Did an account migration to another device?
  3. Did a full Drobo reset, and changed the admin password?
  1. No.
  2. No.
  3. No, but I did do a full Drobo reset before installing any Drobo Apps, though I kept the same admin password.

It seems that there is a change in the letsencrypt backend that dropped precisely August 1st, and which is causing issues like yours. A new version of myDrobo should be released very soon now.

I’m still getting errors. This whole thing still feels like it’s not fully baked. Remember when they launched the Crashplan app for the Drobo? I tried configuring that thing for ages, over and over and over, and still couldn’t get it to work. It’s the same thing here. I uninstalled all the apps, disabled DroboApps, rebooted, re-enabled DroboApps, tried re-installing as per the instructions in this video (, and I keep getting errors about not being to install one of the apps, I can’t even uninstall it now… ugh… So fed up with this. I’m on the latest firmware and Drobo Dashboard version as of the timestamp of this message, it’s a new Drobo 5N, a replacement for one that failed, so there should be nothing wrong in this picture. Stuff should just work, and yet it doesn’t. Dammit.

After 5-6 cycles of installing and uninstalling all DroboApps and enabling and disabling DroboApps altogether, DroboAccess and myDrobo are finally running. But I’m still getting the damned Error 21 when trying to register with And DroboPix refuses to run, it’s stuck on the “DroboPix is currently registering itself with myDrobo.” screen. It says it’s supposed to take up to 5 minutes, but so far it’s taken over 24 hours. So fed up with this… The promise of being able to back up my photos off the iPhone and iPad, directly to the Drobo, sounds so good in theory. It’s too bad that in practice, things don’t work.

roaulpop - can you open a support case and submit diags?

This will help us understand your failure better and fix it.

Sorry to hear you are having problems.



Suppose that I did any or all of these actions, what then? How can I get my credentials to match again? More importantly, how can I get DroboAccess to work again?

Any help is greatly appreciated.

Thank you Jason, my issue is now resolved. It took until now, I kept working with Tech Support on it, but it’s working. I still don’t know the root cause of the problem but I’m glad my photos are getting backed up.

I have the latest firmware for my 5N (3.5.11 [8.90.81921]) and am running the latest version of Dashboard (2.8.3). I performed a hard reset using the reset button on the back without my drives installed because the password for my Admin account was somehow corrupted on the Drobo (I did not forget my password - it worked using the web access). After backing up my data elsewhere, I performed another reset using Dashboard with my drives installed.

Now, when I try to setup the DroboAccess app, my domain is reported as being unavailable, and when I try registering a new domain, I get “DroboAccess registration failed. Please try again later. Error code: 21”

I tried uninstalling and re-installing Dashboard, I tried manually installing the firmware, nothing works yet to resolve this issue. MyDrobo installed just fine and is configures. MySQL is also installed, as is Python 2, Locale, and Apache.

Any help is greatly appreciated.

Please see: