Environment Variables (to some extent) finally solved!

After reverse hacking subversion, the Drobo OS and the shell (ash)… (yada, yada, yada)…
You can set a file that gets read by ash shell when you at least log in via ssh…
Don’t know if the DroboApps pick up this file or not, leave it to your experimentation…

Apparently the ‘home’ directory is this location ‘/mnt/DroboFS’
If you create a file called ‘.profile’, you can put all your EV’s in there and they will be defined.

Ash shell supports the format: export name=value

First noticed this location when svn started to create a sub-dir called ‘.subversion’
to store http config files and the rest is logical history…

Tried it with LD_LIBRARY_PATH and PATH and they both work.
When setting DroboApps variable you can use DROBOAPPS_DIR as a short cut.
Will probably work with TZ variable as well (shoulder-shrug-emoji)

Example:
export PATH=$PATH:$DROBOAPPS_DIR/nano/bin

Hope this helps. :wink:

Hello there!

Thanks for sharing this info!

Have you checked to see if these changes will survive a reboot of your Drobo? In my experience, any time I’ve tried to make these kinds of changes, they were wiped away after a reboot.

Regards,

Dom

Hey Dom,

All files still in place as expected after restart.
Quick check with ‘export’ and all EV’s still defined.
App test next… (over to everybody else) :wink:

Keep up the good work guys!

1 Like

Yup!

Just tested TZ and works instantly when defined, e.g.
export TZ=“GMT”

Another problem of Daylight Saving has reared it’s ugly head!

Thank you for this! I confirm that it worked for me, too. My timezone is successfully set to EST5EDT and it survived a reboot.
Afterwards, I added some of my DroboApps (ex: htop, unrar, p7zip) to PATH. Also worked! And survived a reboot.
Thanks again!

Regards,

Dom