Drobo

Enhanced Mac OS X iSCSI support for DroboPro!

Today, we posted a new version of Drobo Dashboard (2.0.4), which includes a new iSCSI initiator for Mac OS X. We have worked with the excellent team over at ATTO Technology to include a Drobo-specific version of their Xtend SAN iSCSI initiator in Drobo Dashboard. The ATTO initiator is automatically installed and configured by Drobo Dashboard so the user experience is unchanged, but stability is much improved.

If you are connecting DroboPro to a Mac using iSCSI, it is recommended to update to Drobo Dashboard version 2.0.4. This release has been tested on Mac OS X 10.6.8 and 10.7.1. We are especially happy to have a more solid OS X Lion solution out to you.
http://www.drobo.com/support/updates.php

Thanks again for participating on this forum!

-ErikP
Director, Product Management
Drobo, Inc.

Well I’ve tried for several hours. Even did a pin reset, and can’t get my DroboPro to connect to my mini over iSCSI w/OSX lion server.

Did you insure that Java was installed on your OS X Lion machine? The new iSCSI initiator requires it. Details can be found at http://support.apple.com/kb/dl1421.

The Drobo Dashboard 2.0.4 installer will check and see if Java is installed and will prompt you for action if it is not.

-ErikP
Drobo

Yes I had Java installed, and even tried reinstalling it. I am going to do a fresh install of Lion Server so I know exactly what I am dealing with. Will report back.

So, no success on a clean install of Lion, or Lion Server. I have a feeling that something is wrong with my disk pack. It will connect for a couple seconds on iSCSI and then the DroboPro reboots. No issues when connecting with USB or FW. I think I am going to try to move my data to an old Windows Home Server and start with a fresh disk pack. (7TB of data - jeez). I really want to get this working on iSCSI, and if I can, I am planning on buying a second DroboPro. Wish me luck.

I had a case open with Drobo Support for this issue. They closed it a while back but assured me I’d be notified when a fix was released. So much for that.

I installed the new Dashboard today and ran an rsync task which consistently caused the DroboPro to disconnect. For the first time since upgrading to Lion the rsync completed without a problem.

For me, at least, this seems to be a complete fix.

I went ahead and pulled the data off the DroboPro and reset the disk pack. iSCSI is working well now, so I do believe I had a corrupted disk pack. Now I just have to transfer the 7TB back. :slight_smile:

Still working after the upgrade to 10.7.2.

Wow, I forgot how fast iSCSI is compared to FW. The transfer back is going much quicker.

Well I did the firmware updates recommended by Drobo and now iscsi does not even work at all. This is very disappointing. Think I am about done with Drobo. This all came about going from Leopard to Snow Leopard. It was solid as a rock on leopard. Wish I did not have to upgrade the os but an app required it.

You might want to try connecting via usb/firewire and change the ip address to something else and save. Restart the drobo pro, change the ip address back to what you had and then save and shutdownt. Then unplug usb/firewire and plug in ethernet cable in the iSCSI port and start it up again. That worked for me and I’m on Snow Leopard.