Enable Time Machine Volume - Drobo disconnects often

I use my drobo5N to host my mp3 files for iTunes, other backup stuff and also as my time machine drive. I have it setup as a single volume 4x 4TB drives and 1 3Tb drive. Connected over thunderbolt and my host machine is Mac Pro. Been running great for about a year now. Recently I guess one of the dashboard updates has this new feature "Enable Backup/Time Machine Volume. Read about it online it sounded pretty cool. So I clicked the button as setup a 3 TB volume on my drobo. Once I did that, I noticed that pretty much every day several times a day in the morning when I started playing iTunes the volume(s) would suddenly disconnect and then eventually the whole computer would reboot. After about a week of this I have given up on this new drobo feature.

Just curious to know if anyone else has had similar trouble.

This is very strange indeed. Are you on the latest firmware updates, v3.2.3 & 2.6.9 for Dashboard.
You also want to make sure you are using a gigabit connection.
You can also disable Spotlight for Drobo to see if this helps.

This is a Drobo5D over thunderbolt to my mac pro.
Dashboard is 2.6.9
Firmware is 3.2.1 [7.165.75100]

May I ask… is your iTunes Library located (migrated) into the Drobo 5N??

If it is so… did you moved the iTunes Library into a normal Shared Folder in 5N or into the Backup/Time Machine Shared??

The Shared Folder that has Time Machine Backup enabled, should be dedicated for Time Machine use. Try not to put other files into it… Your iTunes library, Lightroom category etc… should be on another separate Shared folder.

So far, I have experienced no issue with the Time Machine Backup enable shared on 5N.

This is a Drobo5D. My iTunes library is not on the same volume as the TimeMachine volume - after clicking the “Enable Backup / Time machine Volume” button, the dashboard created a volume that I called “TimeMachine”. Then I pointed the Time Machine app to point to this volume. My iTunes library and other files are on the other volume which I call “Drobo”. In this configuration, both volumes disconnect pretty regularly. I have since disabled this feature (and the TimeMachine volume is now gone) and the problem has gone away.

I aslo note that in the Dashboard there is no way to add a volume anymore. Does your setup allow this?