Dying Thunderbolt port?


I’ve been having a devil of a time with my Mini disappearing from Dashboard, Finder, and Disk Utility.

It’s been reliably connected to my iMac for quite some time but it’s now just dropping with alarming regularity, and I can’t seem to get it to connect today.

I have tried switching the Thunderbolt ports on both the iMac and the back of the mini, and I have tried both Thunderbolt ports on a MacBook Pro - but I simply can’t get it to mount.

The disks all appear good (based on the green lights on the front) and no amount of reboots to the mini itself or either computer seem to matter.

I do have another drive connected to the Thunderbolt ports on the iMac, and it does work on both ports and is not dropping, so I am 99.999% sure it’s the Thunderbolt port on the Mini.

I suppose it could be the cable too, because that’s the only other consistent piece of hardware, but seems like a long shot for a cable to flake out and “die” but there are active circuits in there, so maybe?

I have updated the dashboard on both iMac and MBP to 3.0.1, and both are up to date in Sierra (the iMac is on 10.12.4 beta 7 and the MBP on 10.12.3 stable)

Any other ideas?

[color=#FF0000]EDIT[/color] - I realized I still had the USB3 cable that came with the Mini, plugged it in and it fired right up. So either it’s the Thunderbolt controller on the mini chassis or it’s the cable. I’m going to keep it on the USB cable for awhile and see if it’s stable before I try a new Thunderbolt cable


hi rpassavant,
i just posted on a similar thread where another user (with their 5d) had a similar issue of usb working but not thunderbolt)

it might be the thunderbolt cable like you mentioned, and trying another one will be good to test, as well as different ports if possible.

am not sure if you have tried having the drobo as the only thunderbolt-connected device (and directly attached) as a test, and it might worth trying if you get a chance, but its good that at least usb is still working


I had tried it as the only thunderbolt device (wondering of the USB3-> TB adapter I was using for another hard drive was interfering) but it made no difference

I left it running for a full week on the USB port and it was still up and running after a couple of reboots including the update to 10.12.4, so that /should/ mean it’s not the whole cabinet.

I just switched over to a new Apple branded TB cable from the included tb cable and I’ll keep an eye on the stability


ah ok, thanks for more info rpassavant,
please let us know how things go


So far, so good.

The new cable seems to be stable - no clue how the other one got fried (since both the dropbox and iMac are on a APC UPS) but seems like something went bad.


ah ok thats good to hear - fingers crossed it continues to be ok going forward


Well - that was short lived - the “Disk Not Ejected Properly” warnings are returning, which was the first symptom I had for this problem previously.

I’m starting to think it might be time to switch devices completely.


hi, can i check if your devices (computer, drobo, and ups) are all ultimately connected to the same power source/ring?

is the usb cable still ok?
if it is only the thunderbolt cable connections that seem to have the problem, is it possible that the thunderbolt port on the drobo, or the mac, are faulty (in which case have you been able to successfully test the thunderbolt cable with another device or computer), or could it be that there is some kind of voltage differential between the ups setup, and the drobo and computer, that is somehow spiking or affect it?


Yes - they are all on the same, it’s impossible for me to move them off since the whole office is on a single circuit. But I’m only having issues with the drobo

Not anymore - yesterday I was getting lots of frequent drops on the new TB cable so I switched it back to the USB and no-joy, still lots of crashes

I’ve tried now two different TB cables in both ports to two both TB ports on the iMac and the TB ports on a MacBook Pro, and the USB port to both the iMac and MBP

I think it is now just the external interface side of the mini is fully dead. It appears to boot fine (based on LED progression, and green lights for each drive) but now I can’t get it to appear in the finder or Dashboard on any computer.

I’ve got the vast majority of what was on it backed up externally so I think it’s time to just give up on the poor thing and migrate to a Synology - which I was exploring already due to other changes I’m planning for my computing environment.

I was hoping to get a full backup today to a single external drive but that doesn’t look like it’s going to happen.[hr]

Now it gets stranger - the mini is now appearing in Dashboard (and disk utility) but the volume won’t mount

I’m wondering if there is “something” I can do in the dashboard that will do “something” to the volume that will make it look fresh and new and mount just so I can get a backup?

I think I’ve got enough spare room that I could go from single disk to dual disk redundancy but I don’t think that will impact the volume being reported to Finder…[hr]

Disk utility couldn’t repair the volume, but luckily TechToolPro could, so I got it to mount - debating investing in DiskWarrior since it’s relatively cheap to ensure I can get everything off it.


ah thanks for the updates rpassavant,
if you are able to get access to diskwarrior, i think it will definitely be worth a go, as it has fixed a lot of access problems for other users of drobo and even for other mac drives too,


I was able to get all my data off and synced, I’ve seen one eject since then but I can contribute it to plugging in another drive that I was going to try and run TechToolPro on as well.

Since I’ve already purchased the Synology (to replace some functions I’m actually doing on the iMac, like Plex) I’m going to blow away the partition and rebuild it completely.

I’d originally made it 16TB with growth in mind that is now not going to occur - I started with 4x750GB drives and then upgraded to 4x2TB - so when I rebuild it I think I’ll just make the volume the “actual” size. By rebuilding from scratch all the volume data will be fresh and then I’ll know for sure if it’s going to be stable.

Then my grand plan is to daisy chain it off the USB3 port on the back of the Synology as a separate volume, which I can move to the MacBookPro over ThunderBolt when I need faster access to the Lightroom catalog (during a big import, and smart Preview build for example)


ah thanks for the update rpassavant, its good that you were able to access all the data again,

am not sure how daisy chaining via usb, off another device will go, though if you happen to have a spare usb port on your computer it might be best to directly give the mini its own comms channel, if possible.


The first issue is I’m decommissioning the computer to which it is currently attached (an iMac acting somewhat as a home server) and in my new condo I won’t have a fixed “workstation” like the iMac to which it can be connected.

Secondly, I will have a MacBook Pro but not sure I’ll be using it in a place where I could have it physically wired, so ideally I want to convert the space to another NAS volume.

But now I’ve come upon an issue with the new Drobo Dashboard - it won’t let me specify a volume size less than the 64TB maximum size supported by HFS+.

Infuriating - I know that for those anticipating growth it makes sense so you can just throw bigger drives in and the actual storage can grow towards the volume size. But I know that I won’t be adding drives anytime soon (probably never) so I want to have say a 6-8TB volume with the 5.27TB usable space. But I can’t find a way to specify volume size in Dashboard 3.0.1.

I may just sell the dang thing now that I know the issue was software volume and not a hardware problem.


oh ok,
for the part about smaller volumes, you might be able to do that with dashboard v.2.5.3
(that worked for me, at least on a 5D das model, since i preferred, and needed 2TB max volume sizes)